summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-libs/libxml/files/digest1
-rw-r--r--dev-libs/libxml/libxml-1.8.9.ebuild28
-rw-r--r--gnome-base/ORBit/ORBit-0.5.3.ebuild36
-rw-r--r--gnome-base/ORBit/files/digest1
-rw-r--r--gnome-base/bonobo/bonobo-0.18.ebuild31
-rw-r--r--gnome-base/bonobo/files/digest1
-rw-r--r--gnome-base/control-center/control-center-1.2.1.ebuild29
-rw-r--r--gnome-base/control-center/files/digest1
-rw-r--r--gnome-base/gdk-pixbuf/files/digest1
-rw-r--r--gnome-base/gdk-pixbuf/gdk-pixbuf-0.8.0.ebuild27
-rw-r--r--gnome-base/gnome-applets/files/digest1
-rw-r--r--gnome-base/gnome-applets/gnome-applets-1.2.1.ebuild27
-rw-r--r--gnome-base/gnome-core/files/digest1
-rw-r--r--gnome-base/gnome-core/gnome-core-1.2.1.ebuild28
-rw-r--r--gnome-base/gnome-libs/files/digest1
-rw-r--r--gnome-base/gnome-libs/gnome-libs-1.2.4.ebuild36
-rw-r--r--gnome-base/gnome-print/files/digest1
-rw-r--r--gnome-base/gnome-print/gnome-print-0.20.ebuild29
-rw-r--r--gnome-base/libghttp/files/digest1
-rw-r--r--gnome-base/libghttp/libghttp-1.0.6.ebuild29
-rw-r--r--gnome-base/libglade/files/digest1
-rw-r--r--gnome-base/libglade/libglade-0.14.ebuild38
-rw-r--r--gnome-base/libgtop/files/digest1
-rw-r--r--gnome-base/libgtop/libgtop-1.0.9.ebuild30
-rw-r--r--gnome-base/libxml/files/digest1
-rw-r--r--gnome-base/libxml/libxml-1.8.9.ebuild28
-rw-r--r--gnome-base/oaf/files/digest1
-rw-r--r--gnome-base/oaf/oaf-0.5.0.ebuild28
-rw-r--r--media-libs/gdk-pixbuf/files/digest1
-rw-r--r--media-libs/gdk-pixbuf/gdk-pixbuf-0.8.0.ebuild27
-rw-r--r--media-libs/imlib/files/digest1
-rw-r--r--media-libs/imlib/imlib-1.9.8.1.ebuild31
32 files changed, 498 insertions, 0 deletions
diff --git a/dev-libs/libxml/files/digest b/dev-libs/libxml/files/digest
new file mode 100644
index 000000000000..6ddf52bfdde4
--- /dev/null
+++ b/dev-libs/libxml/files/digest
@@ -0,0 +1 @@
+MD5 ad50eec1ea625071726434cc5cf9d578 libxml-1.8.9.tar.gz
diff --git a/dev-libs/libxml/libxml-1.8.9.ebuild b/dev-libs/libxml/libxml-1.8.9.ebuild
new file mode 100644
index 000000000000..d98760dad656
--- /dev/null
+++ b/dev-libs/libxml/libxml-1.8.9.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libxml/libxml-1.8.9.ebuild,v 1.1 2000/08/14 15:42:03 achim Exp $
+
+P=libxml-1.8.9
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+CATEGORY="gnome-base"
+DESCRIPTION="libxml"
+SRC_URI="ftp://ftp.gnome.org/pub/GNOME/stable/sources/libxml/"${A}
+HOMEPAGE="http://www.gnome.org/"
+
+src_compile() {
+ cd ${S}
+ LDFLAGS="-lncurses" ./configure --host=${CHOST} --prefix=/opt/gnome
+ make
+}
+
+src_install() {
+ cd ${S}
+ make install prefix=${D}/opt/gnome
+ dodoc AUTHORS COPYING* ChangeLog NEWS README
+}
+
+
+
+
diff --git a/gnome-base/ORBit/ORBit-0.5.3.ebuild b/gnome-base/ORBit/ORBit-0.5.3.ebuild
new file mode 100644
index 000000000000..7713134fdbe1
--- /dev/null
+++ b/gnome-base/ORBit/ORBit-0.5.3.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/ORBit/ORBit-0.5.3.ebuild,v 1.1 2000/08/14 15:42:02 achim Exp $
+
+P=ORBit-0.5.3
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+CATEGORY="gnome-base"
+DESCRIPTION="A high-performance, lightweight CORBA ORB aiming for CORBA 2.2 compliance"
+SRC_URI="ftp://ftp.gnome.org/pub/GNOME/stable/sources/ORBit/"${A}
+HOMEPAGE="http://www.labs.redhat.com/orbit/"
+
+src_compile() {
+ cd ${S}
+ ./configure --host=${CHOST} --prefix=/opt/gnome
+ make
+}
+
+src_install() {
+ cd ${S}
+ make prefix=${D}/opt/gnome install
+ prepinfo /opt/gnome
+
+ dodoc AUTHORS COPYING* ChangeLog README NEWS TODO
+ dodoc docs/*.txt docs/IDEA1
+ docinto idl
+ cd libIDL
+ dodoc AUTHORS BUGS COPYING NEWS README*
+ docinto popt
+ cd ../popt
+ dodoc CHANGES COPYING README
+}
+
+
+
diff --git a/gnome-base/ORBit/files/digest b/gnome-base/ORBit/files/digest
new file mode 100644
index 000000000000..e965a21a1d86
--- /dev/null
+++ b/gnome-base/ORBit/files/digest
@@ -0,0 +1 @@
+MD5 ef0e295ab0666973030c552672aaaee7 ORBit-0.5.3.tar.gz
diff --git a/gnome-base/bonobo/bonobo-0.18.ebuild b/gnome-base/bonobo/bonobo-0.18.ebuild
new file mode 100644
index 000000000000..dfc20814c947
--- /dev/null
+++ b/gnome-base/bonobo/bonobo-0.18.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/bonobo/bonobo-0.18.ebuild,v 1.1 2000/08/14 15:42:03 achim Exp $
+
+P=bonobo-0.18
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+CATEGORY="gnome-base"
+DESCRIPTION="A set of language and system independant CORBA interfaces"
+SRC_URI="ftp://ftp.gnome.org/pub/GNOME/unstable/sources/bonobo/"${A}
+HOMEPAGE="http://www.gnome.org/"
+
+src_compile() {
+ cd ${S}
+ ./configure --host=${CHOST} --prefix=/opt/gnome --with-catgets
+ make
+}
+
+src_install() {
+ cd ${S}
+ make prefix=${D}/opt/gnome install
+ dodoc AUTHORS COPYING* ChangeLog README
+ dodoc NEWS TODO
+}
+
+
+
+
+
+
diff --git a/gnome-base/bonobo/files/digest b/gnome-base/bonobo/files/digest
new file mode 100644
index 000000000000..0930977e839a
--- /dev/null
+++ b/gnome-base/bonobo/files/digest
@@ -0,0 +1 @@
+MD5 09fcbb75c38da4b39ba4c90e0ddd55ab bonobo-0.18.tar.gz
diff --git a/gnome-base/control-center/control-center-1.2.1.ebuild b/gnome-base/control-center/control-center-1.2.1.ebuild
new file mode 100644
index 000000000000..127185742e1d
--- /dev/null
+++ b/gnome-base/control-center/control-center-1.2.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/control-center/control-center-1.2.1.ebuild,v 1.1 2000/08/14 15:42:03 achim Exp $
+
+P=control-center-1.2.1
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+CATEGORY="gnome-base"
+DESCRIPTION="The GNOME control-center"
+SRC_URI="ftp://ftp.gnome.org/pub/GNOME/stable/sources/control-center/"${A}
+HOMEPAGE="http://www.gnome.org/"
+
+
+src_compile() {
+ cd ${S}
+ ./configure --host=${CHOST} --prefix=/opt/gnome
+ make
+}
+
+src_install() {
+ cd ${S}
+ make prefix=${D}/opt/gnome install
+ dodoc AUTHORS COPYING* ChangeLog README NEWS
+}
+
+
+
+
diff --git a/gnome-base/control-center/files/digest b/gnome-base/control-center/files/digest
new file mode 100644
index 000000000000..98f6ea6333f0
--- /dev/null
+++ b/gnome-base/control-center/files/digest
@@ -0,0 +1 @@
+MD5 dff1aad70637e59919f3ec57ff1bfae6 control-center-1.2.1.tar.gz
diff --git a/gnome-base/gdk-pixbuf/files/digest b/gnome-base/gdk-pixbuf/files/digest
new file mode 100644
index 000000000000..8e64bb4e155e
--- /dev/null
+++ b/gnome-base/gdk-pixbuf/files/digest
@@ -0,0 +1 @@
+MD5 2933ed5874290b80ff8c4831917e74b7 gdk-pixbuf-0.8.0.tar.gz
diff --git a/gnome-base/gdk-pixbuf/gdk-pixbuf-0.8.0.ebuild b/gnome-base/gdk-pixbuf/gdk-pixbuf-0.8.0.ebuild
new file mode 100644
index 000000000000..844ccc327eca
--- /dev/null
+++ b/gnome-base/gdk-pixbuf/gdk-pixbuf-0.8.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gdk-pixbuf/gdk-pixbuf-0.8.0.ebuild,v 1.1 2000/08/14 15:42:03 achim Exp $
+
+P=gdk-pixbuf-0.8.0
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+CATEGORY="gnome-base"
+DESCRIPTION="GNOME Image Library"
+SRC_URI="ftp://ftp.gnome.org/pub/GNOME/unstable/sources/gdk-pixbuf"${A}
+
+
+src_compile() {
+ cd ${S}
+ ./configure --host=${CHOST} --prefix=/opt/gnome
+ make
+}
+
+src_install() {
+ cd ${S}
+ make prefix=${D}/opt/gnome install
+ dodoc AUTHORS COPYING* ChangeLog INSTALL README NEWS TODO
+}
+
+
+
diff --git a/gnome-base/gnome-applets/files/digest b/gnome-base/gnome-applets/files/digest
new file mode 100644
index 000000000000..870d883c5c77
--- /dev/null
+++ b/gnome-base/gnome-applets/files/digest
@@ -0,0 +1 @@
+MD5 0e4b39e2c22a5e1ff4c56f6df1773f40 gnome-applets-1.2.1.tar.gz
diff --git a/gnome-base/gnome-applets/gnome-applets-1.2.1.ebuild b/gnome-base/gnome-applets/gnome-applets-1.2.1.ebuild
new file mode 100644
index 000000000000..9c9e0481953e
--- /dev/null
+++ b/gnome-base/gnome-applets/gnome-applets-1.2.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-applets/gnome-applets-1.2.1.ebuild,v 1.1 2000/08/14 15:42:03 achim Exp $
+
+P=gnome-applets-1.2.1
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+CATEGORY="gnome-base"
+DESCRIPTION="gnome-applets"
+SRC_URI="ftp://ftp.gnome.org/pub/GNOME/stable/sources/gnome-applets/"${A}
+HOMEPAGE="http://www.gnome.org/"
+
+src_compile() {
+ cd ${S}
+ ./configure --host=${CHOST} --prefix=/opt/gnome
+ make
+}
+
+src_install() {
+ cd ${S}
+ make prefix=${D}/opt/gnome install
+ dodoc AUTHORS COPYING* ChangeLog NEWS README
+}
+
+
+
diff --git a/gnome-base/gnome-core/files/digest b/gnome-base/gnome-core/files/digest
new file mode 100644
index 000000000000..0349ad8bc33e
--- /dev/null
+++ b/gnome-base/gnome-core/files/digest
@@ -0,0 +1 @@
+MD5 d8ac9408991bad4f2177c9a426b3c33b gnome-core-1.2.1.tar.gz
diff --git a/gnome-base/gnome-core/gnome-core-1.2.1.ebuild b/gnome-base/gnome-core/gnome-core-1.2.1.ebuild
new file mode 100644
index 000000000000..7b2f0cdfa103
--- /dev/null
+++ b/gnome-base/gnome-core/gnome-core-1.2.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-core/gnome-core-1.2.1.ebuild,v 1.1 2000/08/14 15:42:03 achim Exp $
+
+P=gnome-core-1.2.1
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+CATEGORY="gnome-base"
+DESCRIPTION="gnome-core"
+SRC_URI="ftp://ftp.gnome.org/pub/GNOME/stable/sources/gnome-core/"${A}
+HOMEPAGE="http://www.gnome.org/"
+
+src_compile() {
+ cd ${S}
+ ./configure --host=${CHOST} --prefix=/opt/gnome
+ make
+}
+
+src_install() {
+ cd ${S}
+ make prefix=${D}/opt/gnome install
+ prepman /opt/gnome
+ dodoc AUTHORS COPYING* ChangeLog README NEWS
+}
+
+
+
diff --git a/gnome-base/gnome-libs/files/digest b/gnome-base/gnome-libs/files/digest
new file mode 100644
index 000000000000..4bc859c36194
--- /dev/null
+++ b/gnome-base/gnome-libs/files/digest
@@ -0,0 +1 @@
+MD5 53c929ab70307364c1486934bf340bfc gnome-libs-1.2.4.tar.gz
diff --git a/gnome-base/gnome-libs/gnome-libs-1.2.4.ebuild b/gnome-base/gnome-libs/gnome-libs-1.2.4.ebuild
new file mode 100644
index 000000000000..62a3c5c152f6
--- /dev/null
+++ b/gnome-base/gnome-libs/gnome-libs-1.2.4.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-libs/gnome-libs-1.2.4.ebuild,v 1.1 2000/08/14 15:42:03 achim Exp $
+
+P=gnome-libs-1.2.4
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+CATEGORY="gnome-base"
+DESCRIPTION="GNOME Core Libraries"
+SRC_URI="ftp://ftp.gnome.org/pub/GNOME/stable/sources/gnome-libs/"${A}
+HOMEPAGE="http://www.gnome.org/"
+
+src_compile() {
+ cd ${S}
+ ./configure --host=${CHOST} --prefix=/opt/gnome
+ make
+}
+
+src_install() {
+ cd ${S}
+ make prefix=${D}/opt/gnome install
+ prepman /opt/gnome
+
+ into /opt/gnome
+ dodir /usr/doc/${P}
+ mv ${D}/opt/gnome/doc/* ${D}/usr/doc/${P}
+ doman ${D}/usr/doc/${P}/*.3
+ rm ${D}/usr/doc/${P}/*.3
+ gzip ${D}/usr/doc/${P}/*
+ rm -rf ${D}/opt/gnome/doc
+ dodoc AUTHORS COPYING* ChangeLog README NEWS HACKING
+}
+
+
+
diff --git a/gnome-base/gnome-print/files/digest b/gnome-base/gnome-print/files/digest
new file mode 100644
index 000000000000..1d6f1ca9b520
--- /dev/null
+++ b/gnome-base/gnome-print/files/digest
@@ -0,0 +1 @@
+MD5 1cb286ed2bd600ab16e996717904f425 gnome-print-0.20.tar.gz
diff --git a/gnome-base/gnome-print/gnome-print-0.20.ebuild b/gnome-base/gnome-print/gnome-print-0.20.ebuild
new file mode 100644
index 000000000000..d7f89b758ca9
--- /dev/null
+++ b/gnome-base/gnome-print/gnome-print-0.20.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-print/gnome-print-0.20.ebuild,v 1.1 2000/08/14 15:42:03 achim Exp $
+
+P=gnome-print-0.20
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+CATEGORY="gnome-base"
+DESCRIPTION="gnome-print"
+SRC_URI="ftp://ftp.gnome.org/pub/GNOME/stable/latest/sources/"${A}
+HOMEPAGE="http://www.gnome.org/"
+
+src_compile() {
+ cd ${S}
+ ./configure --host=${CHOST} --prefix=/opt/gnome \
+ --with-catgets
+ make
+}
+
+src_install() {
+ cd ${S}
+ make prefix=${D}/opt/gnome install
+ dodoc AUTHORS COPYING ChangeLog NEWS README TODO
+}
+
+
+
+
diff --git a/gnome-base/libghttp/files/digest b/gnome-base/libghttp/files/digest
new file mode 100644
index 000000000000..2341c24d14a4
--- /dev/null
+++ b/gnome-base/libghttp/files/digest
@@ -0,0 +1 @@
+MD5 f9428c3f6828e546697b6353e2653095 libghttp-1.0.6.tar.gz
diff --git a/gnome-base/libghttp/libghttp-1.0.6.ebuild b/gnome-base/libghttp/libghttp-1.0.6.ebuild
new file mode 100644
index 000000000000..63aa4bd11b8f
--- /dev/null
+++ b/gnome-base/libghttp/libghttp-1.0.6.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/libghttp/libghttp-1.0.6.ebuild,v 1.1 2000/08/14 15:42:03 achim Exp $
+
+P=libghttp-1.0.6
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+CATEGORY="gnome-base"
+DESCRIPTION="libghttp"
+SRC_URI="ftp://ftp.gnome.org/pub/GNOME/stable/sources/libghttp/"${A}
+HOMEPAGE="http://www.gnome.org/"
+
+src_compile() {
+ cd ${S}
+ ./configure --host=${CHOST} --prefix=/opt/gnome
+ make
+}
+
+src_install() {
+ cd ${S}
+ make prefix=${D}/opt/gnome install
+ dodoc AUTHORS COPYING* ChangeLog README NEWS TODO
+ docinto html
+ dodoc doc/ghttp.html
+}
+
+
+
diff --git a/gnome-base/libglade/files/digest b/gnome-base/libglade/files/digest
new file mode 100644
index 000000000000..f633db12ef20
--- /dev/null
+++ b/gnome-base/libglade/files/digest
@@ -0,0 +1 @@
+MD5 ac91458f0e6c827b004b662482009bae libglade-0.14.tar.gz
diff --git a/gnome-base/libglade/libglade-0.14.ebuild b/gnome-base/libglade/libglade-0.14.ebuild
new file mode 100644
index 000000000000..f96e03b1ce70
--- /dev/null
+++ b/gnome-base/libglade/libglade-0.14.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/libglade/libglade-0.14.ebuild,v 1.1 2000/08/14 15:42:03 achim Exp $
+
+P=libglade-0.14
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+CATEGORY="gnome-base"
+DESCRIPTION="libglade"
+SRC_URI="ftp://ftp.gnome.org/pub/GNOME/stable/sources/libglade/"${A}
+HOMEPAGE="http://www.gnome.org/"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ # Bonobo does not work at the moment
+ cp configure.in configure.in.orig
+ sed -e "s:have_bonobo=true:have_bonobo=false:" configure.in.orig > configure.in
+ autoconf configure.in > configure
+}
+src_compile() {
+ cd ${S}
+ ./configure --host=${CHOST} --prefix=/opt/gnome --with-catgets
+ make
+}
+
+src_install() {
+ cd ${S}
+ make prefix=${D}/opt/gnome install
+ dodoc AUTHORS COPYING* ChangeLog NEWS
+ dodoc doc/*.txt
+}
+
+
+
+
+
diff --git a/gnome-base/libgtop/files/digest b/gnome-base/libgtop/files/digest
new file mode 100644
index 000000000000..70799a7ffdd2
--- /dev/null
+++ b/gnome-base/libgtop/files/digest
@@ -0,0 +1 @@
+MD5 714ace1260fba2a6fe198c4a7672bb9e libgtop-1.0.9.tar.gz
diff --git a/gnome-base/libgtop/libgtop-1.0.9.ebuild b/gnome-base/libgtop/libgtop-1.0.9.ebuild
new file mode 100644
index 000000000000..a424cc92ba2d
--- /dev/null
+++ b/gnome-base/libgtop/libgtop-1.0.9.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/libgtop/libgtop-1.0.9.ebuild,v 1.1 2000/08/14 15:42:03 achim Exp $
+
+P=libgtop-1.0.9
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+CATEGORY="gnome-base"
+DESCRIPTION="libgtop"
+SRC_URI="ftp://ftp.gnome.org/pub/GNOME/stable/sources/libgtop/"${A}
+HOMEPAGE="http://www.gnome.org/"
+
+src_compile() {
+ cd ${S}
+ LDFLAGS="-lncurses" ./configure --host=${CHOST} --prefix=/opt/gnome
+ make
+}
+
+src_install() {
+ cd ${S}
+ make prefix=${D}/opt/gnome install
+ dodoc ABOUT-NLS AUTHORS COPYING* ChangeLog INSTALL LIBGTOP* README NEWS
+ dodoc RELNOTES*
+ doinfo doc/libgtop.info
+ prepinfo /opt/gnome
+}
+
+
+
diff --git a/gnome-base/libxml/files/digest b/gnome-base/libxml/files/digest
new file mode 100644
index 000000000000..6ddf52bfdde4
--- /dev/null
+++ b/gnome-base/libxml/files/digest
@@ -0,0 +1 @@
+MD5 ad50eec1ea625071726434cc5cf9d578 libxml-1.8.9.tar.gz
diff --git a/gnome-base/libxml/libxml-1.8.9.ebuild b/gnome-base/libxml/libxml-1.8.9.ebuild
new file mode 100644
index 000000000000..985a564c0f9d
--- /dev/null
+++ b/gnome-base/libxml/libxml-1.8.9.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/libxml/libxml-1.8.9.ebuild,v 1.1 2000/08/14 15:42:03 achim Exp $
+
+P=libxml-1.8.9
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+CATEGORY="gnome-base"
+DESCRIPTION="libxml"
+SRC_URI="ftp://ftp.gnome.org/pub/GNOME/stable/sources/libxml/"${A}
+HOMEPAGE="http://www.gnome.org/"
+
+src_compile() {
+ cd ${S}
+ LDFLAGS="-lncurses" ./configure --host=${CHOST} --prefix=/opt/gnome
+ make
+}
+
+src_install() {
+ cd ${S}
+ make install prefix=${D}/opt/gnome
+ dodoc AUTHORS COPYING* ChangeLog NEWS README
+}
+
+
+
+
diff --git a/gnome-base/oaf/files/digest b/gnome-base/oaf/files/digest
new file mode 100644
index 000000000000..e5b09e47863e
--- /dev/null
+++ b/gnome-base/oaf/files/digest
@@ -0,0 +1 @@
+MD5 6c88954b72f478209f660ba1e2cbcf96 oaf-0.5.0.tar.gz
diff --git a/gnome-base/oaf/oaf-0.5.0.ebuild b/gnome-base/oaf/oaf-0.5.0.ebuild
new file mode 100644
index 000000000000..55f9b3d726a4
--- /dev/null
+++ b/gnome-base/oaf/oaf-0.5.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/oaf/oaf-0.5.0.ebuild,v 1.1 2000/08/14 15:42:03 achim Exp $
+
+P=oaf-0.5.0
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+CATEGORY="gnome-base"
+DESCRIPTION="Object Activation Framework for GNOME"
+SRC_URI="ftp://ftp.gnome.org/pub/GNOME/unstable/sources/oaf/"${A}
+
+src_compile() {
+ cd ${S}
+ ./configure --host=${CHOST} --prefix=/opt/gnome
+ make
+}
+
+src_install() {
+ cd ${S}
+ make prefix=${D}/opt/gnome install
+ dodoc AUTHORS COPYING* ChangeLog README
+ dodoc NEWS
+}
+
+
+
+
diff --git a/media-libs/gdk-pixbuf/files/digest b/media-libs/gdk-pixbuf/files/digest
new file mode 100644
index 000000000000..8e64bb4e155e
--- /dev/null
+++ b/media-libs/gdk-pixbuf/files/digest
@@ -0,0 +1 @@
+MD5 2933ed5874290b80ff8c4831917e74b7 gdk-pixbuf-0.8.0.tar.gz
diff --git a/media-libs/gdk-pixbuf/gdk-pixbuf-0.8.0.ebuild b/media-libs/gdk-pixbuf/gdk-pixbuf-0.8.0.ebuild
new file mode 100644
index 000000000000..e83d8e2b1e72
--- /dev/null
+++ b/media-libs/gdk-pixbuf/gdk-pixbuf-0.8.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/media-libs/gdk-pixbuf/gdk-pixbuf-0.8.0.ebuild,v 1.1 2000/08/14 15:42:03 achim Exp $
+
+P=gdk-pixbuf-0.8.0
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+CATEGORY="gnome-base"
+DESCRIPTION="GNOME Image Library"
+SRC_URI="ftp://ftp.gnome.org/pub/GNOME/unstable/sources/gdk-pixbuf"${A}
+
+
+src_compile() {
+ cd ${S}
+ ./configure --host=${CHOST} --prefix=/opt/gnome
+ make
+}
+
+src_install() {
+ cd ${S}
+ make prefix=${D}/opt/gnome install
+ dodoc AUTHORS COPYING* ChangeLog INSTALL README NEWS TODO
+}
+
+
+
diff --git a/media-libs/imlib/files/digest b/media-libs/imlib/files/digest
new file mode 100644
index 000000000000..7300f31fe488
--- /dev/null
+++ b/media-libs/imlib/files/digest
@@ -0,0 +1 @@
+MD5 224948ee96653990cd96daec090a5599 imlib-1.9.8.1.tar.gz
diff --git a/media-libs/imlib/imlib-1.9.8.1.ebuild b/media-libs/imlib/imlib-1.9.8.1.ebuild
new file mode 100644
index 000000000000..44483e751f11
--- /dev/null
+++ b/media-libs/imlib/imlib-1.9.8.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/media-libs/imlib/imlib-1.9.8.1.ebuild,v 1.1 2000/08/14 15:37:06 achim Exp $
+
+P=imlib-1.9.8.1
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+CATEGORY="media-libs"
+DESCRIPTION="imlib"
+SRC_URI="ftp://ftp.gnome.org/pub/GNOME/stable/sources/imlib/"${A}
+HOMEPAGE="http://www.gnome.org/"
+
+src_compile() {
+ cd ${S}
+ ./configure --host=${CHOST} --prefix=/usr/X11R6 --sysconfdir=/etc/X11/imlib
+ make
+}
+
+src_install() {
+ cd ${S}
+ make prefix=${D}/usr/X11R6 sysconfdir=${D}/etc/X11/imlib install
+ dodoc AUTHORS COPYING* ChangeLog README
+ dodoc NEWS
+ docinto html
+ dodoc doc/*.gif doc/index.html
+}
+
+
+
+