summaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-04-12 18:35:37 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-04-12 18:35:37 +0000
commitaa3741ccb7483b340ef5f09c94b33bd65bdbfea4 (patch)
treeab37a13f226e6027b0d4988e94bee01023fadb56 /x11-wm
parentUnmasked new libpng (diff)
downloadhistorical-aa3741ccb7483b340ef5f09c94b33bd65bdbfea4.tar.gz
historical-aa3741ccb7483b340ef5f09c94b33bd65bdbfea4.tar.bz2
historical-aa3741ccb7483b340ef5f09c94b33bd65bdbfea4.zip
Recompile against newest libpng and also got rid of the ungif USE flag in favour of the gif USE flag.
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/WindowMaker/ChangeLog9
-rw-r--r--x11-wm/WindowMaker/WindowMaker-0.80.0-r3.ebuild112
-rw-r--r--x11-wm/WindowMaker/files/digest-WindowMaker-0.80.0-r3 (renamed from x11-wm/WindowMaker/files/digest-WindowMaker-0.80.0-r1)0
3 files changed, 120 insertions, 1 deletions
diff --git a/x11-wm/WindowMaker/ChangeLog b/x11-wm/WindowMaker/ChangeLog
index 826cea0e1b34..cd94b5f2945c 100644
--- a/x11-wm/WindowMaker/ChangeLog
+++ b/x11-wm/WindowMaker/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for x11-wm/WindowMaker
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/WindowMaker/ChangeLog,v 1.2 2002/04/02 19:40:16 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/WindowMaker/ChangeLog,v 1.3 2002/04/12 18:35:36 seemant Exp $
+
+*WindowMaker-0.80.0-r3 (12 Apr 2002)
+
+ 12 Apr 2002; Seemant Kulleen <seemant@gentoo.org> WindowMaker-0.80.0-r3.ebuild:
+
+ Removed the ungif USE flag in favour of the gif USE flag. Also, adjusted
+ the libpng dependency to reflect the 1.2.1 release of that library.
*WindowMaker-0.80.0-r2 (2 Apr 2002)
diff --git a/x11-wm/WindowMaker/WindowMaker-0.80.0-r3.ebuild b/x11-wm/WindowMaker/WindowMaker-0.80.0-r3.ebuild
new file mode 100644
index 000000000000..70585cba5532
--- /dev/null
+++ b/x11-wm/WindowMaker/WindowMaker-0.80.0-r3.ebuild
@@ -0,0 +1,112 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# Author Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/WindowMaker/WindowMaker-0.80.0-r3.ebuild,v 1.1 2002/04/12 18:35:37 seemant Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Window Maker"
+SRC_URI="ftp://ftp.windowmaker.org/pub/source/release/${P}.tar.gz
+ ftp://ftp.windowmaker.org/pub/source/release/WindowMaker-extra-0.1.tar.bz2"
+HOMEPAGE="http://www.windowmaker.org/"
+SLOT="0"
+DEPEND="virtual/x11
+ >=media-libs/xpm-3.4k
+ >=media-libs/tiff-3.5.5
+ x11-wm/gnustep-env
+ png? ( >=media-libs/libpng-1.2.1 )
+ jpeg? ( >=media-libs/jpeg-6b-r2 )
+ gif? ( >=media-libs/giflib-4.1.0-r3 )
+ >=media-libs/libungif-4.1.0 )"
+
+RDEPEND="nls? ( >=sys-devel/gettext-0.10.39 )"
+
+#NOTE: the default menu has the wrong path for the WMPrefs utility.
+# Needs fixing.
+
+src_compile() {
+
+ patch -p1 < ${FILESDIR}/wmfpo-80.patch
+
+ local myconf
+
+ use gnome \
+ && myconf="${myconf} --enable-gnome" \
+ || myconf="${myconf} --disable-gnome"
+
+ use kde \
+ && myconf="${myconf} --enable-kde" \
+ && export KDEDIR=/usr/kde/2 \
+ || myconf="${myconf} --disable-kde"
+
+ if [ "$WITH_MODELOCK" ] ; then
+ myconf="${myconf} --enable-modelock"
+ else
+ myconf="${myconf} --disable-modelock"
+ fi
+
+ use nls \
+ && export LINGUAS="`ls po/*.po | sed 's:po/\(.*\)\.po$:\1:'`" \
+ || myconf="${myconf} --disable-nls --disable-locale"
+
+ use gif \
+ || myconf="${myconf} --disable-gif"
+
+ use jpeg \
+ || myconf="${myconf} --disable-jpeg"
+
+ use png \
+ || myconf="${myconf} --disable-png"
+
+
+ use esd || use alsa || use oss \
+ && myconf="${myconf} --enable-sound" \
+ || myconf="${myconf} --disable-sound"
+
+ ./configure \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --sysconfdir=/etc/X11 \
+ --with-x \
+ --enable-newstyle \
+ --enable-superfluous \
+ --enable-usermenu \
+ ${myconf} || die
+
+ emake || die
+
+ # WindowMaker Extra
+ cd ../WindowMaker-extra-0.1
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info || die
+
+ make || die
+}
+
+src_install() {
+
+ make prefix=${D}/usr \
+ mandir=${D}/usr/share/man \
+ infodir=${D}/usr/share/info \
+ sysconfdir=${D}/etc/X11 \
+ GNUSTEP_LOCAL_ROOT=${D}${GNUSTEP_LOCAL_ROOT} \
+ install || die
+
+ cp -f WindowMaker/plmenu ${D}/etc/X11/WindowMaker/WMRootMenu
+
+ dodoc AUTHORS BUGFORUM BUGS ChangeLog COPYING* INSTALL* FAQ* \
+ MIRRORS README* NEWS TODO
+
+ # WindowMaker Extra
+ cd ../WindowMaker-extra-0.1
+ make prefix=${D}/usr \
+ mandir=${D}/usr/share/man \
+ infodir=${D}/usr/share/info \
+ install || die
+
+ newdoc README README.extra
+}
+
diff --git a/x11-wm/WindowMaker/files/digest-WindowMaker-0.80.0-r1 b/x11-wm/WindowMaker/files/digest-WindowMaker-0.80.0-r3
index d30375d13abb..d30375d13abb 100644
--- a/x11-wm/WindowMaker/files/digest-WindowMaker-0.80.0-r1
+++ b/x11-wm/WindowMaker/files/digest-WindowMaker-0.80.0-r3