summaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorMarinus Schraal <foser@gentoo.org>2003-01-05 12:03:33 +0000
committerMarinus Schraal <foser@gentoo.org>2003-01-05 12:03:33 +0000
commit9d458aa4378f21227a3bf8a85aa0df6030619d43 (patch)
treec9c7b812bae7fa235936f4b0c294e4bfa6eccdb1 /x11-wm
parentUpdates (diff)
downloadhistorical-9d458aa4378f21227a3bf8a85aa0df6030619d43.tar.gz
historical-9d458aa4378f21227a3bf8a85aa0df6030619d43.tar.bz2
historical-9d458aa4378f21227a3bf8a85aa0df6030619d43.zip
bugfix
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/sawfish/ChangeLog5
-rw-r--r--x11-wm/sawfish/files/sawfish-1.2-gtk+-2.2.patch11
-rw-r--r--x11-wm/sawfish/sawfish-1.2.ebuild4
3 files changed, 18 insertions, 2 deletions
diff --git a/x11-wm/sawfish/ChangeLog b/x11-wm/sawfish/ChangeLog
index 0d758f066290..43e2cae146c7 100644
--- a/x11-wm/sawfish/ChangeLog
+++ b/x11-wm/sawfish/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for x11-wm/sawfish
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/sawfish/ChangeLog,v 1.23 2002/12/31 18:55:50 chouser Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/sawfish/ChangeLog,v 1.24 2003/01/05 12:03:33 foser Exp $
+
+ 05 Jan 2003; foser <foser@gentoo.org> sawfish-1.2.ebuild :
+ gtk+-2.2 build fix provided by Andy Dustman (bug #12755)
31 Dec 2002; Chris Houser <chouser@gentoo.org> sawfish-1.0.1-r6.ebuild :
Added alpha to KEYWORDS
diff --git a/x11-wm/sawfish/files/sawfish-1.2-gtk+-2.2.patch b/x11-wm/sawfish/files/sawfish-1.2-gtk+-2.2.patch
new file mode 100644
index 000000000000..d5215adc74c9
--- /dev/null
+++ b/x11-wm/sawfish/files/sawfish-1.2-gtk+-2.2.patch
@@ -0,0 +1,11 @@
+--- sawfish-1.2-gtk2/src/gtk-style.c.orig 2002-01-10 14:29:21.000000000 -0500
++++ sawfish-1.2-gtk2/src/gtk-style.c 2003-01-04 23:16:31.000000000 -0500
+@@ -97,7 +97,7 @@
+ {
+ /* If GTK_MINOR_VERSION is not 2 we are using gtk+ 1.3.x or 2.0
+ so these two members are no more */
+-#if (GTK_MINOR_VERSION == 2)
++#if (GTK_MAJOR_VERSION == 1 && GTK_MINOR_VERSION == 2)
+ if (rc->font_name != 0)
+ printf ("(font . \"%s\")\n", rc->font_name);
+ if (rc->fontset_name != 0)
diff --git a/x11-wm/sawfish/sawfish-1.2.ebuild b/x11-wm/sawfish/sawfish-1.2.ebuild
index cc3449b213e6..b419121b2c87 100644
--- a/x11-wm/sawfish/sawfish-1.2.ebuild
+++ b/x11-wm/sawfish/sawfish-1.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/sawfish/sawfish-1.2.ebuild,v 1.8 2002/12/17 22:55:48 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/sawfish/sawfish-1.2.ebuild,v 1.9 2003/01/05 12:03:33 foser Exp $
inherit base eutils
@@ -30,6 +30,8 @@ src_unpack() {
base_src_unpack
cd ${S}; epatch ${FILESDIR}/sawfish-1.2-fullscreen.patch
+ # Fixes gtk 2.2 being detected as 1.x
+ epatch ${FILESDIR}/sawfish-1.2-gtk+-2.2.patch
}
src_compile() {