summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2012-03-10 00:08:40 +0000
committerChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2012-03-10 00:08:40 +0000
commit95abde7cc50efccf353ca5b813bdd6a661e74d83 (patch)
tree2813dd3caf107f42d21db609e971c9ab8082e2db /x11-proto/xcb-proto/xcb-proto-1.7-r1.ebuild
parentAdd support for colorhug device (diff)
downloadhistorical-95abde7cc50efccf353ca5b813bdd6a661e74d83.tar.gz
historical-95abde7cc50efccf353ca5b813bdd6a661e74d83.tar.bz2
historical-95abde7cc50efccf353ca5b813bdd6a661e74d83.zip
Works with python 3 now.
Package-Manager: portage-2.2.0_alpha89/cvs/Linux x86_64
Diffstat (limited to 'x11-proto/xcb-proto/xcb-proto-1.7-r1.ebuild')
-rw-r--r--x11-proto/xcb-proto/xcb-proto-1.7-r1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/x11-proto/xcb-proto/xcb-proto-1.7-r1.ebuild b/x11-proto/xcb-proto/xcb-proto-1.7-r1.ebuild
new file mode 100644
index 000000000000..616bd1ec806d
--- /dev/null
+++ b/x11-proto/xcb-proto/xcb-proto-1.7-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-proto/xcb-proto/xcb-proto-1.7-r1.ebuild,v 1.1 2012/03/10 00:08:40 chithanh Exp $
+
+EAPI=4
+
+inherit python xorg-2
+
+DESCRIPTION="X C-language Bindings protocol headers"
+HOMEPAGE="http://xcb.freedesktop.org/"
+EGIT_REPO_URI="git://anongit.freedesktop.org/git/xcb/proto"
+[[ ${PV} != 9999* ]] && \
+ SRC_URI="http://xcb.freedesktop.org/dist/${P}.tar.bz2"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-libs/libxml2"
+
+src_install() {
+ xorg-2_src_install
+ python_clean_installation_image
+}
+
+pkg_postinst() {
+ python_mod_optimize xcbgen
+ ewarn "Please rebuild both libxcb and xcb-util if you are upgrading from version 1.6"
+}
+
+pkg_postrm() {
+ python_mod_cleanup xcbgen
+}