summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetteri Räty <betelgeuse@gentoo.org>2009-08-16 09:18:41 +0000
committerPetteri Räty <betelgeuse@gentoo.org>2009-08-16 09:18:41 +0000
commit90f37271b118d81fb39a782f8357064f5339cc57 (patch)
treef47180ab1af33003508a8d3b0c2653ce1ba84315 /x11-plugins
parentRemove unused patch (diff)
downloadhistorical-90f37271b118d81fb39a782f8357064f5339cc57.tar.gz
historical-90f37271b118d81fb39a782f8357064f5339cc57.tar.bz2
historical-90f37271b118d81fb39a782f8357064f5339cc57.zip
Migrate to EAPI 2 in order to drop built_with_use call.
Package-Manager: portage-2.2_rc38/cvs/Linux i686
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/pidgin-hotkeys/ChangeLog8
-rw-r--r--x11-plugins/pidgin-hotkeys/pidgin-hotkeys-0.2.3.ebuild22
2 files changed, 12 insertions, 18 deletions
diff --git a/x11-plugins/pidgin-hotkeys/ChangeLog b/x11-plugins/pidgin-hotkeys/ChangeLog
index a7ed68dec600..eae7477b5143 100644
--- a/x11-plugins/pidgin-hotkeys/ChangeLog
+++ b/x11-plugins/pidgin-hotkeys/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-plugins/pidgin-hotkeys
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/pidgin-hotkeys/ChangeLog,v 1.10 2008/01/07 23:09:51 tester Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/pidgin-hotkeys/ChangeLog,v 1.11 2009/08/16 09:18:41 betelgeuse Exp $
+
+ 16 Aug 2009; Petteri Räty <betelgeuse@gentoo.org>
+ pidgin-hotkeys-0.2.3.ebuild:
+ Migrate to EAPI 2 in order to drop built_with_use call.
07 Jan 2008; <tester@gentoo.org> pidgin-hotkeys-0.2.3.ebuild:
Add missing inherit eutils for built_with_use
diff --git a/x11-plugins/pidgin-hotkeys/pidgin-hotkeys-0.2.3.ebuild b/x11-plugins/pidgin-hotkeys/pidgin-hotkeys-0.2.3.ebuild
index 3c668a4e02bb..cded1c9be739 100644
--- a/x11-plugins/pidgin-hotkeys/pidgin-hotkeys-0.2.3.ebuild
+++ b/x11-plugins/pidgin-hotkeys/pidgin-hotkeys-0.2.3.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/pidgin-hotkeys/pidgin-hotkeys-0.2.3.ebuild,v 1.10 2008/01/07 23:09:51 tester Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/pidgin-hotkeys/pidgin-hotkeys-0.2.3.ebuild,v 1.11 2009/08/16 09:18:41 betelgeuse Exp $
+
+EAPI="2"
inherit eutils
@@ -15,24 +17,12 @@ SLOT="0"
KEYWORDS="amd64 hppa ppc x86"
IUSE=""
-RDEPEND="net-im/pidgin
+RDEPEND="net-im/pidgin[gtk]
>=x11-libs/gtk+-2"
DEPEND="${RDEPEND}
dev-util/pkgconfig"
-pkg_setup() {
- if ! built_with_use net-im/pidgin gtk; then
- eerror "You need to compile net-im/pidgin with USE=gtk"
- die "Missing gtk USE flag on net-im/pidgin"
- fi
-}
-
-src_compile() {
- econf || die "econf failed"
- emake || die "emake failed"
-}
-
src_install() {
- make DESTDIR="${D}" install || die
+ emake DESTDIR="${D}" install || die
}