summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKacper Kowalik <xarthisius@gentoo.org>2010-09-09 09:33:43 +0000
committerKacper Kowalik <xarthisius@gentoo.org>2010-09-09 09:33:43 +0000
commit805ecd99ffc389bcaac53957cfe0109b947d1c48 (patch)
tree301b1666c31e3513c40934f75276fe47ca2b5331 /x11-misc
parentPort to EAPI 3, correct runtime and build-time dependencies, make it respect ... (diff)
downloadhistorical-805ecd99ffc389bcaac53957cfe0109b947d1c48.tar.gz
historical-805ecd99ffc389bcaac53957cfe0109b947d1c48.tar.bz2
historical-805ecd99ffc389bcaac53957cfe0109b947d1c48.zip
Respect LDFLAGS wrt bug 336546. Thanks to Diego for the report. Fix implicit function declarations.
Package-Manager: portage-2.2_rc77/cvs/Linux x86_64
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/unclutter/ChangeLog11
-rw-r--r--x11-misc/unclutter/Manifest3
-rw-r--r--x11-misc/unclutter/unclutter-8-r2.ebuild37
3 files changed, 48 insertions, 3 deletions
diff --git a/x11-misc/unclutter/ChangeLog b/x11-misc/unclutter/ChangeLog
index e049769294ae..3c4465f9b834 100644
--- a/x11-misc/unclutter/ChangeLog
+++ b/x11-misc/unclutter/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for x11-misc/unclutter
-# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/unclutter/ChangeLog,v 1.24 2007/07/22 03:41:55 dberkholz Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/unclutter/ChangeLog,v 1.25 2010/09/09 09:33:43 xarthisius Exp $
+
+*unclutter-8-r2 (09 Sep 2010)
+
+ 09 Sep 2010; Kacper Kowalik <xarthisius@gentoo.org>
+ +unclutter-8-r2.ebuild:
+ Respect LDFLAGS wrt bug 336546. Thanks to Diego for the report. Fix
+ implicit function declarations.
22 Jul 2007; Donnie Berkholz <dberkholz@gentoo.org>;
unclutter-8-r1.ebuild:
diff --git a/x11-misc/unclutter/Manifest b/x11-misc/unclutter/Manifest
index b8937876baa2..87feb012f6e6 100644
--- a/x11-misc/unclutter/Manifest
+++ b/x11-misc/unclutter/Manifest
@@ -1,4 +1,5 @@
DIST unclutter-8.tar.Z 12344 RMD160 a78b6e148e7eea8f33b6fe0d6db3ad570889770d SHA1 726e829b41e9cb4d6a14cd91ca7efa02125be2be SHA256 b855a78d4465ab2f86287eacac63a73f1504b08522840aa37718776e7ec9192a
EBUILD unclutter-8-r1.ebuild 856 RMD160 43c668426e403791b08a48b649d3db9a038cd2d5 SHA1 7c59f272359f8598d614baca84eb2a372e265385 SHA256 7d9e0246e6ee45a2e1f6c2e502cf01da31a7ee440ba376788e068f70f6c67a7e
-MISC ChangeLog 2845 RMD160 c09abc8e658b7d698a618956e39402f7a9b921df SHA1 229e1fb179bb448110c6905f54d330ec75480a7b SHA256 5b460ab31b3266ee4f5b81896ebb91faa5a62af80aa9d573558df0056954a76c
+EBUILD unclutter-8-r2.ebuild 935 RMD160 3f2cf47f4dbfe868028f7ea91460713bdefe9618 SHA1 e7c96e7cd7bf7197394af5588cbf4298e449a3b1 SHA256 dee224457b2b400871d9f5787cd944c115ce74c32a07844bbcfc7ce6423cd12f
+MISC ChangeLog 3062 RMD160 2555207b2f4c5f78a541263e246f930f201532ef SHA1 63e6cf1f44819f3a5129a406bf55aefc84dbcbda SHA256 b4e65d9396a046c47a5addb9cf497fa380d80ac5c8551d70a42e05eb2185d73a
MISC metadata.xml 165 RMD160 4ebc1c537fcebcb28586a47c958a7d0237f3bbcc SHA1 87fed26b774e4dd2226bea04c4bcc8ba39fcc4c3 SHA256 d7da9ed29b7afb87ac00580d48a49d248f89c92269e9a7791782dc72f4490aec
diff --git a/x11-misc/unclutter/unclutter-8-r2.ebuild b/x11-misc/unclutter/unclutter-8-r2.ebuild
new file mode 100644
index 000000000000..6fcfb4c0d3f5
--- /dev/null
+++ b/x11-misc/unclutter/unclutter-8-r2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/unclutter/unclutter-8-r2.ebuild,v 1.1 2010/09/09 09:33:43 xarthisius Exp $
+
+EAPI=2
+
+inherit toolchain-funcs
+
+DESCRIPTION="Hides mouse pointer while not in use."
+HOMEPAGE="http://www.ibiblio.org/pub/X11/contrib/utilities/unclutter-8.README"
+SRC_URI="ftp://ftp.x.org/contrib/utilities/${P}.tar.Z"
+
+SLOT="0"
+LICENSE="public-domain"
+KEYWORDS="~alpha ~amd64 ~hppa ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND="x11-libs/libX11"
+DEPEND="${RDEPEND}
+ x11-proto/xproto"
+
+S=${WORKDIR}/${PN}
+
+src_prepare() {
+ sed -i -e "/stdio/ a #include <stdlib.h>" unclutter.c || die #implictits
+}
+
+src_compile() {
+ emake CDEBUGFLAGS="${CFLAGS}" CC="$(tc-getCC)" \
+ LDOPTIONS="${LDFLAGS}" || die
+}
+
+src_install () {
+ dobin unclutter || die
+ newman unclutter.man unclutter.1x || die
+ dodoc README || die
+}