summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2003-05-30 09:11:23 +0000
committerSeemant Kulleen <seemant@gentoo.org>2003-05-30 09:11:23 +0000
commite0a3f47e5337ee144eaf7fe59084e29551764b50 (patch)
tree2fefb45d5e4174e909e67522192610faf119aef8 /x11-misc/xaos
parentversion bump and removal of ggi support (diff)
downloadhistorical-e0a3f47e5337ee144eaf7fe59084e29551764b50.tar.gz
historical-e0a3f47e5337ee144eaf7fe59084e29551764b50.tar.bz2
historical-e0a3f47e5337ee144eaf7fe59084e29551764b50.zip
version bump and removal of ggi support
Diffstat (limited to 'x11-misc/xaos')
-rw-r--r--x11-misc/xaos/Manifest6
-rw-r--r--x11-misc/xaos/files/digest-xaos-3.11
-rw-r--r--x11-misc/xaos/xaos-3.1.ebuild59
-rw-r--r--x11-misc/xaos/xaos-3.1_pre5.ebuild22
4 files changed, 74 insertions, 14 deletions
diff --git a/x11-misc/xaos/Manifest b/x11-misc/xaos/Manifest
index 0055540d9c36..0301b7d83b28 100644
--- a/x11-misc/xaos/Manifest
+++ b/x11-misc/xaos/Manifest
@@ -1,5 +1,5 @@
-MD5 d591c2534efe104faf6d73796c67ff31 xaos-3.1_pre5.ebuild 1573
-MD5 233d38e37c8d30e6b3dd6e2594ea7980 xaos-3.1.ebuild 1661
-MD5 bc7f8dc3abf209673261f2d58efc97df ChangeLog 465
+MD5 70aeff241952871f8f16ad241bfd9f1a xaos-3.1_pre5.ebuild 1575
+MD5 b17179d0ff5843279480ca9c846144c0 xaos-3.1.ebuild 1665
+MD5 abdb9426a745f5f20bfa3244b8544304 ChangeLog 713
MD5 f15bb8d89c74bd6168e7e67b16b789d4 files/digest-xaos-3.1 61
MD5 94464bc3f5d2a609e7c9df60b40e022f files/digest-xaos-3.1_pre5 65
diff --git a/x11-misc/xaos/files/digest-xaos-3.1 b/x11-misc/xaos/files/digest-xaos-3.1
new file mode 100644
index 000000000000..70a1995ab8d6
--- /dev/null
+++ b/x11-misc/xaos/files/digest-xaos-3.1
@@ -0,0 +1 @@
+MD5 0da770514374f41a10d0af8e528804e2 XaoS-3.1.tar.gz 1182143
diff --git a/x11-misc/xaos/xaos-3.1.ebuild b/x11-misc/xaos/xaos-3.1.ebuild
new file mode 100644
index 000000000000..2f8fb6cd6dd6
--- /dev/null
+++ b/x11-misc/xaos/xaos-3.1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xaos/xaos-3.1.ebuild,v 1.1 2003/05/30 09:11:21 seemant Exp $
+
+IUSE="X svga aalib ggi"
+
+MY_PN=XaoS
+MY_P=${MY_PN}-${PV}
+
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="A very fast real-time fractal zoomer"
+HOMEPAGE="http://sourceforge.net/projects/xaos/"
+SRC_URI="mirror://sourceforge/xaos/${MY_P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+
+DEPEND="X? ( virtual/x11 )
+ svga? ( >=media-libs/svgalib-1.4.3 )
+ aalib? ( media-libs/aalib )
+ sys-libs/zlib
+ media-libs/libpng"
+# xaos has ggi support, but it doesn't build
+# ggi? ( media-libs/libggi )
+
+
+src_compile() {
+ local myconf
+ use X || myconf="--with-x11-driver=no"
+# use dga || myconf="${myconf} --with-dga-driver=no"
+# ggi support removed due to upstream bug
+ #use ggi ||
+ myconf="${myconf} --with-ggi-driver=no"
+ use svga || myconf="${myconf} --with-svga-driver=no"
+# use aalib || myconf="${myconf} --with-aa-driver=no"
+
+ #i18n support is quite broken in XaoS, it gets installed
+ #anyway, so we remove it later during install if not desired
+ use nls || myconf="${myconf} --with-i18n=no"
+
+ ./configure --prefix=/usr ${myconf} && make || die
+}
+
+src_install() {
+ # these get installed, assuming that the directories exist!
+ mkdir -p ${D}/usr/share/locale/{hu,es,fr,cs,de}/LC_MESSAGES
+ mkdir -p ${D}/usr/share/{man,info}
+ make \
+ prefix=${D}/usr \
+ infodir=${D}/usr/share/info \
+ mandir=${D}/usr/share/man \
+ LOCALEDIR=${D}/usr/share/locale \
+ install || die
+
+ use nls || rm -r ${D}/usr/share/locale
+
+ dodoc ChangeLog* COPYING INSTALL* TODO*
+}
diff --git a/x11-misc/xaos/xaos-3.1_pre5.ebuild b/x11-misc/xaos/xaos-3.1_pre5.ebuild
index 5f8143bb83cd..e37a23c28821 100644
--- a/x11-misc/xaos/xaos-3.1_pre5.ebuild
+++ b/x11-misc/xaos/xaos-3.1_pre5.ebuild
@@ -1,26 +1,24 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/xaos/xaos-3.1_pre5.ebuild,v 1.2 2003/04/06 07:10:14 george Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xaos/xaos-3.1_pre5.ebuild,v 1.3 2003/05/30 09:11:21 seemant Exp $
-IUSE="X svga aalib ggi"
+IUSE="X svga aalib"
-PN=XaoS
-PV=3.1pre5
-P=${PN}-${PV}
-S=${WORKDIR}/${P}
+MY_PN="XaoS"
+MY_P=${MY_PN}-${PV/_/}
+S=${WORKDIR}/${MY_P}
DESCRIPTION="A very fast real-time fractal zoomer"
HOMEPAGE="http://sourceforge.net/projects/xaos/"
-SRC_URI="mirror://sourceforge/xaos/${P}.tar.gz"
+SRC_URI="mirror://sourceforge/xaos/${MY_P}.tar.gz"
-KEYWORDS="x86"
-LICENSE="GPL-2"
SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86"
DEPEND="X? ( virtual/x11 )
svga? ( >=media-libs/svgalib-1.4.3 )
aalib? ( media-libs/aalib )
- ggi? ( media-libs/libggi )
sys-libs/zlib
media-libs/libpng"
@@ -29,7 +27,9 @@ src_compile() {
local myconf
use X || myconf="--with-x11-driver=no"
# use dga || myconf="${myconf} --with-dga-driver=no"
- use ggi || myconf="${myconf} --with-ggi-driver=no"
+
+# ggi support is broken
+# use ggi || myconf="${myconf} --with-ggi-driver=no"
use svga || myconf="${myconf} --with-svga-driver=no"
# use aalib || myconf="${myconf} --with-aa-driver=no"