summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2010-08-11 13:41:36 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2010-08-11 13:41:36 +0000
commit8ae73553c166d06f30d0da2538af80e630ac9204 (patch)
tree1b67aa205d02bceb0deb913f8b94e65bb01686b4 /x11-misc/dragbox/dragbox-0.4.0.ebuild
parentRespect LDFLAGS (Bug #331873) (diff)
downloadhistorical-8ae73553c166d06f30d0da2538af80e630ac9204.tar.gz
historical-8ae73553c166d06f30d0da2538af80e630ac9204.tar.bz2
historical-8ae73553c166d06f30d0da2538af80e630ac9204.zip
Moved from sunrise overaly. Thanks to Chad A. Simmons <chad.simmons@member.fsf.org> for the initial ebuild. Fixes bug #237944
Package-Manager: portage-2.2_rc67/cvs/Linux x86_64
Diffstat (limited to 'x11-misc/dragbox/dragbox-0.4.0.ebuild')
-rw-r--r--x11-misc/dragbox/dragbox-0.4.0.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/x11-misc/dragbox/dragbox-0.4.0.ebuild b/x11-misc/dragbox/dragbox-0.4.0.ebuild
new file mode 100644
index 000000000000..7b647d6374e0
--- /dev/null
+++ b/x11-misc/dragbox/dragbox-0.4.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/dragbox/dragbox-0.4.0.ebuild,v 1.1 2010/08/11 13:41:36 hwoarang Exp $
+
+EAPI="2"
+
+PYTHON_DEPEND="2"
+inherit python
+
+DESCRIPTION="GTK tool for connecting the commandline with the desktop environment"
+HOMEPAGE="http://kaizer.se/wiki/dragbox/"
+SRC_URI="http://kaizer.se/publicfiles/${PN}/${P}.tar.gz"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/pygtk
+ gnome-base/libglade
+ dev-python/gnome-vfs-python
+ dev-python/libgnome-python
+ dev-python/gconf-python
+ sys-apps/dbus
+ x11-libs/gtk+"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog NEWS README TODO || die "dodoc failed"
+}
+
+pkg_postinst() {
+ python_mod_optimize $(python_get_sitedir)/Dragbox
+}
+
+pkg_postrm() {
+ python_mod_cleanup $(python_get_sitedir)/Dragbox
+}