summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-02-20 12:25:42 +0000
committerMike Frysinger <vapier@gentoo.org>2003-02-20 12:25:42 +0000
commit513effcc8643f233530edbb17e8a1e0c6149e985 (patch)
treed613cbb4956207c23290d09d55f01e8fc9b1d3a7 /x11-libs
parentinitial import for e17 seperation (diff)
downloadhistorical-513effcc8643f233530edbb17e8a1e0c6149e985.tar.gz
historical-513effcc8643f233530edbb17e8a1e0c6149e985.tar.bz2
historical-513effcc8643f233530edbb17e8a1e0c6149e985.zip
initial import for e17 seperation
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/ecore/ChangeLog15
-rw-r--r--x11-libs/ecore/ecore-0.0.2.20030220.ebuild38
-rw-r--r--x11-libs/ecore/ecore-0.0.2.ebuild36
-rw-r--r--x11-libs/ecore/files/0.0.2/ecore-0.0.2-cxxfix.patch43
-rw-r--r--x11-libs/ecore/files/digest-ecore-0.0.21
-rw-r--r--x11-libs/ecore/files/digest-ecore-0.0.2.200302201
-rw-r--r--x11-libs/eprog/ChangeLog8
-rw-r--r--x11-libs/eprog/eprog-0.0.0.20030220.ebuild39
-rw-r--r--x11-libs/eprog/files/digest-eprog-0.0.0.200302201
9 files changed, 91 insertions, 91 deletions
diff --git a/x11-libs/ecore/ChangeLog b/x11-libs/ecore/ChangeLog
index fedee265f3f5..931947f89854 100644
--- a/x11-libs/ecore/ChangeLog
+++ b/x11-libs/ecore/ChangeLog
@@ -1,15 +1,8 @@
# ChangeLog for x11-libs/ecore
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/ecore/ChangeLog,v 1.4 2003/02/12 09:22:20 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/ecore/ChangeLog,v 1.5 2003/02/20 12:24:01 vapier Exp $
- 06 Dec 2002; Rodney Rees <manson@gentoo.org> : changed sparc ~sparc keywords
-
-*ecore-0.0.2 (20 Apr 2002)
+*ecore-0.0.2.20030220 (20 Feb 2003)
- 20 Apr 2002; Leigh Dyer <lsd@linuxgamers.net> ecore-0.0.2.ebuild :
-
- Ecore is the core event abstraction layer and X abstraction layer that makes
- doing selections, Xdnd, general X stuff, and event loops, timeouts and idle
- handlers fast, optimized, and convenient. it's a separate library so anyone
- can make use of the work put into Ecore to make this job easy for
- applications.
+ 20 Feb 2003; Mike Frysinger <vapier@gentoo.org> :
+ Initial import. Ebuild submitted by me.
diff --git a/x11-libs/ecore/ecore-0.0.2.20030220.ebuild b/x11-libs/ecore/ecore-0.0.2.20030220.ebuild
new file mode 100644
index 000000000000..fa829d70ed15
--- /dev/null
+++ b/x11-libs/ecore/ecore-0.0.2.20030220.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/ecore/ecore-0.0.2.20030220.ebuild,v 1.1 2003/02/20 12:24:01 vapier Exp $
+
+DESCRIPTION="core event abstraction layer and X abstraction layer (nice convenience library)"
+HOMEPAGE="http://www.enlightenment.org/pages/ecore.html"
+SRC_URI="mirror://gentoo/${P}.tar.bz2
+ http://wh0rd.tk/gentoo/distfiles/${P}.tar.bz2"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="pic"
+
+DEPEND="virtual/x11
+ virtual/glibc
+ sys-devel/gcc"
+
+S=${WORKDIR}/${PN}
+
+pkg_setup() {
+ # the stupid gettextize script prevents non-interactive mode, so we hax it
+ cp `which gettextize` ${T} || die "could not copy gettextize"
+ cp ${T}/gettextize ${T}/gettextize.old
+ sed -e 's:read dummy < /dev/tty::' ${T}/gettextize.old > ${T}/gettextize
+}
+
+src_compile() {
+ env PATH="${T}:${PATH}" WANT_AUTOCONF_2_5=1 NOCONFIGURE=yes ./autogen.sh || die
+ econf `use_with pic` --with-gnu-ld || die
+ emake || die
+}
+
+src_install() {
+ make install DESTDIR=${D} || die
+ dodoc AUTHORS ChangeLog NEWS README
+ dohtml -r doc
+}
diff --git a/x11-libs/ecore/ecore-0.0.2.ebuild b/x11-libs/ecore/ecore-0.0.2.ebuild
deleted file mode 100644
index 2467b82ad5bf..000000000000
--- a/x11-libs/ecore/ecore-0.0.2.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/ecore/ecore-0.0.2.ebuild,v 1.8 2003/02/13 16:55:02 vapier Exp $
-
-S=${WORKDIR}/${P}
-DESCRIPTION="Convenience library for Xlib from the enlightenment project"
-SRC_URI="mirror://sourceforge/enlightenment/${P}.tar.gz"
-HOMEPAGE="http://www.enlightenment.org"
-LICENSE="as-is"
-SLOT="0"
-KEYWORDS="x86 sparc "
-
-DEPEND="x11-base/xfree"
-
-src_unpack() {
- unpack ${A}
- cd ${S}
- # This patch fixes a function prototype that breaks C++ compilation
- patch -p1 < ${FILESDIR}/${PVR}/ecore-0.0.2-cxxfix.patch || die
-}
-
-src_compile() {
- ./configure \
- --host=${CHOST} \
- --prefix=/usr \
- --infodir=/usr/share/info \
- --mandir=/usr/share/man || die "./configure failed"
-
- emake || die
-}
-
-src_install () {
- make DESTDIR=${D} install || die
-
- dodoc README AUTHORS
-}
diff --git a/x11-libs/ecore/files/0.0.2/ecore-0.0.2-cxxfix.patch b/x11-libs/ecore/files/0.0.2/ecore-0.0.2-cxxfix.patch
deleted file mode 100644
index 2121151b9f45..000000000000
--- a/x11-libs/ecore/files/0.0.2/ecore-0.0.2-cxxfix.patch
+++ /dev/null
@@ -1,43 +0,0 @@
-diff -U2 -r ecore-0.0.2/src/Ecore.h ecore-0.0.2-lsd/src/Ecore.h
---- ecore-0.0.2/src/Ecore.h Sun Apr 8 12:00:39 2001
-+++ ecore-0.0.2-lsd/src/Ecore.h Sat Apr 13 21:14:31 2002
-@@ -21,4 +21,8 @@
- #endif
-
-+#ifdef __cplusplus
-+extern "C" {
-+#endif
-+
- #define XEV_NONE NoEventMask
- #define XEV_KEY KeyPressMask | KeyReleaseMask
-@@ -205,5 +209,5 @@
- void e_window_set_name_class(Window win, char *name,
-
-- char *class);
-+ char *e_class);
- void e_window_set_min_size(Window win, int w, int h);
- void e_window_set_max_size(Window win, int w, int h);
-@@ -771,3 +775,7 @@
- double e_get_time(void);
-
-+#ifdef __cplusplus
-+}
-+#endif
-+
- #endif
-diff -U2 -r ecore-0.0.2/src/e_x.c ecore-0.0.2-lsd/src/e_x.c
---- ecore-0.0.2/src/e_x.c Sun Apr 8 12:00:26 2001
-+++ ecore-0.0.2-lsd/src/e_x.c Sat Apr 13 20:51:33 2002
-@@ -2213,10 +2213,10 @@
-
- void
--e_window_set_name_class(Window win, char *name, char *class)
-+e_window_set_name_class(Window win, char *name, char *e_class)
- {
- XClassHint hint;
-
- hint.res_name = name;
-- hint.res_class = class;
-+ hint.res_class = e_class;
- XSetClassHint(disp, win, &hint);
- }
diff --git a/x11-libs/ecore/files/digest-ecore-0.0.2 b/x11-libs/ecore/files/digest-ecore-0.0.2
deleted file mode 100644
index 07320ccd230e..000000000000
--- a/x11-libs/ecore/files/digest-ecore-0.0.2
+++ /dev/null
@@ -1 +0,0 @@
-MD5 544fc26bbf996e1e15430fb31d212c2a ecore-0.0.2.tar.gz 146515
diff --git a/x11-libs/ecore/files/digest-ecore-0.0.2.20030220 b/x11-libs/ecore/files/digest-ecore-0.0.2.20030220
new file mode 100644
index 000000000000..6c84d79f5eed
--- /dev/null
+++ b/x11-libs/ecore/files/digest-ecore-0.0.2.20030220
@@ -0,0 +1 @@
+MD5 eb80f9f41657243218be3e9b7f4a4fcf ecore-0.0.2.20030220.tar.bz2 57028
diff --git a/x11-libs/eprog/ChangeLog b/x11-libs/eprog/ChangeLog
new file mode 100644
index 000000000000..b8151601a447
--- /dev/null
+++ b/x11-libs/eprog/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for x11-libs/eprog
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/eprog/ChangeLog,v 1.1 2003/02/20 12:25:42 vapier Exp $
+
+*eprog-0.0.0.20030220 (20 Feb 2003)
+
+ 20 Feb 2003; Mike Frysinger <vapier@gentoo.org> :
+ Initial import. Ebuild submitted by me.
diff --git a/x11-libs/eprog/eprog-0.0.0.20030220.ebuild b/x11-libs/eprog/eprog-0.0.0.20030220.ebuild
new file mode 100644
index 000000000000..757a4cec0db1
--- /dev/null
+++ b/x11-libs/eprog/eprog-0.0.0.20030220.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/eprog/eprog-0.0.0.20030220.ebuild,v 1.1 2003/02/20 12:25:42 vapier Exp $
+
+DESCRIPTION="convenience library for evas2"
+HOMEPAGE="http://www.rephorm.com/rephorm/code/eprog/"
+SRC_URI="mirror://gentoo/${P}.tar.bz2
+ http://wh0rd.tk/gentoo/distfiles/${P}.tar.bz2"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="pic"
+
+DEPEND="virtual/x11
+ virtual/glibc
+ sys-devel/gcc
+ >=x11-libs/evas-1.0.0.2003*
+ >=x11-libs/ecore-0.0.2.2003*"
+
+S=${WORKDIR}/${PN}
+
+pkg_setup() {
+ # the stupid gettextize script prevents non-interactive mode, so we hax it
+ cp `which gettextize` ${T} || die "could not copy gettextize"
+ cp ${T}/gettextize ${T}/gettextize.old
+ sed -e 's:read dummy < /dev/tty::' ${T}/gettextize.old > ${T}/gettextize
+}
+
+src_compile() {
+ env PATH="${T}:${PATH}" WANT_AUTOCONF_2_5=1 NOCONFIGURE=yes ./autogen.sh || die
+ econf `use_with pic` --with-gnu-ld || die
+ emake || die
+}
+
+src_install() {
+ make install DESTDIR=${D} || die
+ dodoc AUTHORS ChangeLog NEWS README
+}
diff --git a/x11-libs/eprog/files/digest-eprog-0.0.0.20030220 b/x11-libs/eprog/files/digest-eprog-0.0.0.20030220
new file mode 100644
index 000000000000..efd96f7a250c
--- /dev/null
+++ b/x11-libs/eprog/files/digest-eprog-0.0.0.20030220
@@ -0,0 +1 @@
+MD5 4249afe8b8c6f2793f7e9db45678131b eprog-0.0.0.20030220.tar.bz2 161593