summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2008-06-05 21:10:21 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2008-06-05 21:10:21 +0000
commitbc8c19766eb7a93c467f4424166fa6dd3f59116f (patch)
tree15acad0390e326366b69334e0a04c76f30718b59 /x11-libs/vte
parentAdded the KDE 4.0.5 version of kbruch. (diff)
downloadhistorical-bc8c19766eb7a93c467f4424166fa6dd3f59116f.tar.gz
historical-bc8c19766eb7a93c467f4424166fa6dd3f59116f.tar.bz2
historical-bc8c19766eb7a93c467f4424166fa6dd3f59116f.zip
bump to 0.16.14. Bug fixes.
Package-Manager: portage-2.1.5.4
Diffstat (limited to 'x11-libs/vte')
-rw-r--r--x11-libs/vte/ChangeLog7
-rw-r--r--x11-libs/vte/vte-0.16.14.ebuild57
2 files changed, 63 insertions, 1 deletions
diff --git a/x11-libs/vte/ChangeLog b/x11-libs/vte/ChangeLog
index 06c93222831b..6bdba37a9560 100644
--- a/x11-libs/vte/ChangeLog
+++ b/x11-libs/vte/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-libs/vte
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/vte/ChangeLog,v 1.203 2008/05/08 14:32:23 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/vte/ChangeLog,v 1.204 2008/06/05 21:10:21 eva Exp $
+
+*vte-0.16.14 (05 Jun 2008)
+
+ 05 Jun 2008; Gilles Dartiguelongue <eva@gentoo.org> +vte-0.16.14.ebuild:
+ bump to 0.16.14. Bug fixes.
08 May 2008; Gilles Dartiguelongue <eva@gentoo.org>
-files/vte-0.16.6-cursor-modifers-to-csi.patch, -vte-0.16.9.ebuild,
diff --git a/x11-libs/vte/vte-0.16.14.ebuild b/x11-libs/vte/vte-0.16.14.ebuild
new file mode 100644
index 000000000000..191aa0dd2ab1
--- /dev/null
+++ b/x11-libs/vte/vte-0.16.14.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/vte/vte-0.16.14.ebuild,v 1.1 2008/06/05 21:10:21 eva Exp $
+
+inherit eutils gnome2 autotools
+
+DESCRIPTION="Gnome terminal widget"
+HOMEPAGE="http://www.gnome.org/"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+# pcre is broken in this release
+IUSE="debug doc python opengl"
+
+RDEPEND=">=dev-libs/glib-2.9
+ >=x11-libs/gtk+-2.6
+ >=x11-libs/pango-1.1
+ >=media-libs/freetype-2.0.2
+ media-libs/fontconfig
+ sys-libs/ncurses
+ opengl? (
+ virtual/opengl
+ virtual/glu
+ )
+ python? (
+ >=dev-python/pygtk-2.4
+ >=dev-lang/python-2.4.4-r5
+ )
+ x11-libs/libX11
+ virtual/xft"
+
+DEPEND="${RDEPEND}
+ doc? ( >=dev-util/gtk-doc-1.0 )
+ >=dev-util/intltool-0.35
+ >=dev-util/pkgconfig-0.9
+ sys-devel/gettext"
+
+DOCS="AUTHORS ChangeLog HACKING NEWS README"
+
+pkg_setup() {
+ G2CONF="${G2CONF}
+ $(use_enable debug)
+ $(use_enable python)
+ $(use_with opengl glX)
+ --with-xft2 --with-pangox"
+}
+
+src_unpack() {
+ gnome2_src_unpack
+
+ epatch "${FILESDIR}/${PN}-0.13.2-no-lazy-bindings.patch"
+ cd "${S}/gnome-pty-helper"
+
+ # eautoreconf will break on systems without gtk-doc
+ eautomake
+}