summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2002-11-23 07:26:34 +0000
committerMike Frysinger <vapier@gentoo.org>2002-11-23 07:26:34 +0000
commit3797ef355e459c887411a007cf5be8f3d0f7c7f7 (patch)
tree720c8819a44526edcf352b419574bdb5027cd630 /x11-libs/guile-gtk
parenttouch ups (diff)
downloadhistorical-3797ef355e459c887411a007cf5be8f3d0f7c7f7.tar.gz
historical-3797ef355e459c887411a007cf5be8f3d0f7c7f7.tar.bz2
historical-3797ef355e459c887411a007cf5be8f3d0f7c7f7.zip
small fix
Diffstat (limited to 'x11-libs/guile-gtk')
-rw-r--r--x11-libs/guile-gtk/ChangeLog9
-rw-r--r--x11-libs/guile-gtk/files/guile-gtk-0.19-Makefile.in.patch11
-rw-r--r--x11-libs/guile-gtk/guile-gtk-0.19.ebuild7
3 files changed, 21 insertions, 6 deletions
diff --git a/x11-libs/guile-gtk/ChangeLog b/x11-libs/guile-gtk/ChangeLog
index 809dfa998342..4502a337572d 100644
--- a/x11-libs/guile-gtk/ChangeLog
+++ b/x11-libs/guile-gtk/ChangeLog
@@ -1,8 +1,11 @@
# ChangeLog for x11-libs/guile-gtk
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/guile-gtk/ChangeLog,v 1.1 2002/10/23 19:36:28 spider Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/guile-gtk/ChangeLog,v 1.2 2002/11/23 07:26:34 vapier Exp $
*guile-gtk-0.19 (23 Oct 2002)
- 23 Oct 2002; Spider <spider@gentoo.org> guile-gtk-0.19.ebuild :initial
- release, package provided by <jonner@mailandnews.com> " Jonathan Rogers" And edited by me.
+ 23 Nov 2002; Mike Frysinger <vapier@gentoo.org> :
+ Added a small patch so that guile-snarf is passed the file as 1st parm
+
+ 23 Oct 2002; Spider <spider@gentoo.org> guile-gtk-0.19.ebuild :
+ initial release, package provided by <jonner@mailandnews.com> " Jonathan Rogers" And edited by me.
diff --git a/x11-libs/guile-gtk/files/guile-gtk-0.19-Makefile.in.patch b/x11-libs/guile-gtk/files/guile-gtk-0.19-Makefile.in.patch
new file mode 100644
index 000000000000..05d89adbe5ba
--- /dev/null
+++ b/x11-libs/guile-gtk/files/guile-gtk-0.19-Makefile.in.patch
@@ -0,0 +1,11 @@
+--- Makefile.in.orig 2000-07-26 19:24:58.000000000 -0400
++++ Makefile.in 2002-11-23 02:20:43.000000000 -0500
+@@ -617,7 +617,7 @@
+ $(INSTALL_DATA) ./gtk/config.scm $(gtkmoduledir)/config.scm
+ $(INSTALL_DATA) $(srcdir)/gtk/event-repl.scm $(gtkmoduledir)/event-repl.scm
+ .c.x:
+- guile-snarf $(DEFS) $(INCLUDES) $(CPPFLAGS) $(CFLAGS) $< >$<.tmp && mv $<.tmp $@
++ guile-snarf $< $(DEFS) $(INCLUDES) $(CPPFLAGS) $(CFLAGS) >$<.tmp && mv $<.tmp $@
+
+ gtk-glue.c: $(gtkdefs) $(gdkdefs) build-guile-gtk
+ $(BUILD) -I $(srcdir) glue $(gtkdefs) >tmpt && mv tmpt $@
diff --git a/x11-libs/guile-gtk/guile-gtk-0.19.ebuild b/x11-libs/guile-gtk/guile-gtk-0.19.ebuild
index e4954c8d42c7..3e0d6844abfe 100644
--- a/x11-libs/guile-gtk/guile-gtk-0.19.ebuild
+++ b/x11-libs/guile-gtk/guile-gtk-0.19.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/guile-gtk/guile-gtk-0.19.ebuild,v 1.2 2002/11/23 07:13:54 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/guile-gtk/guile-gtk-0.19.ebuild,v 1.3 2002/11/23 07:26:34 vapier Exp $
DESCRIPTION="GTK+ bindings for guile"
-SRC_URI="http://www.ping.de/sites/zagadka/guile-gtk/download/guile-gtk-0.19.tar.gz"
+SRC_URI="http://www.ping.de/sites/zagadka/guile-gtk/download/${P}.tar.gz"
HOMEPAGE="http://www.ping.de/sites/zagadka/guile-gtk/"
-KEYWORDS="~x86"
+KEYWORDS="x86"
LICENSE="GPL-2"
SLOT="0"
@@ -14,6 +14,7 @@ DEPEND="=dev-util/guile-1.4*
=x11-libs/gtk+-1.2*"
src_compile() {
+ patch < ${FILESDIR}/${P}-Makefile.in.patch || die "patch failed"
econf
emake || die
}