summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-06-04 03:33:03 +0000
committerAchim Gottinger <achim@gentoo.org>2001-06-04 03:33:03 +0000
commita83024060f205ff0773ae8d553b350a8e2caff12 (patch)
tree6bd2f0406f3e5284ee58cd8696d5e145e96c0fd5 /x11-libs/gtkDPS
parentgrrr, commit I say COMMIT (diff)
downloadhistorical-a83024060f205ff0773ae8d553b350a8e2caff12.tar.gz
historical-a83024060f205ff0773ae8d553b350a8e2caff12.tar.bz2
historical-a83024060f205ff0773ae8d553b350a8e2caff12.zip
*** empty log message ***
Diffstat (limited to 'x11-libs/gtkDPS')
-rw-r--r--x11-libs/gtkDPS/gtkDPS-0.3.3.ebuild15
1 files changed, 8 insertions, 7 deletions
diff --git a/x11-libs/gtkDPS/gtkDPS-0.3.3.ebuild b/x11-libs/gtkDPS/gtkDPS-0.3.3.ebuild
index ae07a24bdd49..413b73d94ae4 100644
--- a/x11-libs/gtkDPS/gtkDPS-0.3.3.ebuild
+++ b/x11-libs/gtkDPS/gtkDPS-0.3.3.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtkDPS/gtkDPS-0.3.3.ebuild,v 1.3 2000/12/19 01:07:22 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtkDPS/gtkDPS-0.3.3.ebuild,v 1.4 2001/06/04 03:33:03 achim Exp $
A=${P}.tar.gz
S=${WORKDIR}/${P}
@@ -9,23 +9,24 @@ DESCRIPTION="Set of functions, objects and widgets to use DPS easily with GTK"
SRC_URI="http://www.aist-nara.ac.jp/~masata-y/gtkDPS/dist/${A}"
HOMEPAGE="http://www.aist-nara.ac.jp/~masata-y/gtkDPS/"
-DEPEND=">=sys-apps/bash-2.04
- >=sys-libs/glibc-2.1.3
+DEPEND="virtual/glibc nls? ( sys-devel/gettext )
>=x11-libs/gtk+-1.2.8
>=app-text/dgs-0.5.9.1"
-
+RDEPEND="virtual/glibc"
+
src_compile() {
+ if [ -z "`use nls`" ] ; then
+ myconf="--disable-nls"
+ fi
- cd ${S}
try ./configure --prefix=/usr/X11R6 --host=${CHOST} \
- --with-catgets --with-x --with-dps
+ --with-x --with-dps $myconf
try make
}
src_install () {
- cd ${S}
try make prefix=${D}/usr/X11R6 install
dodoc COPYING* ChangeLog GTKDPS-VERSION HACKING NEWS README TODO
}