summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThilo Bangert <bangert@gentoo.org>2010-02-12 10:23:21 +0000
committerThilo Bangert <bangert@gentoo.org>2010-02-12 10:23:21 +0000
commit3e6dd4c66fa80520e815cb416b5ee4a68a76e5b7 (patch)
tree91f14449c444a8bb8c3e2752bfc943f10b7f5d63 /www-servers/pound/pound-2.5.ebuild
parentadd /dev/ttyACM type devices to list of know serial ports (#301126) (diff)
downloadhistorical-3e6dd4c66fa80520e815cb416b5ee4a68a76e5b7.tar.gz
historical-3e6dd4c66fa80520e815cb416b5ee4a68a76e5b7.tar.bz2
historical-3e6dd4c66fa80520e815cb416b5ee4a68a76e5b7.zip
version bump
Package-Manager: portage-2.2_rc62/cvs/Linux i686
Diffstat (limited to 'www-servers/pound/pound-2.5.ebuild')
-rw-r--r--www-servers/pound/pound-2.5.ebuild56
1 files changed, 56 insertions, 0 deletions
diff --git a/www-servers/pound/pound-2.5.ebuild b/www-servers/pound/pound-2.5.ebuild
new file mode 100644
index 000000000000..d00b381fec9b
--- /dev/null
+++ b/www-servers/pound/pound-2.5.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-servers/pound/pound-2.5.ebuild,v 1.1 2010/02/12 10:23:21 bangert Exp $
+
+EAPI="2"
+
+MY_P="${P/p/P}"
+DESCRIPTION="A http/https reverse-proxy and load-balancer."
+SRC_URI="http://www.apsis.ch/pound/${MY_P}.tgz"
+HOMEPAGE="http://www.apsis.ch/pound/"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~mips ~ppc ~sparc ~x86"
+IUSE="dynscaler"
+
+DEPEND="dev-libs/libpcre
+ dev-libs/openssl"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_configure() {
+ econf \
+ $(use_enable dynscaler) \
+ || die "configure failed"
+}
+
+src_install() {
+ dodir /usr/sbin
+ cp "${S}"/pound "${D}"/usr/sbin/
+ cp "${S}"/poundctl "${D}"/usr/sbin/
+
+ doman pound.8
+ doman poundctl.8
+ dodoc README FAQ
+
+ dodir /etc/init.d
+ newinitd "${FILESDIR}"/pound.init-1.9 pound
+
+ insinto /etc
+ newins "${FILESDIR}"/pound-2.2.cfg pound.cfg
+}
+
+pkg_postinst() {
+ elog "No demo-/sample-configfile is included in the distribution -"
+ elog "read the man-page for more info."
+ elog "A sample (localhost:8888 -> localhost:80) for gentoo is given in \"/etc/pound.cfg\"."
+ echo
+ ewarn "You will have to upgrade you configuration file, if you are"
+ ewarn "upgrading from a version <= 2.0."
+ echo
+ ewarn "The 'WebDAV' config statement is no longer supported!"
+ ewarn "Please adjust your configuration, if necessary."
+ echo
+}