summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaúl Porcel <armin76@gentoo.org>2008-09-28 15:26:50 +0000
committerRaúl Porcel <armin76@gentoo.org>2008-09-28 15:26:50 +0000
commite0174ce80e04a4d2846abb7ae8c5233486f7735e (patch)
tree9f3918480ac3227d62feffd44736b3a7d85549ed /www-client
parentarm/sh stable wrt #197349 (diff)
downloadhistorical-e0174ce80e04a4d2846abb7ae8c5233486f7735e.tar.gz
historical-e0174ce80e04a4d2846abb7ae8c5233486f7735e.tar.bz2
historical-e0174ce80e04a4d2846abb7ae8c5233486f7735e.zip
old
Package-Manager: portage-2.1.4.4
Diffstat (limited to 'www-client')
-rw-r--r--www-client/mozilla-firefox-bin/mozilla-firefox-bin-2.0.0.16.ebuild157
-rw-r--r--www-client/mozilla-firefox/mozilla-firefox-2.0.0.16.ebuild319
-rw-r--r--www-client/seamonkey-bin/seamonkey-bin-1.1.11.ebuild72
-rw-r--r--www-client/seamonkey/seamonkey-1.1.11.ebuild282
4 files changed, 0 insertions, 830 deletions
diff --git a/www-client/mozilla-firefox-bin/mozilla-firefox-bin-2.0.0.16.ebuild b/www-client/mozilla-firefox-bin/mozilla-firefox-bin-2.0.0.16.ebuild
deleted file mode 100644
index 09a29586588a..000000000000
--- a/www-client/mozilla-firefox-bin/mozilla-firefox-bin-2.0.0.16.ebuild
+++ /dev/null
@@ -1,157 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/mozilla-firefox-bin/mozilla-firefox-bin-2.0.0.16.ebuild,v 1.3 2008/08/04 15:07:51 keytoaster Exp $
-
-inherit eutils mozilla-launcher multilib mozextension
-
-LANGS="af ar be bg ca cs da de el en-GB en-US es-AR es-ES eu fi fr fy-NL ga-IE gu-IN he hu it ja ka ko ku lt mk mn nb-NO nl nn-NO pa-IN pl pt-BR pt-PT ro ru sk sl sv-SE tr uk zh-CN zh-TW"
-NOSHORTLANGS="en-GB es-AR pt-BR zh-TW"
-
-DESCRIPTION="Firefox Web Browser"
-SRC_URI="http://releases.mozilla.org/pub/mozilla.org/firefox/releases/${PV}/linux-i686/en-US/firefox-${PV}.tar.gz"
-HOMEPAGE="http://www.mozilla.com/firefox"
-RESTRICT="strip"
-QA_EXECSTACK="opt/firefox/extensions/talkback@mozilla.org/components/libqfaservices.so"
-QA_TEXTRELS="opt/firefox/extensions/talkback@mozilla.org/components/libqfaservices.so"
-
-KEYWORDS="-* amd64 x86"
-SLOT="0"
-LICENSE="|| ( MPL-1.1 GPL-2 LGPL-2.1 )"
-IUSE="restrict-javascript"
-
-for X in ${LANGS} ; do
- if [ "${X}" != "en" ] && [ "${X}" != "en-US" ]; then
- SRC_URI="${SRC_URI}
- linguas_${X/-/_}? ( http://dev.gentoo.org/~armin76/dist/${P/-bin}-xpi/${P/-bin/}-${X}.xpi )"
- fi
- IUSE="${IUSE} linguas_${X/-/_}"
- # english is handled internally
- if [ "${#X}" == 5 ] && ! has ${X} ${NOSHORTLANGS}; then
- if [ "${X}" != "en-US" ]; then
- SRC_URI="${SRC_URI}
- linguas_${X%%-*}? ( http://dev.gentoo.org/~armin76/dist/${P/-bin}-xpi/${P/-bin/}-${X}.xpi )"
- fi
- IUSE="${IUSE} linguas_${X%%-*}"
- fi
-done
-
-DEPEND="app-arch/unzip"
-RDEPEND="x11-libs/libXrender
- x11-libs/libXt
- x11-libs/libXmu
- x11-libs/pango
- x86? (
- >=x11-libs/gtk+-2.2
- =virtual/libstdc++-3.3
- )
- amd64? (
- >=app-emulation/emul-linux-x86-baselibs-1.0
- >=app-emulation/emul-linux-x86-gtklibs-1.0
- app-emulation/emul-linux-x86-compat
- )
- >=www-client/mozilla-launcher-1.41"
-
-PDEPEND="restrict-javascript? ( x11-plugins/noscript )"
-
-S="${WORKDIR}/firefox"
-
-pkg_setup() {
- # This is a binary x86 package => ABI=x86
- # Please keep this in future versions
- # Danny van Dyk <kugelfang@gentoo.org> 2005/03/26
- has_multilib_profile && ABI="x86"
-
- if ! built_with_use --missing true x11-libs/pango X; then
- eerror "Pango is not built with X useflag."
- eerror "Please add 'X' to your USE flags, and re-emerge pango."
- die "Pango needs X"
- fi
-}
-
-linguas() {
- local LANG SLANG
- for LANG in ${LINGUAS}; do
- if has ${LANG} en en_US; then
- has en ${linguas} || linguas="${linguas:+"${linguas} "}en"
- continue
- elif has ${LANG} ${LANGS//-/_}; then
- has ${LANG//_/-} ${linguas} || linguas="${linguas:+"${linguas} "}${LANG//_/-}"
- continue
- elif [[ " ${LANGS} " == *" ${LANG}-"* ]]; then
- for X in ${LANGS}; do
- if [[ "${X}" == "${LANG}-"* ]] && \
- [[ " ${NOSHORTLANGS} " != *" ${X} "* ]]; then
- has ${X} ${linguas} || linguas="${linguas:+"${linguas} "}${X}"
- continue 2
- fi
- done
- fi
- ewarn "Sorry, but mozilla-firefox does not support the ${LANG} LINGUA"
- done
-}
-
-src_unpack() {
- unpack firefox-${PV}.tar.gz
-
- linguas
- for X in ${linguas}; do
- [[ ${X} != "en" ]] && xpi_unpack "${P/-bin/}-${X}.xpi"
- done
- if [[ ${linguas} != "" && ${linguas} != "en" ]]; then
- einfo "Selected language packs (first will be default): ${linguas}"
- fi
-}
-
-src_install() {
- declare MOZILLA_FIVE_HOME=/opt/firefox
-
- # Install firefox in /opt
- dodir ${MOZILLA_FIVE_HOME%/*}
- touch "${S}"/extensions/talkback@mozilla.org/chrome.manifest
- mv "${S}" "${D}"${MOZILLA_FIVE_HOME}
-
- linguas
- for X in ${linguas}; do
- [[ ${X} != "en" ]] && xpi_install "${WORKDIR}"/"${P/-bin/}-${X}"
- done
-
- local LANG=${linguas%% *}
- if [[ -n ${LANG} && ${LANG} != "en" ]]; then
- elog "Setting default locale to ${LANG}"
- dosed -e "s:general.useragent.locale\", \"en-US\":general.useragent.locale\", \"${LANG}\":" \
- "${MOZILLA_FIVE_HOME}"/defaults/pref/firefox.js \
- "${MOZILLA_FIVE_HOME}"/defaults/pref/firefox-l10n.js || \
- die "sed failed to change locale"
- fi
-
- # Create /usr/bin/firefox-bin
- install_mozilla_launcher_stub firefox-bin ${MOZILLA_FIVE_HOME}
-
- # Install icon and .desktop for menu entry
- doicon "${FILESDIR}"/icon/${PN}-icon.png
- domenu "${FILESDIR}"/icon/${PN}.desktop
-
- # revdep-rebuild entry
- insinto /etc/revdep-rebuild
- doins "${FILESDIR}"/10firefox-bin
-
- # install ldpath env.d
- doenvd "${FILESDIR}"/71firefox-bin
-}
-
-pkg_preinst() {
- declare MOZILLA_FIVE_HOME=/opt/firefox
-
- # Remove entire installed instance to prevent all kinds of
- # problems... see bug 44772 for example
- rm -rf "${ROOT}"${MOZILLA_FIVE_HOME}
-}
-
-pkg_postinst() {
- use amd64 && einfo "NB: You just installed a 32-bit firefox"
- update_mozilla_launcher_symlinks
-}
-
-pkg_postrm() {
- update_mozilla_launcher_symlinks
-}
diff --git a/www-client/mozilla-firefox/mozilla-firefox-2.0.0.16.ebuild b/www-client/mozilla-firefox/mozilla-firefox-2.0.0.16.ebuild
deleted file mode 100644
index 71c5bbbeee44..000000000000
--- a/www-client/mozilla-firefox/mozilla-firefox-2.0.0.16.ebuild
+++ /dev/null
@@ -1,319 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/mozilla-firefox/mozilla-firefox-2.0.0.16.ebuild,v 1.7 2008/08/04 15:06:37 keytoaster Exp $
-
-WANT_AUTOCONF="2.1"
-
-inherit flag-o-matic toolchain-funcs eutils mozconfig-2 mozilla-launcher makeedit multilib fdo-mime mozextension autotools
-
-PATCH="${PN}-2.0.0.15-patches-0.1"
-LANGS="af ar be bg ca cs da de el en-GB en-US es-AR es-ES eu fi fr fy-NL ga-IE gu-IN he hu it ja ka ko ku lt mk mn nb-NO nl nn-NO pa-IN pl pt-BR pt-PT ro ru sk sl sv-SE tr uk zh-CN zh-TW"
-NOSHORTLANGS="en-GB es-AR pt-BR zh-TW"
-
-DESCRIPTION="Firefox Web Browser"
-HOMEPAGE="http://www.mozilla.com/firefox"
-
-KEYWORDS="alpha amd64 ~arm hppa ia64 ~mips ppc ppc64 sparc x86 ~x86-fbsd"
-SLOT="0"
-LICENSE="|| ( MPL-1.1 GPL-2 LGPL-2.1 )"
-IUSE="java mozdevelop bindist xforms restrict-javascript filepicker iceweasel"
-
-MOZ_URI="http://releases.mozilla.org/pub/mozilla.org/firefox/releases/${PV}"
-SRC_URI="${MOZ_URI}/source/firefox-${PV}-source.tar.bz2
- mirror://gentoo/${PATCH}.tar.bz2
- iceweasel? ( mirror://gentoo/iceweasel-icons-2.0.0.11.tar.bz2 )"
-
-# These are in
-#
-# http://releases.mozilla.org/pub/mozilla.org/firefox/releases/${PV}/linux-i686/xpi/
-#
-# for i in $LANGS $SHORTLANGS; do wget $i.xpi -O ${P}-$i.xpi; done
-for X in ${LANGS} ; do
- if [ "${X}" != "en" ] && [ "${X}" != "en-US" ]; then
- SRC_URI="${SRC_URI}
- linguas_${X/-/_}? ( http://dev.gentoo.org/~armin76/dist/${P}-xpi/${P}-${X}.xpi )"
- fi
- IUSE="${IUSE} linguas_${X/-/_}"
- # english is handled internally
- if [ "${#X}" == 5 ] && ! has ${X} ${NOSHORTLANGS}; then
- if [ "${X}" != "en-US" ]; then
- SRC_URI="${SRC_URI}
- linguas_${X%%-*}? ( http://dev.gentoo.org/~armin76/dist/${P}-xpi/${P}-${X}.xpi )"
- fi
- IUSE="${IUSE} linguas_${X%%-*}"
- fi
-done
-
-RDEPEND="java? ( virtual/jre )
- >=www-client/mozilla-launcher-1.55
- >=sys-devel/binutils-2.16.1
- >=dev-libs/nss-3.11.8
- >=dev-libs/nspr-4.6.8"
-
-DEPEND="${RDEPEND}
- java? ( >=dev-java/java-config-0.2.0 )"
-
-PDEPEND="restrict-javascript? ( x11-plugins/noscript )"
-
-S="${WORKDIR}/mozilla"
-
-# Needed by src_compile() and src_install().
-# Would do in pkg_setup but that loses the export attribute, they
-# become pure shell variables.
-export MOZ_CO_PROJECT=browser
-export BUILD_OFFICIAL=1
-export MOZILLA_OFFICIAL=1
-
-linguas() {
- local LANG SLANG
- for LANG in ${LINGUAS}; do
- if has ${LANG} en en_US; then
- has en ${linguas} || linguas="${linguas:+"${linguas} "}en"
- continue
- elif has ${LANG} ${LANGS//-/_}; then
- has ${LANG//_/-} ${linguas} || linguas="${linguas:+"${linguas} "}${LANG//_/-}"
- continue
- elif [[ " ${LANGS} " == *" ${LANG}-"* ]]; then
- for X in ${LANGS}; do
- if [[ "${X}" == "${LANG}-"* ]] && \
- [[ " ${NOSHORTLANGS} " != *" ${X} "* ]]; then
- has ${X} ${linguas} || linguas="${linguas:+"${linguas} "}${X}"
- continue 2
- fi
- done
- fi
- ewarn "Sorry, but mozilla-firefox does not support the ${LANG} LINGUA"
- done
-}
-
-pkg_setup(){
- if ! built_with_use x11-libs/cairo X; then
- eerror "Cairo is not built with X useflag."
- eerror "Please add 'X' to your USE flags, and re-emerge cairo."
- die "Cairo needs X"
- fi
-
- if ! built_with_use --missing true x11-libs/pango X; then
- eerror "Pango is not built with X useflag."
- eerror "Please add 'X' to your USE flags, and re-emerge pango."
- die "Pango needs X"
- fi
-
- if ! use bindist && ! use iceweasel; then
- elog "You are enabling official branding. You may not redistribute this build"
- elog "to any users on your network or the internet. Doing so puts yourself into"
- elog "a legal problem with Mozilla Foundation"
- elog "You can disable it by emerging ${PN} _with_ the bindist USE-flag"
-
- fi
-
- use moznopango && warn_mozilla_launcher_stub
-}
-
-src_unpack() {
- unpack firefox-${PV}-source.tar.bz2 ${PATCH}.tar.bz2
-
- if use iceweasel; then
- unpack iceweasel-icons-2.0.0.11.tar.bz2
-
- cp -r iceweaselicons/browser mozilla/
- fi
-
- linguas
- for X in ${linguas}; do
- [[ ${X} != "en" ]] && xpi_unpack "${P}-${X}.xpi"
- done
- if [[ ${linguas} != "" && ${linguas} != "en" ]]; then
- einfo "Selected language packs (first will be default): ${linguas}"
- fi
-
- # Apply our patches
- cd "${S}" || die "cd failed"
- EPATCH_SUFFIX="patch" \
- EPATCH_FORCE="yes" \
- epatch "${WORKDIR}"/patch
-
- if use filepicker; then
- epatch "${FILESDIR}"/mozilla-filepicker.patch
- fi
-
- if use iceweasel; then
- sed -i -e "s|Bon Echo|Iceweasel|" browser/locales/en-US/chrome/branding/brand.*
- sed -i -e "s|BonEcho|Iceweasel|" configure.in
- fi
-
- #Don't strip extension
- sed -i -e 's/STRIP_/#STRIP_/g' extensions/xforms/Makefile.in
-
- eautoreconf
-}
-
-src_compile() {
- declare MOZILLA_FIVE_HOME="/usr/$(get_libdir)/${PN}"
-
- mozconfig_init
- mozconfig_config
-
- mozconfig_annotate '' --enable-application=browser
- mozconfig_annotate '' --enable-image-encoder=all
- mozconfig_annotate '' --enable-canvas
- mozconfig_annotate '' --with-system-nspr
- mozconfig_annotate '' --with-system-nss
-
- if use xforms; then
- mozconfig_annotate '' --enable-extensions=default,xforms,schema-validation,typeaheadfind
- else
- mozconfig_annotate '' --enable-extensions=default,typeaheadfind
- fi
-
- if use ia64; then
- echo "ac_cv_visibility_pragma=no" >> "${S}/.mozconfig"
- fi
-
- if ! use bindist && ! use iceweasel; then
- mozconfig_annotate '' --enable-official-branding
- fi
-
- # Bug 60668: Galeon doesn't build without oji enabled, so enable it
- # regardless of java setting.
- mozconfig_annotate '' --enable-oji --enable-mathml
-
- # Other ff-specific settings
- mozconfig_use_enable mozdevelop jsd
- mozconfig_use_enable mozdevelop xpctools
- mozconfig_use_extension mozdevelop venkman
- mozconfig_annotate '' --with-default-mozilla-five-home=${MOZILLA_FIVE_HOME}
-
- # Finalize and report settings
- mozconfig_final
-
- # -fstack-protector breaks us
- if gcc-version ge 4 1; then
- gcc-specs-ssp && append-flags -fno-stack-protector
- else
- gcc-specs-ssp && append-flags -fno-stack-protector-all
- fi
- filter-flags -fstack-protector -fstack-protector-all
-
- ####################################
- #
- # Configure and build
- #
- ####################################
-
- CPPFLAGS="${CPPFLAGS} -DARON_WAS_HERE" \
- CC="$(tc-getCC)" CXX="$(tc-getCXX)" LD="$(tc-getLD)" \
- econf || die
-
- # It would be great if we could pass these in via CPPFLAGS or CFLAGS prior
- # to econf, but the quotes cause configure to fail.
- sed -i -e \
- 's|-DARON_WAS_HERE|-DGENTOO_NSPLUGINS_DIR=\\\"/usr/'"$(get_libdir)"'/nsplugins\\\" -DGENTOO_NSBROWSER_PLUGINS_DIR=\\\"/usr/'"$(get_libdir)"'/nsbrowser/plugins\\\"|' \
- "${S}"/config/autoconf.mk \
- "${S}"/toolkit/content/buildconfig.html
-
- # This removes extraneous CFLAGS from the Makefiles to reduce RAM
- # requirements while compiling
- edit_makefiles
-
- # Should the build use multiprocessing? Not enabled by default, as it tends to break
- [ "${WANT_MP}" = "true" ] && jobs=${MAKEOPTS} || jobs="-j1"
- emake ${jobs} || die
-}
-
-pkg_preinst() {
- declare MOZILLA_FIVE_HOME="/usr/$(get_libdir)/${PN}"
-
- einfo "Removing old installs with some really ugly code. It potentially"
- einfo "eliminates any problems during the install, however suggestions to"
- einfo "replace this are highly welcome. Send comments and suggestions to"
- einfo "mozilla@gentoo.org."
- rm -rf "${ROOT}"/"${MOZILLA_FIVE_HOME}"
-}
-
-src_install() {
- declare MOZILLA_FIVE_HOME="/usr/$(get_libdir)/${PN}"
-
- # Most of the installation happens here
- dodir "${MOZILLA_FIVE_HOME}"
- cp -RL "${S}"/dist/bin/* "${D}"/"${MOZILLA_FIVE_HOME}"/ || die "cp failed"
-
- linguas
- for X in ${linguas}; do
- [[ ${X} != "en" ]] && xpi_install "${WORKDIR}"/"${P}-${X}"
- done
-
- local LANG=${linguas%% *}
- if [[ -n ${LANG} && ${LANG} != "en" ]]; then
- elog "Setting default locale to ${LANG}"
- dosed -e "s:general.useragent.locale\", \"en-US\":general.useragent.locale\", \"${LANG}\":" \
- "${MOZILLA_FIVE_HOME}"/defaults/pref/firefox.js \
- "${MOZILLA_FIVE_HOME}"/defaults/pref/firefox-l10n.js || \
- die "sed failed to change locale"
- fi
-
- # Create /usr/bin/firefox
- install_mozilla_launcher_stub firefox "${MOZILLA_FIVE_HOME}"
-
- # Install icon and .desktop for menu entry
- if use iceweasel; then
- newicon "${S}"/browser/base/branding/icon48.png iceweasel-icon.png
- newmenu "${FILESDIR}"/icon/iceweasel.desktop \
- mozilla-firefox-2.0.desktop
- elif ! use bindist; then
- newicon "${S}"/other-licenses/branding/firefox/content/icon48.png firefox-icon.png
- newmenu "${FILESDIR}"/icon/mozilla-firefox-1.5.desktop \
- mozilla-firefox-2.0.desktop
- else
- newicon "${S}"/browser/base/branding/icon48.png firefox-icon-unbranded.png
- newmenu "${FILESDIR}"/icon/mozilla-firefox-1.5-unbranded.desktop \
- mozilla-firefox-2.0.desktop
- fi
-
- # Fix icons to look the same everywhere
- insinto "${MOZILLA_FIVE_HOME}"/icons
- doins "${S}"/dist/branding/mozicon16.xpm
- doins "${S}"/dist/branding/mozicon50.xpm
-
- # Install files necessary for applications to build against firefox
- einfo "Installing includes and idl files..."
- cp -LfR "${S}"/dist/include "${D}"/"${MOZILLA_FIVE_HOME}" || die "cp failed"
- cp -LfR "${S}"/dist/idl "${D}"/"${MOZILLA_FIVE_HOME}" || die "cp failed"
-
- # Dirty hack to get some applications using this header running
- dosym "${MOZILLA_FIVE_HOME}"/include/necko/nsIURI.h \
- "${MOZILLA_FIVE_HOME}"/include/nsIURI.h
-
- # Install pkgconfig files
- insinto /usr/"$(get_libdir)"/pkgconfig
- doins "${S}"/build/unix/*.pc
-
- insinto "${MOZILLA_FIVE_HOME}"/greprefs
- newins "${FILESDIR}"/gentoo-default-prefs.js all-gentoo.js
- insinto "${MOZILLA_FIVE_HOME}"/defaults/pref
- newins "${FILESDIR}"/gentoo-default-prefs.js all-gentoo.js
-}
-
-pkg_postinst() {
- declare MOZILLA_FIVE_HOME="/usr/$(get_libdir)/${PN}"
-
- # This should be called in the postinst and postrm of all the
- # mozilla, mozilla-bin, firefox, firefox-bin, thunderbird and
- # thunderbird-bin ebuilds.
- update_mozilla_launcher_symlinks
-
- # Update mimedb for the new .desktop file
- fdo-mime_desktop_database_update
-
- elog "Please remember to rebuild any packages that you have built"
- elog "against Firefox. Some packages might be broken by the upgrade; if this"
- elog "is the case, please search at http://bugs.gentoo.org and open a new bug"
- elog "if one does not exist. Before filing any bugs, please move or remove"
- elog " ~/.mozilla and test with a clean profile directory."
-}
-
-pkg_postrm() {
- declare MOZILLA_FIVE_HOME="/usr/$(get_libdir)/${PN}"
-
- update_mozilla_launcher_symlinks
-}
diff --git a/www-client/seamonkey-bin/seamonkey-bin-1.1.11.ebuild b/www-client/seamonkey-bin/seamonkey-bin-1.1.11.ebuild
deleted file mode 100644
index 285d3da1cb1e..000000000000
--- a/www-client/seamonkey-bin/seamonkey-bin-1.1.11.ebuild
+++ /dev/null
@@ -1,72 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/seamonkey-bin/seamonkey-bin-1.1.11.ebuild,v 1.3 2008/08/04 15:11:01 keytoaster Exp $
-
-inherit eutils mozilla-launcher multilib
-
-DESCRIPTION="Mozilla Application Suite - web browser, email, HTML editor, IRC"
-SRC_URI="http://releases.mozilla.org/pub/mozilla.org/seamonkey/releases/${PV}/seamonkey-${PV}.en-US.linux-i686.tar.gz"
-HOMEPAGE="http://www.seamonkey-project.org/"
-RESTRICT="strip"
-QA_EXECSTACK="opt/seamonkey/*"
-
-KEYWORDS="-* amd64 x86"
-SLOT="0"
-LICENSE="|| ( MPL-1.1 GPL-2 LGPL-2.1 )"
-IUSE=""
-
-DEPEND="app-arch/unzip"
-RDEPEND="x11-libs/libXrender
- x11-libs/libXt
- x11-libs/libXmu
- x86? (
- >=x11-libs/gtk+-2.2
- =virtual/libstdc++-3.3
- )
- amd64? (
- >=app-emulation/emul-linux-x86-baselibs-1.0
- >=app-emulation/emul-linux-x86-gtklibs-1.0
- app-emulation/emul-linux-x86-compat
- )
- >=www-client/mozilla-launcher-1.56"
-
-S="${WORKDIR}/seamonkey"
-
-pkg_setup() {
- # This is a binary x86 package => ABI=x86
- # Please keep this in future versions
- # Danny van Dyk <kugelfang@gentoo.org> 2005/03/26
- has_multilib_profile && ABI="x86"
-}
-
-src_install() {
- declare MOZILLA_FIVE_HOME=/opt/seamonkey
-
- # Install seamonkey in /opt
- dodir ${MOZILLA_FIVE_HOME%/*}
- mv "${S}" "${D}${MOZILLA_FIVE_HOME}"
-
- # Install /usr/bin/seamonkey-bin
- install_mozilla_launcher_stub seamonkey-bin ${MOZILLA_FIVE_HOME}
-
- # Install icon and .desktop for menu entry
- doicon "${FILESDIR}/icon/${PN}.png"
- domenu "${FILESDIR}/icon/${PN}.desktop"
-}
-
-pkg_preinst() {
- declare MOZILLA_FIVE_HOME=/opt/seamonkey
-
- # Remove entire installed instance to prevent all kinds of
- # problems... see bug 44772 for example
- rm -rf "${ROOT}${MOZILLA_FIVE_HOME}"
-}
-
-pkg_postinst() {
- use amd64 && einfo "NB: You just installed a 32-bit seamonkey"
- update_mozilla_launcher_symlinks
-}
-
-pkg_postrm() {
- update_mozilla_launcher_symlinks
-}
diff --git a/www-client/seamonkey/seamonkey-1.1.11.ebuild b/www-client/seamonkey/seamonkey-1.1.11.ebuild
deleted file mode 100644
index b205f941a816..000000000000
--- a/www-client/seamonkey/seamonkey-1.1.11.ebuild
+++ /dev/null
@@ -1,282 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/seamonkey/seamonkey-1.1.11.ebuild,v 1.7 2008/08/04 15:09:48 keytoaster Exp $
-
-WANT_AUTOCONF="2.1"
-
-inherit flag-o-matic toolchain-funcs eutils mozcoreconf mozconfig-2 mozilla-launcher makeedit multilib autotools
-
-PATCH="${PN}-1.1.10-patches-0.1"
-EMVER="0.95.6"
-
-DESCRIPTION="Mozilla Application Suite - web browser, email, HTML editor, IRC"
-HOMEPAGE="http://www.seamonkey-project.org/"
-SRC_URI="http://releases.mozilla.org/pub/mozilla.org/${PN}/releases/${PV}/${P}.source.tar.bz2
- mirror://gentoo/${PATCH}.tar.bz2
- crypt? ( !moznomail? ( http://www.mozilla-enigmail.org/download/source/enigmail-${EMVER}.tar.gz ) )"
-
-KEYWORDS="alpha amd64 ~arm hppa ia64 ppc ppc64 sparc x86 ~x86-fbsd"
-SLOT="0"
-LICENSE="|| ( MPL-1.1 GPL-2 LGPL-2.1 )"
-IUSE="java ldap mozdevelop moznocompose moznoirc moznomail moznoroaming postgres crypt xforms"
-
-RDEPEND="java? ( virtual/jre )
- >=www-client/mozilla-launcher-1.56
- >=dev-libs/nss-3.11.5
- >=dev-libs/nspr-4.6.5-r1
- crypt? ( !moznomail? ( >=app-crypt/gnupg-1.4 ) )"
-
-DEPEND="${RDEPEND}
- java? ( >=dev-java/java-config-0.2.0 )
- dev-lang/perl
- postgres? ( >=virtual/postgresql-server-7.2.0 )"
-
-S="${WORKDIR}/mozilla"
-
-# Needed by src_compile() and src_install().
-# Would do in pkg_setup but that loses the export attribute, they
-# become pure shell variables.
-export MOZ_CO_PROJECT=suite
-export BUILD_OFFICIAL=1
-export MOZILLA_OFFICIAL=1
-
-pkg_setup() {
- if ! built_with_use x11-libs/cairo X; then
- eerror "Cairo is not built with X useflag."
- eerror "Please add 'X' to your USE flags, and re-emerge cairo."
- die "Cairo needs X"
- fi
-
- if ! built_with_use --missing true x11-libs/pango X; then
- eerror "Pango is not built with X useflag."
- eerror "Please add 'X' to your USE flags, and re-emerge pango."
- die "Pango needs X"
- fi
-
- use moznopango && warn_mozilla_launcher_stub
-}
-
-src_unpack() {
- unpack ${P}.source.tar.bz2 ${PATCH}.tar.bz2
-
- # Apply our patches
- cd "${S}" || die "cd failed"
- EPATCH_SUFFIX="patch" \
- EPATCH_FORCE="yes" \
- epatch "${WORKDIR}"/patch
-
- # Unpack the enigmail plugin
- if use crypt && ! use moznomail; then
- cd "${S}"/mailnews/extensions || die
- unpack enigmail-${EMVER}.tar.gz
- cd "${S}"/mailnews/extensions/enigmail || die "cd failed"
- makemake2
- fi
-
- # Fix scripts that call for /usr/local/bin/perl #51916
- ebegin "Patching smime to call perl from /usr/bin"
- sed -i -e '1s,usr/local/bin,usr/bin,' "${S}"/security/nss/cmd/smimetools/smime
- eend $? || die "sed failed"
-
- cd "${S}"
- eautoreconf
-}
-
-src_compile() {
- declare MOZILLA_FIVE_HOME="/usr/$(get_libdir)/${PN}"
-
- ####################################
- #
- # mozconfig, CFLAGS and CXXFLAGS setup
- #
- ####################################
- mozconfig_init
- mozconfig_config
-
- mozconfig_annotate 'gentoo' --enable-canvas
- mozconfig_annotate 'gentoo' --with-system-nspr
- mozconfig_annotate 'gentoo' --with-system-nss
-
- # Bug 60668: Galeon doesn't build without oji enabled, so enable it
- # regardless of java setting.
- mozconfig_annotate 'galeon' --enable-oji --enable-mathml
-
- # Other moz-specific settings
- mozconfig_use_enable mozdevelop jsd
- mozconfig_use_enable mozdevelop xpctools
- mozconfig_use_extension mozdevelop venkman
-
- if use moznoirc; then
- mozconfig_annotate '+moznocompose +moznoirc' --enable-extensions=-irc
- fi
-
- if use moznoroaming ; then
- mozconfig_annotate '+moznoroaming' --enable-extensions=-sroaming
- fi
-
- if use postgres ; then
- mozconfig_annotate '+postgres' --enable-extensions=sql
- export MOZ_ENABLE_PGSQL=1
- export MOZ_PGSQL_INCLUDES=/usr/include
- export MOZ_PGSQL_LIBS=/usr/$(get_libdir)
- fi
-
- mozconfig_use_enable ldap
- mozconfig_use_enable ldap ldap-experimental
- mozconfig_annotate '' --with-default-mozilla-five-home=${MOZILLA_FIVE_HOME}
- mozconfig_annotate '' --with-user-appdir=.mozilla
-
- if use moznomail; then
- mozconfig_annotate "+moznomail" --disable-mailnews
- fi
-
- if use moznocompose; then
- if use moznoirc && use moznomail; then
- mozconfig_annotate "+moznocompose" --disable-composer
- fi
- fi
-
- if use xforms; then
- mozconfig_annotate "+xforms" --enable-extensions=xforms,schema-validation
- fi
-
- # Finalize and report settings
- mozconfig_final
-
- # -fstack-protector breaks us
- if gcc-version ge 4 1; then
- gcc-specs-ssp && append-flags -fno-stack-protector
- else
- gcc-specs-ssp && append-flags -fno-stack-protector-all
- fi
- filter-flags -fstack-protector -fstack-protector-all
-
- ####################################
- #
- # Configure and build
- #
- ####################################
-
- CPPFLAGS="${CPPFLAGS} -DARON_WAS_HERE" \
- CC="$(tc-getCC)" CXX="$(tc-getCXX)" LD="$(tc-getLD)" \
- econf || die
-
- # It would be great if we could pass these in via CPPFLAGS or CFLAGS prior
- # to econf, but the quotes cause configure to fail.
- sed -i -e \
- 's|-DARON_WAS_HERE|-DGENTOO_NSPLUGINS_DIR=\\\"/usr/'"$(get_libdir)"'/nsplugins\\\" -DGENTOO_NSBROWSER_PLUGINS_DIR=\\\"/usr/'"$(get_libdir)"'/nsbrowser/plugins\\\"|' \
- "${S}"/config/autoconf.mk \
- "${S}"/xpfe/global/buildconfig.html
-
- # This removes extraneous CFLAGS from the Makefiles to reduce RAM
- # requirements while compiling
- edit_makefiles
-
- emake || die
-
- ####################################
- #
- # Build Enigmail extension
- #
- ####################################
-
- if use crypt && ! use moznomail; then
- emake -C "${S}"/mailnews/extensions/enigmail || die "make enigmail failed"
- fi
-}
-
-src_install() {
- declare MOZILLA_FIVE_HOME=/usr/$(get_libdir)/${PN}
-
- # Most of the installation happens here
- dodir "${MOZILLA_FIVE_HOME}"
- cp -RL "${S}"/dist/bin/* "${D}"/"${MOZILLA_FIVE_HOME}"/ || die "cp failed"
-
- # Create directory structure to support portage-installed extensions.
- # See update_chrome() in mozilla-launcher
- keepdir ${MOZILLA_FIVE_HOME}/chrome.d
- keepdir ${MOZILLA_FIVE_HOME}/extensions.d
- cp "${D}"${MOZILLA_FIVE_HOME}/chrome/installed-chrome.txt \
- "${D}"${MOZILLA_FIVE_HOME}/chrome.d/0_base-chrome.txt
-
- # Create /usr/bin/seamonkey
- install_mozilla_launcher_stub seamonkey ${MOZILLA_FIVE_HOME}
-
- # Install icon and .desktop for menu entry
- doicon "${FILESDIR}"/icon/${PN}.png
- domenu "${FILESDIR}"/icon/${PN}.desktop
-
- # Fix icons to look the same everywhere
- insinto ${MOZILLA_FIVE_HOME}/icons
- doins "${S}"/widget/src/gtk/mozicon16.xpm
- doins "${S}"/widget/src/gtk/mozicon50.xpm
-
- ####################################
- #
- # Install files necessary for applications to build against seamonkey
- #
- ####################################
-
- elog "Installing includes and idl files..."
- cp -LfR "${S}"/dist/include "${D}"/"${MOZILLA_FIVE_HOME}" || die "cp failed"
- cp -LfR "${S}"/dist/idl "${D}"/"${MOZILLA_FIVE_HOME}" || die "cp failed"
-
- # Fix mozilla-config and install it
- exeinto ${MOZILLA_FIVE_HOME}
- doexe "${S}"/build/unix/${PN}-config
-
- # Install pkgconfig files
- insinto /usr/"$(get_libdir)"/pkgconfig
- doins "${S}"/build/unix/*.pc
-
- # Install env.d snippet, which isn't necessary for running mozilla, but
- # might be necessary for programs linked against firefox
- doenvd "${FILESDIR}"/10${PN}
- dosed "s|/usr/lib|/usr/$(get_libdir)|" /etc/env.d/10${PN}
-
- # Install rebuild script since mozilla-bin doesn't support registration yet
- exeinto ${MOZILLA_FIVE_HOME}
- doexe "${FILESDIR}"/${PN}-rebuild-databases.pl
- dosed -e 's|/lib/|/'"$(get_libdir)"'/|g' \
- ${MOZILLA_FIVE_HOME}/${PN}-rebuild-databases.pl
-
- # Install docs
- dodoc "${S}"/{LEGAL,LICENSE}
-
- # Update Google search plugin to use UTF8 charset ...
- insinto ${MOZILLA_FIVE_HOME}/searchplugins
- doins "${FILESDIR}"/google.src
-}
-
-pkg_preinst() {
- declare MOZILLA_FIVE_HOME="/usr/$(get_libdir)/${PN}"
-
- # Remove entire installed instance to solve various problems,
- # for example see bug 27719
- rm -rf "${ROOT}"${MOZILLA_FIVE_HOME}
-}
-
-pkg_postinst() {
- declare MOZILLA_FIVE_HOME="/usr/$(get_libdir)/${PN}"
-
- # Update the component registry
- MOZILLA_LIBDIR=${ROOT}${MOZILLA_FIVE_HOME} MOZILLA_LAUNCHER=${PN} \
- /usr/libexec/mozilla-launcher -register
-
- # This should be called in the postinst and postrm of all the
- # mozilla, mozilla-bin, firefox, firefox-bin, thunderbird and
- # thunderbird-bin ebuilds.
- update_mozilla_launcher_symlinks
-}
-
-pkg_postrm() {
- declare MOZILLA_FIVE_HOME="/usr/$(get_libdir)/${PN}"
-
- # Update the component registry
- if [[ -x ${MOZILLA_FIVE_HOME}/${PN}-bin ]]; then
- MOZILLA_LIBDIR=${ROOT}${MOZILLA_FIVE_HOME} MOZILLA_LAUNCHER=${PN} \
- /usr/libexec/mozilla-launcher -register
- fi
-
- update_mozilla_launcher_symlinks
-}