summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2008-12-16 15:51:23 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2008-12-16 15:51:23 +0000
commitb9fc368cab27e46d34469c4a378f5e78ae71eaf5 (patch)
tree017457345e12e48e5860530c350ea33de83c2ef5 /www-client/kazehakase/kazehakase-0.5.6-r1.ebuild
parentStable for HPPA (bug #246209). (diff)
downloadhistorical-b9fc368cab27e46d34469c4a378f5e78ae71eaf5.tar.gz
historical-b9fc368cab27e46d34469c4a378f5e78ae71eaf5.tar.bz2
historical-b9fc368cab27e46d34469c4a378f5e78ae71eaf5.zip
Removed webkit USE flag, bug #245556.
Package-Manager: portage-2.1.6/cvs/Linux 2.6.27-gentoo-r4 x86_64
Diffstat (limited to 'www-client/kazehakase/kazehakase-0.5.6-r1.ebuild')
-rw-r--r--www-client/kazehakase/kazehakase-0.5.6-r1.ebuild58
1 files changed, 58 insertions, 0 deletions
diff --git a/www-client/kazehakase/kazehakase-0.5.6-r1.ebuild b/www-client/kazehakase/kazehakase-0.5.6-r1.ebuild
new file mode 100644
index 000000000000..8daf8cf1e7e3
--- /dev/null
+++ b/www-client/kazehakase/kazehakase-0.5.6-r1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-client/kazehakase/kazehakase-0.5.6-r1.ebuild,v 1.1 2008/12/16 15:51:23 matsuu Exp $
+
+inherit eutils flag-o-matic
+
+IUSE="hyperestraier migemo ruby ssl webkit"
+
+DESCRIPTION="a browser with gecko engine like Epiphany or Galeon."
+SRC_URI="mirror://sourceforge.jp/${PN}/33533/${P}.tar.gz"
+HOMEPAGE="http://kazehakase.sourceforge.jp/"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+LICENSE="GPL-2"
+
+DEPEND=">=x11-libs/gtk+-2.12
+ || (
+ >=www-client/mozilla-firefox-2
+ >=www-client/seamonkey-1
+ >=mail-client/mozilla-thunderbird-2
+ >=net-libs/xulrunner-1.8
+ )
+ ssl? ( >=net-libs/gnutls-1.2.0 )
+ ruby? ( dev-ruby/ruby-gtk2 dev-ruby/ruby-gettext )
+ hyperestraier? ( >=app-text/hyperestraier-1.2 )
+ webkit? ( net-libs/webkit-gtk )"
+
+RDEPEND="${DEPEND}
+ migemo? ( app-text/migemo )"
+
+DEPEND="${DEPEND}
+ dev-util/pkgconfig"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-0.5.5-xulrunner19.patch
+}
+
+src_compile() {
+ local myconf
+
+ # Bug 159949
+ replace-flags -Os -O2
+
+ myconf="${myconf} $(use_enable migemo)"
+ use ruby || myconf="${myconf} --with-ruby=no --with-rgettext=no"
+ use ssl || myconf="${myconf} --disable-ssl"
+
+ econf ${myconf} || die
+ emake || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS ChangeLog NEWS README* TODO*
+}