summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRoy Marples <uberlord@gentoo.org>2006-06-23 12:35:36 +0000
committerRoy Marples <uberlord@gentoo.org>2006-06-23 12:35:36 +0000
commitcdc2145e8dcf24143f1956bf843429dc5fb7a92b (patch)
tree920afc63a7aba539542c653d33ee2c42d6644e20 /www-apps/websvn/websvn-2.0_rc1.ebuild
parentTaking up maintainership. (diff)
downloadhistorical-cdc2145e8dcf24143f1956bf843429dc5fb7a92b.tar.gz
historical-cdc2145e8dcf24143f1956bf843429dc5fb7a92b.tar.bz2
historical-cdc2145e8dcf24143f1956bf843429dc5fb7a92b.zip
Drop invalid DEPEND on PEAR-XML_Parser, replace with check to see if php
has been built with the xml USE flag. Package-Manager: portage-2.1.1_pre1-r1
Diffstat (limited to 'www-apps/websvn/websvn-2.0_rc1.ebuild')
-rw-r--r--www-apps/websvn/websvn-2.0_rc1.ebuild10
1 files changed, 8 insertions, 2 deletions
diff --git a/www-apps/websvn/websvn-2.0_rc1.ebuild b/www-apps/websvn/websvn-2.0_rc1.ebuild
index 7aa76a380501..cd19cc9db4d8 100644
--- a/www-apps/websvn/websvn-2.0_rc1.ebuild
+++ b/www-apps/websvn/websvn-2.0_rc1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/websvn/websvn-2.0_rc1.ebuild,v 1.2 2006/06/18 16:22:35 uberlord Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/websvn/websvn-2.0_rc1.ebuild,v 1.3 2006/06/23 12:35:36 uberlord Exp $
inherit eutils webapp
@@ -13,13 +13,19 @@ IUSE="enscript"
KEYWORDS="~amd64 ~sparc ~x86"
RDEPEND="virtual/php
- dev-php/PEAR-XML_Parser
dev-util/subversion
sys-apps/sed
enscript? ( app-text/enscript )"
S="${WORKDIR}/WebSVN-${MY_PV}"
+pkg_setup() {
+ if ! built_with_use dev-lang/php xml ; then
+ eerror "You MUST re-emerge php with the xml USE flag"
+ die "current php install cannot support ${PN}"
+ fi
+}
+
src_unpack() {
unpack ${A}
cd "${S}"