summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2008-10-14 15:05:13 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2008-10-14 15:05:13 +0000
commit6be1bdfd3a5eebd86da6e6f3a7c54628d681583b (patch)
tree271d56ca746e2b3613cb9e8e99dd505a33c86ad6 /sys-power/nvram-wakeup/nvram-wakeup-0.97_p863.ebuild
parentSet compiler and linker during src_compile rather than unpack. (diff)
downloadhistorical-6be1bdfd3a5eebd86da6e6f3a7c54628d681583b.tar.gz
historical-6be1bdfd3a5eebd86da6e6f3a7c54628d681583b.tar.bz2
historical-6be1bdfd3a5eebd86da6e6f3a7c54628d681583b.zip
Let CFLAGS be respected during src_compile rather than being set in stone.
Package-Manager: portage-2.2_rc12/cvs/Linux 2.6.27-gentoo x86_64
Diffstat (limited to 'sys-power/nvram-wakeup/nvram-wakeup-0.97_p863.ebuild')
-rw-r--r--sys-power/nvram-wakeup/nvram-wakeup-0.97_p863.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/sys-power/nvram-wakeup/nvram-wakeup-0.97_p863.ebuild b/sys-power/nvram-wakeup/nvram-wakeup-0.97_p863.ebuild
index e1bd2d88d255..e418e418a965 100644
--- a/sys-power/nvram-wakeup/nvram-wakeup-0.97_p863.ebuild
+++ b/sys-power/nvram-wakeup/nvram-wakeup-0.97_p863.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-power/nvram-wakeup/nvram-wakeup-0.97_p863.ebuild,v 1.4 2007/03/03 06:27:06 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-power/nvram-wakeup/nvram-wakeup-0.97_p863.ebuild,v 1.5 2008/10/14 15:05:13 flameeyes Exp $
inherit flag-o-matic
@@ -33,7 +33,7 @@ src_unpack() {
# Need to be careful with CFLAGS since this could eat your bios
strip-flags
sed -i \
- -e "s:-O2 -Wall -Wstrict-prototypes -g -mcpu=i686:${CFLAGS}:" \
+ -e "s:= -O2 -Wall -Wstrict-prototypes -g -mcpu=i686:+=:" \
Makefile || die "setting CFLAGS"
}