summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Jones <cretin@gentoo.org>2002-11-02 21:18:16 +0000
committerStefan Jones <cretin@gentoo.org>2002-11-02 21:18:16 +0000
commitfd283930c13bff71ae98890779fc635c177e457a (patch)
treeb14a17d901f849f0ae36f7940a27a69402cb8773 /sys-libs
parentNew ebuild added to portage. See bug #7770 (diff)
downloadhistorical-fd283930c13bff71ae98890779fc635c177e457a.tar.gz
historical-fd283930c13bff71ae98890779fc635c177e457a.tar.bz2
historical-fd283930c13bff71ae98890779fc635c177e457a.zip
Big fix in glibc regarding OPEN_X math functions and C++, bug #9883
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/glibc/files/2.2.5/glibc-2.2.5-sparc-mathinline.patch30
-rw-r--r--sys-libs/glibc/glibc-2.2.5-r7.ebuild7
2 files changed, 36 insertions, 1 deletions
diff --git a/sys-libs/glibc/files/2.2.5/glibc-2.2.5-sparc-mathinline.patch b/sys-libs/glibc/files/2.2.5/glibc-2.2.5-sparc-mathinline.patch
new file mode 100644
index 000000000000..0560a68cfd60
--- /dev/null
+++ b/sys-libs/glibc/files/2.2.5/glibc-2.2.5-sparc-mathinline.patch
@@ -0,0 +1,30 @@
+--- glibc-2.2.5/sysdeps/sparc/fpu/bits/mathinline.h 2001-11-28 21:13:08.000000000 +0000
++++ glibc-2.3.1/sysdeps/sparc/fpu/bits/mathinline.h 2002-05-16 01:16:23.000000000 +0100
+@@ -1,5 +1,5 @@
+ /* Inline math functions for SPARC.
+- Copyright (C) 1999, 2000, 2001 Free Software Foundation, Inc.
++ Copyright (C) 1999, 2000, 2001, 2002 Free Software Foundation, Inc.
+ This file is part of the GNU C Library.
+ Contributed by Jakub Jelinek <jakub@redhat.com>.
+
+@@ -213,16 +213,16 @@
+
+ # ifndef __NO_MATH_INLINES
+
+-__MATH_INLINE double fdim (double __x, double __y);
++__MATH_INLINE double fdim (double __x, double __y) __THROW;
+ __MATH_INLINE double
+-fdim (double __x, double __y)
++fdim (double __x, double __y) __THROW
+ {
+ return __x < __y ? 0 : __x - __y;
+ }
+
+-__MATH_INLINE float fdimf (float __x, float __y);
++__MATH_INLINE float fdimf (float __x, float __y) __THROW;
+ __MATH_INLINE float
+-fdimf (float __x, float __y)
++fdimf (float __x, float __y) __THROW
+ {
+ return __x < __y ? 0 : __x - __y;
+ }
diff --git a/sys-libs/glibc/glibc-2.2.5-r7.ebuild b/sys-libs/glibc/glibc-2.2.5-r7.ebuild
index 0f5b77a4c572..6888c5265a71 100644
--- a/sys-libs/glibc/glibc-2.2.5-r7.ebuild
+++ b/sys-libs/glibc/glibc-2.2.5-r7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.2.5-r7.ebuild,v 1.21 2002/11/02 21:05:19 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.2.5-r7.ebuild,v 1.22 2002/11/02 21:18:16 cretin Exp $
IUSE="nls pic build"
@@ -140,6 +140,11 @@ src_unpack() {
fi
# Some patches to fixup build on sparc and sparc64
+
+ #This is a sparc mathinline.h update, fixes problems with C++ and the mathinline header, cretin@gentoo.org
+ einfo "Applying sparc-mathinline patch..."
+ cd ${S}; patch -p1 < ${FILESDIR}/${PV}/${P}-sparc-mathinline.patch > /dev/null || die
+
if use sparc64 > /dev/null || use sparc > /dev/null
then
einfo "Applying sparc-misc patch..."