summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2004-04-24 06:24:19 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2004-04-24 06:24:19 +0000
commitcd6604ccf0822a63332d47818d8f24ebee8098aa (patch)
tree61f9d8c8bdea9084fde8b523ad5b41a9912eeae5 /sys-libs
parentremove packaged racoon #48847 (diff)
downloadhistorical-cd6604ccf0822a63332d47818d8f24ebee8098aa.tar.gz
historical-cd6604ccf0822a63332d47818d8f24ebee8098aa.tar.bz2
historical-cd6604ccf0822a63332d47818d8f24ebee8098aa.zip
bug #47482, libcrack.so should be in /lib as other stuff in the root fs is linked against it.
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/cracklib/ChangeLog8
-rw-r--r--sys-libs/cracklib/Manifest10
-rw-r--r--sys-libs/cracklib/cracklib-2.7-r9.ebuild75
-rw-r--r--sys-libs/cracklib/files/digest-cracklib-2.7-r91
4 files changed, 89 insertions, 5 deletions
diff --git a/sys-libs/cracklib/ChangeLog b/sys-libs/cracklib/ChangeLog
index 572d78a7f1ab..8d2776fc7308 100644
--- a/sys-libs/cracklib/ChangeLog
+++ b/sys-libs/cracklib/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-libs/cracklib
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/cracklib/ChangeLog,v 1.40 2004/03/09 23:40:53 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/cracklib/ChangeLog,v 1.41 2004/04/24 06:24:19 robbat2 Exp $
+
+*cracklib-2.7-r9 (23 Apr 2004)
+
+ 23 Apr 2004; Robin H. Johnson <robbat2@gentoo.org> cracklib-2.7-r9.ebuild:
+ bug #47482, libcrack.so should be in /lib as other stuff in the root fs is
+ linked against it.
09 Mar 2004; <agriffis@gentoo.org> cracklib-2.7-r8.ebuild:
stable on alpha and ia64
diff --git a/sys-libs/cracklib/Manifest b/sys-libs/cracklib/Manifest
index 9d3d972e13e0..371a2668737d 100644
--- a/sys-libs/cracklib/Manifest
+++ b/sys-libs/cracklib/Manifest
@@ -1,10 +1,12 @@
-MD5 046aeb6638889cab3264835584204bb2 ChangeLog 5377
-MD5 bdbe6cfb56a7908877579725e7c98064 cracklib-2.7-r7.ebuild 1704
-MD5 5c53a1f454189f0cecc276e30901bb0b cracklib-2.7-r8.ebuild 1978
+MD5 caa31e31e64c50b169e06cfa4f0838bb cracklib-2.7-r7.ebuild 1703
+MD5 dde4c3c62e7c8b122bb3290c15ef7dc4 cracklib-2.7-r9.ebuild 2099
+MD5 e65d0bf21178d7f69661c2e7396d3316 cracklib-2.7-r8.ebuild 1977
+MD5 f97c5b7aa43a650ce6f4e778af6257d7 ChangeLog 5583
MD5 9a09f8d531c582e78977dbfd96edc1f2 metadata.xml 164
MD5 85783b83e5bfa51190033895cfaf803e files/cracklib-2.7-dec-alpha-compiler.diff 333
-MD5 9c566d6a249f8d02ad419aac76fffd66 files/cracklib-2.7-gentoo-new.diff 4244
MD5 954e8e0d53c6f878366e472a90917356 files/cracklib-2.7-redhat.patch 1224
MD5 cd32ee2bf36a5facd5b5eb5d99aa66ee files/cracklib-2.7-static-lib.patch 1346
+MD5 9c566d6a249f8d02ad419aac76fffd66 files/cracklib-2.7-gentoo-new.diff 4244
MD5 f27fad03a3939b6e405193b419b645a4 files/digest-cracklib-2.7-r7 63
MD5 f27fad03a3939b6e405193b419b645a4 files/digest-cracklib-2.7-r8 63
+MD5 f27fad03a3939b6e405193b419b645a4 files/digest-cracklib-2.7-r9 63
diff --git a/sys-libs/cracklib/cracklib-2.7-r9.ebuild b/sys-libs/cracklib/cracklib-2.7-r9.ebuild
new file mode 100644
index 000000000000..8d8e526f9ea9
--- /dev/null
+++ b/sys-libs/cracklib/cracklib-2.7-r9.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/cracklib/cracklib-2.7-r9.ebuild,v 1.1 2004/04/24 06:24:19 robbat2 Exp $
+
+inherit flag-o-matic eutils
+
+MY_P=${P/-/,}
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="Password Checking Library"
+HOMEPAGE="http://www.crypticide.org/users/alecm/"
+SRC_URI="http://www.crypticide.org/users/alecm/security/${MY_P}.tar.gz"
+
+LICENSE="CRACKLIB"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~mips ~hppa ~ia64 ~amd64 ~ppc64 ~s390"
+
+RDEPEND="sys-apps/miscfiles
+ >=sys-apps/portage-2.0.47-r10"
+DEPEND="${RDEPEND}
+ sys-devel/gcc-config"
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+ epatch ${FILESDIR}/${P}-redhat.patch
+ epatch ${FILESDIR}/${P}-gentoo-new.diff
+ epatch ${FILESDIR}/${P}-static-lib.patch
+
+ [ "${ARCH}" = "alpha" -a "${CC}" = "ccc" ] && \
+ sed -i -e 's:CFLAGS += -g :CFLAGS += -g3 :' ${S}/cracklib/Makefile
+
+ # this is only needed for the transparent hgcc
+ if has_version 'sys-devel/hardened-gcc' && [ ${CC} == "gcc" ]
+ then
+ einfo "hardened-gcc: adding libgcc for propolice __guard symbol to cracklib"
+ sed -i "s:= ld:= ld $(gcc-config -L)/libgcc_s.so:" ${S}/cracklib/Makefile
+ fi
+}
+
+src_compile() {
+ filter-flags -fstack-protector
+ # Parallel make does not work for 2.7
+ make all || die
+}
+
+src_install() {
+ dodir /usr/{lib,sbin,include} /lib
+ keepdir /usr/share/cracklib
+
+ make DESTDIR=${D} install || die
+
+ # Needed by pam
+ if [ ! -f "${D}/usr/lib/libcrack.a" ]
+ then
+ eerror "Could not find libcrack.a which is needed by core components!"
+ die "Could not find libcrack.a which is needed by core components!"
+ fi
+
+ # put libcrack.so.2.7 in /lib for cases where /usr isn't available yet
+ mv ${D}/usr/lib/libcrack.so* ${D}/lib
+
+ # This link is needed and not created. :| bug #9611
+ cd ${D}/lib
+ dosym libcrack.so.2.7 /lib/libcrack.so.2
+ cd ${S}
+
+ cp ${S}/cracklib/packer.h ${D}/usr/include
+ #fix the permissions on it as they may be wrong in some cases
+ fperms 644 usr/include/packer.h
+
+ preplib /usr/lib /lib
+
+ dodoc HISTORY LICENCE MANIFEST POSTER README
+}
diff --git a/sys-libs/cracklib/files/digest-cracklib-2.7-r9 b/sys-libs/cracklib/files/digest-cracklib-2.7-r9
new file mode 100644
index 000000000000..12a9da188d95
--- /dev/null
+++ b/sys-libs/cracklib/files/digest-cracklib-2.7-r9
@@ -0,0 +1 @@
+MD5 0c84ad7413d9dd3e5c2eaa5f97d53c4a cracklib,2.7.tar.gz 21059