summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Imhof <tantive@gentoo.org>2003-08-16 12:48:15 +0000
committerMichael Imhof <tantive@gentoo.org>2003-08-16 12:48:15 +0000
commit98951914ecdf199274865d9006c01a7ac1004edd (patch)
tree4577247e0e873b72b8c462e3960fe6982e2711f4 /sys-kernel
parentadded prepatch kernels (diff)
downloadhistorical-98951914ecdf199274865d9006c01a7ac1004edd.tar.gz
historical-98951914ecdf199274865d9006c01a7ac1004edd.tar.bz2
historical-98951914ecdf199274865d9006c01a7ac1004edd.zip
added prepatch kernels
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/openmosix-sources/Manifest4
-rw-r--r--sys-kernel/openmosix-sources/files/digest-openmosix-sources-2.4.22_rc23
-rw-r--r--sys-kernel/openmosix-sources/files/digest-openmosix-sources-2.6.0_beta32
-rw-r--r--sys-kernel/openmosix-sources/openmosix-sources-2.4.22_rc2.ebuild39
-rw-r--r--sys-kernel/openmosix-sources/openmosix-sources-2.6.0_beta3.ebuild122
5 files changed, 168 insertions, 2 deletions
diff --git a/sys-kernel/openmosix-sources/Manifest b/sys-kernel/openmosix-sources/Manifest
index 1da6b9067109..797ef17e67bd 100644
--- a/sys-kernel/openmosix-sources/Manifest
+++ b/sys-kernel/openmosix-sources/Manifest
@@ -7,8 +7,8 @@ MD5 3eec695f0481b07db403de0e580062eb openmosix-sources-2.4.20-r5.ebuild 3197
MD5 2baf3a70602d45cf08b466989175cb5a openmosix-sources-2.4.20-r6.ebuild 3198
MD5 433f31a4ff1b72a6eabe1ccbd40a3e86 openmosix-sources-2.4.21.ebuild 3199
MD5 beb9efce81ae2c582a621528fc783095 metadata.xml 373
-MD5 159cc0fecdad086403a719bfb42e56ca openmosix-sources-2.4.22_rc2.ebuild 1487
-MD5 00efa667e1f149564f98fe754d0bbb75 openmosix-sources-2.6.0_beta3.ebuild 3523
+MD5 e0f222318183bd127875a072f80b1721 openmosix-sources-2.4.22_rc2.ebuild 1491
+MD5 4931aa289d1d7a25dc59a1d33a2da647 openmosix-sources-2.6.0_beta3.ebuild 3748
MD5 41b8fa1f0e2e59514496f8f5d52bcd75 files/digest-openmosix-sources-2.4.20-r1 154
MD5 4843f8c1a5a7d5a7f0f2b37038cab7b6 files/digest-openmosix-sources-2.4.20-r2 154
MD5 32f9a2d3d0d7c57a50c7a055031a72f4 files/digest-openmosix-sources-2.4.20-r3 133
diff --git a/sys-kernel/openmosix-sources/files/digest-openmosix-sources-2.4.22_rc2 b/sys-kernel/openmosix-sources/files/digest-openmosix-sources-2.4.22_rc2
new file mode 100644
index 000000000000..6a1a6a386579
--- /dev/null
+++ b/sys-kernel/openmosix-sources/files/digest-openmosix-sources-2.4.22_rc2
@@ -0,0 +1,3 @@
+MD5 f51e12efa18bb828cf57d9d4a81b2fb1 linux-2.4.21.tar.bz2 28533733
+MD5 141f00e759d6aa30cc0b2a25f1f0d60e patch-2.4.22-rc2.bz2 4290549
+MD5 59810ffcb6197b353b798932a918d9e0 patch-2.4.22-rc2-om-20030811.bz2 247144
diff --git a/sys-kernel/openmosix-sources/files/digest-openmosix-sources-2.6.0_beta3 b/sys-kernel/openmosix-sources/files/digest-openmosix-sources-2.6.0_beta3
new file mode 100644
index 000000000000..db35786be79c
--- /dev/null
+++ b/sys-kernel/openmosix-sources/files/digest-openmosix-sources-2.6.0_beta3
@@ -0,0 +1,2 @@
+MD5 b7eb2c72aacb289b1448a8ea574ceab3 linux-2.6.0-test3.tar.bz2 32948106
+MD5 29fd00224747ebee0ff008657410e38a patch-2.6.0-test3-om-20030811.bz2 339144
diff --git a/sys-kernel/openmosix-sources/openmosix-sources-2.4.22_rc2.ebuild b/sys-kernel/openmosix-sources/openmosix-sources-2.4.22_rc2.ebuild
new file mode 100644
index 000000000000..36cdf7fa9f38
--- /dev/null
+++ b/sys-kernel/openmosix-sources/openmosix-sources-2.4.22_rc2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/openmosix-sources/openmosix-sources-2.4.22_rc2.ebuild,v 1.1 2003/08/16 12:47:56 tantive Exp $
+#OKV=original kernel version, KV=patched kernel version. They can be the same.
+
+OKV="2.4.21"
+[ "${PR}" == "r0" ] && KV=${PV/_/-}-openmosix || KV=${PV/_/-}-openmosix-${PR}
+EXTRAVERSION="`echo ${KV}|sed -e 's:[0-9]\+\.[0-9]\+\.[0-9]\+\(.*\):\1:'`"
+BASE="`echo ${KV}|sed -e s:${EXTRAVERSION}::`"
+S=${WORKDIR}/linux-${KV}
+
+ETYPE="sources"
+inherit kernel || die
+
+# What's in this kernel?
+
+# INCLUDED:
+# 2.4.22-rc2, plus:
+# 2.4.22-rc2 openmosix-2.4.22-rc2-20030811
+
+DESCRIPTION="Full sources for the Gentoo openMosix Linux kernel"
+SRC_URI="http://www.kernel.org/pub/linux/kernel/v2.4/linux-${OKV}.tar.bz2
+http://www.kernel.org/pub/linux/kernel/v2.4/testing/patch-${PV/_/-}.bz2
+http://tab.tuxfamily.org/download/openmosix/patch-2.4.22-rc2-om-20030811.bz2"
+PROVIDE="virtual/linux-sources"
+HOMEPAGE="http://www.kernel.org/ http://www.gentoo.org/ http://www.openmosix.org/"
+LICENSE="GPL-2"
+SLOT="${KV}"
+KEYWORDS="~x86 -ppc -sparc -alpha"
+
+src_unpack() {
+ unpack linux-${OKV}.tar.bz2
+ mv linux-${OKV} linux-${KV} || die
+ cd linux-${KV}
+ bzcat ${DISTDIR}/patch-${PV/_/-}.bz2|patch -p1 || die "-marcelo patch failed"
+ bzcat ${DISTDIR}/patch-2.4.22-rc2-om-20030811.bz2|patch -p1 || die "-openmosix patch failed"
+
+ kernel_universal_unpack
+}
diff --git a/sys-kernel/openmosix-sources/openmosix-sources-2.6.0_beta3.ebuild b/sys-kernel/openmosix-sources/openmosix-sources-2.6.0_beta3.ebuild
new file mode 100644
index 000000000000..fd1d1b919f36
--- /dev/null
+++ b/sys-kernel/openmosix-sources/openmosix-sources-2.6.0_beta3.ebuild
@@ -0,0 +1,122 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/openmosix-sources/openmosix-sources-2.6.0_beta3.ebuild,v 1.1 2003/08/16 12:47:56 tantive Exp $
+#OKV=original kernel version, KV=patched kernel version. They can be the same.
+
+OKV=${PV/_beta/-test}
+
+PKV=${PF/_beta/-test}
+PKV=${PKV/-r/-bk}
+PKV=${PKV//${PN}-}-openmosix
+
+[ "${PR}" == "r0" ] && KV=${PV/_beta/-test}-openmosix ||
+KV=${PV/_beta/-test}-openmosix-${PR}
+EXTRAVERSION="`echo ${KV}|sed -e 's:[0-9]\+\.[0-9]\+\.[0-9]\+\(.*\):\1:'`"
+BASE="`echo ${KV}|sed -e s:${EXTRAVERSION}::`"
+
+S=${WORKDIR}/linux-${PKV}
+ETYPE="sources"
+
+IUSE="alsa"
+DESCRIPTION="Full sources for the Development Branch of the Linux kernel
+including openMosix"
+PATCH_URI="http://www.kernel.org/pub/linux/kernel/v2.6/snapshots/patch-${PKV}.bz2"
+SRC_URI="mirror://kernel/linux/kernel/v2.6/linux-${OKV}.tar.bz2
+http://tab.tuxfamily.org/download/openmosix/patch-2.6.0-test3-om-20030811.bz2"
+HOMEPAGE="http://www.kernel.org/ http://www.gentoo.org/
+http://www.openmosix.org"
+LICENSE="GPL-2"
+SLOT="${PKV}"
+KEYWORDS="-* ~x86"
+PROVIDE="virtual/linux-sources"
+[ -n "$(use alsa)" ] && PROVIDE="${PROVIDE} virtual/alsa"
+
+if [ $ETYPE = "sources" ] && [ -z "`use build`" ]
+then
+ #console-tools is needed to solve the loadkeys fiasco; binutils version needed to avoid Athlon/PIII/SSE assembler bugs.
+ DEPEND=">=sys-devel/binutils-2.11.90.0.31"
+ RDEPEND=">=sys-libs/ncurses-5.2 dev-lang/perl
+ sys-devel/make
+ sys-apps/module-init-tools"
+fi
+
+[ -z "$LINUX_HOSTCFLAGS" ] && LINUX_HOSTCFLAGS="-Wall -Wstrict-prototypes -O2 -fomit-frame-pointer -I${S}/include"
+
+src_unpack() {
+ cd ${WORKDIR}
+ unpack linux-${OKV}.tar.bz2
+
+ mv linux-${OKV} linux-${PKV}
+ cd ${S}
+ epatch ${DISTDIR}/patch-2.6.0-test3-om-20030811.bz2
+
+ unset ARCH
+ #sometimes we have icky kernel symbols; this seems to get rid of them
+ make mrproper || die
+
+ #fix silly permissions in tarball
+# cd ${WORKDIR}
+# chown -R 0.0 *
+# chmod -R a+r-w+X,u+w *
+}
+
+src_compile() {
+ if [ "$ETYPE" = "headers" ]
+ then
+ yes "" | make oldconfig
+ echo "Ignore any errors from the yes command above."
+ fi
+}
+
+src_install() {
+ if [ "$ETYPE" = "sources" ]
+ then
+ dodir /usr/src
+ echo ">>> Copying sources..."
+ mv ${WORKDIR}/* ${D}/usr/src
+ else
+ #linux-headers
+ dodir /usr/include/linux
+ cp -ax ${S}/include/linux/* ${D}/usr/include/linux
+ rm -rf ${D}/usr/include/linux/modules
+ dodir /usr/include/asm
+ cp -ax ${S}/include/asm-i386/* ${D}/usr/include/asm
+ fi
+}
+
+pkg_preinst() {
+ if [ "$ETYPE" = "headers" ]
+ then
+ [ -L ${ROOT}usr/include/linux ] && rm ${ROOT}usr/include/linux
+ [ -L ${ROOT}usr/include/asm ] && rm ${ROOT}usr/include/asm
+ true
+ fi
+}
+
+pkg_postinst() {
+ [ "$ETYPE" = "headers" ] && return
+ if [ ! -e ${ROOT}usr/src/linux-beta ]
+ then
+
+ ln -sf linux-${PKV} ${ROOT}/usr/src/linux-beta
+ fi
+
+ echo
+ ewarn "Please note that ptyfs support has been removed from devfs"
+ ewarn "in the later 2.5.x kernels, and you have to compile it in now,"
+ ewarn "or else you will get errors when trying to open a pty."
+ ewarn "The option is File systems->Pseudo filesystems->/dev/pts"
+ ewarn "filesystem."
+ echo
+ ewarn "Also, note that you must compile in support for"
+ ewarn "input devices (Input device support->Input devices),"
+ ewarn "the virtual terminal (Character Devices->Virtual terminal),"
+ ewarn "vga_console (Graphics Support->Console...->VGA text console)"
+ ewarn "and the vt_console (Character Devices->Support for console...)."
+ ewarn "Otherwise, you will get the dreaded \"Uncompressing the Kernel\""
+ ewarn "error."
+ echo
+ einfo "Consult http://www.codemonkey.org.uk/post-halloween-2.5.txt"
+ einfo "for more info about the development series."
+ echo
+}