summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2008-01-01 13:12:29 +0000
committerMike Frysinger <vapier@gentoo.org>2008-01-01 13:12:29 +0000
commiteeab26bb36e2e796a7e44e0ddf62124b29741ba5 (patch)
treeec8725d3fe5ab541d587202c251ba99b5af0e9f5 /sys-fs
parentVersion bump. (diff)
downloadhistorical-eeab26bb36e2e796a7e44e0ddf62124b29741ba5.tar.gz
historical-eeab26bb36e2e796a7e44e0ddf62124b29741ba5.tar.bz2
historical-eeab26bb36e2e796a7e44e0ddf62124b29741ba5.zip
old
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/e2fsprogs/e2fsprogs-1.39-r1.ebuild120
-rw-r--r--sys-fs/e2fsprogs/e2fsprogs-1.39-r2.ebuild117
-rw-r--r--sys-fs/e2fsprogs/e2fsprogs-1.40.1.ebuild111
-rw-r--r--sys-fs/e2fsprogs/e2fsprogs-1.40.ebuild114
-rw-r--r--sys-fs/e2fsprogs/files/digest-e2fsprogs-1.39-r16
-rw-r--r--sys-fs/e2fsprogs/files/digest-e2fsprogs-1.39-r23
-rw-r--r--sys-fs/e2fsprogs/files/digest-e2fsprogs-1.403
-rw-r--r--sys-fs/e2fsprogs/files/digest-e2fsprogs-1.40.13
-rw-r--r--sys-fs/e2fsprogs/files/e2fsprogs-1.32-mk_cmds-cosmetic.patch11
-rw-r--r--sys-fs/e2fsprogs/files/e2fsprogs-1.36-makefile.patch106
-rw-r--r--sys-fs/e2fsprogs/files/e2fsprogs-1.38-locale.patch30
-rw-r--r--sys-fs/e2fsprogs/files/e2fsprogs-1.39-blkid-memleak.patch53
-rw-r--r--sys-fs/e2fsprogs/files/e2fsprogs-1.39-ext4-prototypes.patch12
-rw-r--r--sys-fs/e2fsprogs/files/e2fsprogs-1.39-libintl.patch11
-rw-r--r--sys-fs/e2fsprogs/files/e2fsprogs-1.39-parse-types.patch53
15 files changed, 0 insertions, 753 deletions
diff --git a/sys-fs/e2fsprogs/e2fsprogs-1.39-r1.ebuild b/sys-fs/e2fsprogs/e2fsprogs-1.39-r1.ebuild
deleted file mode 100644
index 21ac3ea9d9dc..000000000000
--- a/sys-fs/e2fsprogs/e2fsprogs-1.39-r1.ebuild
+++ /dev/null
@@ -1,120 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/e2fsprogs/e2fsprogs-1.39-r1.ebuild,v 1.7 2007/11/03 16:43:58 grobian Exp $
-
-inherit eutils flag-o-matic toolchain-funcs
-
-DESCRIPTION="Standard EXT2 and EXT3 filesystem utilities"
-HOMEPAGE="http://e2fsprogs.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz
- http://www.bullopensource.org/ext4/patches/ext4-e2fsprogs-1.39.patch.tar"
-
-LICENSE="GPL-2 BSD"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd" # do NOT stabilize
-IUSE="nls static elibc_FreeBSD"
-
-RDEPEND="~sys-libs/com_err-${PV}
- ~sys-libs/ss-${PV}
- nls? ( virtual/libintl )"
-DEPEND="${RDEPEND}
- nls? ( sys-devel/gettext )
- sys-apps/texinfo"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- # Fix locale issues while running tests #99766
- epatch "${FILESDIR}"/${PN}-1.38-tests-locale.patch
- epatch "${FILESDIR}"/${PN}-1.38-locale.patch #131462
- # Fix a cosmetic error in mk_cmds's help output.
- epatch "${FILESDIR}"/e2fsprogs-1.32-mk_cmds-cosmetic.patch
- epatch "${FILESDIR}"/e2fsprogs-1.39-util-strptime.patch
- chmod u+w po/*.po # Userpriv fix #27348
- # Clean up makefile to suck less
- epatch "${FILESDIR}"/e2fsprogs-1.39-makefile.patch
- epatch "${FILESDIR}"/e2fsprogs-1.39-parse-types.patch #146903
- # Fixes libintl handling on non-glibc #122368
- epatch "${FILESDIR}"/${PN}-1.39-libintl.patch
- # Add ext4 support #156697
- epatch $(sed -e 's:^:patches/:g' patches/series)
- epatch "${FILESDIR}"/e2fsprogs-1.39-ext4-prototypes.patch
-
- # kernel headers use the same defines as e2fsprogs and can cause issues #48829
- sed -i \
- -e 's:CONFIG_JBD_DEBUG:__CONFIG_JBD_DEBUG__E2FS:g' \
- $(grep -rl CONFIG_JBD_DEBUG *) \
- || die "sed jbd debug failed"
-
- # fake out files we forked into sep packages
- sed -i \
- -e '/^LIB_SUBDIRS/s:lib/et::' \
- -e '/^LIB_SUBDIRS/s:lib/ss::' \
- Makefile.in || die "remove subdirs"
- ln -s "${ROOT}"/usr/$(get_libdir)/libcom_err.a lib/libcom_err.a
- ln -s "${ROOT}"/$(get_libdir)/libcom_err.so lib/libcom_err.so
- ln -s /usr/bin/mk_cmds lib/ss/mk_cmds
- ln -s "${ROOT}"/usr/include/ss/ss_err.h lib/ss/
- ln -s "${ROOT}"/$(get_libdir)/libss.so lib/libss.so
-
- # sanity check for Bug 105304
- if [[ -z ${USERLAND} ]] ; then
- eerror "You just hit Bug 105304, please post your 'emerge info' here:"
- eerror "http://bugs.gentoo.org/105304"
- die "Aborting to prevent screwing your system"
- fi
-}
-
-src_compile() {
- # Keep the package from doing silly things
- export LDCONFIG=/bin/true
- export CC=$(tc-getCC)
- export STRIP=/bin/true
-
- econf \
- --bindir=/bin \
- --sbindir=/sbin \
- --enable-elf-shlibs \
- --with-ldopts="${LDFLAGS}" \
- $(use_enable !static dynamic-e2fsck) \
- --without-included-gettext \
- $(use_enable nls) \
- $(use_enable userland_GNU fsck) \
- || die
- if [[ ${CHOST} != *-uclibc ]] && grep -qs 'USE_INCLUDED_LIBINTL.*yes' config.{log,status} ; then
- eerror "INTL sanity check failed, aborting build."
- eerror "Please post your ${S}/config.log file as an"
- eerror "attachment to http://bugs.gentoo.org/show_bug.cgi?id=81096"
- die "Preventing included intl cruft from building"
- fi
- # Parallel make sometimes fails
- emake -j1 COMPILE_ET=compile_et || die
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die
- dodoc ChangeLog README RELEASE-NOTES SHLIBS
- docinto e2fsck
- dodoc e2fsck/ChangeLog e2fsck/CHANGES
-
- # Move shared libraries to /lib/, install static libraries to /usr/lib/,
- # and install linker scripts to /usr/lib/.
- dodir /$(get_libdir)
- mv "${D}"/usr/$(get_libdir)/*.so* "${D}"/$(get_libdir)/
- dolib.a lib/*.a || die "dolib.a"
- rm -f "${D}"/usr/$(get_libdir)/libcom_err.a #125146
- local x
- cd "${D}"/$(get_libdir)
- for x in *.so ; do
- gen_usr_ldscript ${x} || die "gen ldscript ${x}"
- done
-
- # move 'useless' stuff to /usr/
- dosbin "${D}"/sbin/mklost+found
- rm -f "${D}"/sbin/mklost+found
-
- # these manpages are already provided by FreeBSD libc
- use elibc_FreeBSD && \
- rm -f "${D}"/usr/share/man/man3/{uuid,uuid_compare}.3 \
- "${D}"/usr/share/man/man1/uuidgen.1
-}
diff --git a/sys-fs/e2fsprogs/e2fsprogs-1.39-r2.ebuild b/sys-fs/e2fsprogs/e2fsprogs-1.39-r2.ebuild
deleted file mode 100644
index a32c6f7fd1a5..000000000000
--- a/sys-fs/e2fsprogs/e2fsprogs-1.39-r2.ebuild
+++ /dev/null
@@ -1,117 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/e2fsprogs/e2fsprogs-1.39-r2.ebuild,v 1.13 2007/11/03 16:43:58 grobian Exp $
-
-inherit eutils flag-o-matic toolchain-funcs
-
-DESCRIPTION="Standard EXT2 and EXT3 filesystem utilities"
-HOMEPAGE="http://e2fsprogs.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2 BSD"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 m68k mips ppc ppc64 s390 sh sparc x86 ~x86-fbsd"
-IUSE="nls static elibc_FreeBSD"
-
-RDEPEND="~sys-libs/com_err-${PV}
- ~sys-libs/ss-${PV}
- nls? ( virtual/libintl )"
-DEPEND="${RDEPEND}
- nls? ( sys-devel/gettext )
- sys-apps/texinfo"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/${P}-blkid-memleak.patch #171844
- # Fix locale issues while running tests #99766
- epatch "${FILESDIR}"/${PN}-1.38-tests-locale.patch
- epatch "${FILESDIR}"/${PN}-1.38-locale.patch #131462
- # Fix a cosmetic error in mk_cmds's help output.
- epatch "${FILESDIR}"/e2fsprogs-1.32-mk_cmds-cosmetic.patch
- epatch "${FILESDIR}"/e2fsprogs-1.39-util-strptime.patch
- chmod u+w po/*.po # Userpriv fix #27348
- # Clean up makefile to suck less
- epatch "${FILESDIR}"/e2fsprogs-1.39-makefile.patch
- epatch "${FILESDIR}"/e2fsprogs-1.39-parse-types.patch #146903
- # Fixes libintl handling on non-glibc #122368
- epatch "${FILESDIR}"/${PN}-1.39-libintl.patch
-
- # kernel headers use the same defines as e2fsprogs and can cause issues #48829
- sed -i \
- -e 's:CONFIG_JBD_DEBUG:__CONFIG_JBD_DEBUG__E2FS:g' \
- $(grep -rl CONFIG_JBD_DEBUG *) \
- || die "sed jbd debug failed"
-
- # fake out files we forked into sep packages
- sed -i \
- -e '/^LIB_SUBDIRS/s:lib/et::' \
- -e '/^LIB_SUBDIRS/s:lib/ss::' \
- Makefile.in || die "remove subdirs"
- ln -s "${ROOT}"/usr/$(get_libdir)/libcom_err.a lib/libcom_err.a
- ln -s "${ROOT}"/$(get_libdir)/libcom_err.so lib/libcom_err.so
- ln -s /usr/bin/mk_cmds lib/ss/mk_cmds
- ln -s "${ROOT}"/usr/include/ss/ss_err.h lib/ss/
- ln -s "${ROOT}"/$(get_libdir)/libss.so lib/libss.so
-
- # sanity check for Bug 105304
- if [[ -z ${USERLAND} ]] ; then
- eerror "You just hit Bug 105304, please post your 'emerge info' here:"
- eerror "http://bugs.gentoo.org/105304"
- die "Aborting to prevent screwing your system"
- fi
-}
-
-src_compile() {
- # Keep the package from doing silly things
- export LDCONFIG=/bin/true
- export CC=$(tc-getCC)
- export STRIP=/bin/true
-
- econf \
- --bindir=/bin \
- --sbindir=/sbin \
- --enable-elf-shlibs \
- --with-ldopts="${LDFLAGS}" \
- $(use_enable !static dynamic-e2fsck) \
- --without-included-gettext \
- $(use_enable nls) \
- $(use_enable userland_GNU fsck) \
- || die
- if [[ ${CHOST} != *-uclibc ]] && grep -qs 'USE_INCLUDED_LIBINTL.*yes' config.{log,status} ; then
- eerror "INTL sanity check failed, aborting build."
- eerror "Please post your ${S}/config.log file as an"
- eerror "attachment to http://bugs.gentoo.org/show_bug.cgi?id=81096"
- die "Preventing included intl cruft from building"
- fi
- # Parallel make sometimes fails
- emake -j1 COMPILE_ET=compile_et || die
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die
- dodoc ChangeLog README RELEASE-NOTES SHLIBS
- docinto e2fsck
- dodoc e2fsck/ChangeLog e2fsck/CHANGES
-
- # Move shared libraries to /lib/, install static libraries to /usr/lib/,
- # and install linker scripts to /usr/lib/.
- dodir /$(get_libdir)
- mv "${D}"/usr/$(get_libdir)/*.so* "${D}"/$(get_libdir)/
- dolib.a lib/*.a || die "dolib.a"
- rm -f "${D}"/usr/$(get_libdir)/libcom_err.a #125146
- local x
- cd "${D}"/$(get_libdir)
- for x in *.so ; do
- gen_usr_ldscript ${x} || die "gen ldscript ${x}"
- done
-
- # move 'useless' stuff to /usr/
- dosbin "${D}"/sbin/mklost+found
- rm -f "${D}"/sbin/mklost+found
-
- # these manpages are already provided by FreeBSD libc
- use elibc_FreeBSD && \
- rm -f "${D}"/usr/share/man/man3/{uuid,uuid_compare}.3 \
- "${D}"/usr/share/man/man1/uuidgen.1
-}
diff --git a/sys-fs/e2fsprogs/e2fsprogs-1.40.1.ebuild b/sys-fs/e2fsprogs/e2fsprogs-1.40.1.ebuild
deleted file mode 100644
index fb3fb4e485fb..000000000000
--- a/sys-fs/e2fsprogs/e2fsprogs-1.40.1.ebuild
+++ /dev/null
@@ -1,111 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/e2fsprogs/e2fsprogs-1.40.1.ebuild,v 1.3 2007/11/03 16:43:58 grobian Exp $
-
-inherit eutils flag-o-matic toolchain-funcs
-
-DESCRIPTION="Standard EXT2 and EXT3 filesystem utilities"
-HOMEPAGE="http://e2fsprogs.sourceforge.net/"
-SRC_URI="mirror://sourceforge/e2fsprogs/${P}.tar.gz"
-
-LICENSE="GPL-2 BSD"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
-IUSE="nls static elibc_FreeBSD"
-
-RDEPEND="~sys-libs/com_err-${PV}
- ~sys-libs/ss-${PV}
- nls? ( virtual/libintl )"
-DEPEND="${RDEPEND}
- nls? ( sys-devel/gettext )
- sys-apps/texinfo"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- # Fix locale issues while running tests #99766
- epatch "${FILESDIR}"/${PN}-1.38-tests-locale.patch #99766
- epatch "${FILESDIR}"/e2fsprogs-1.39-util-strptime.patch
- chmod u+w po/*.po # Userpriv fix #27348
- # Clean up makefile to suck less
- epatch "${FILESDIR}"/e2fsprogs-1.39-makefile.patch
- epatch "${FILESDIR}"/${PN}-1.40-libintl.patch #122368
-
- # kernel headers use the same defines as e2fsprogs and can cause issues #48829
- sed -i \
- -e 's:CONFIG_JBD_DEBUG:__CONFIG_JBD_DEBUG__E2FS:g' \
- $(grep -rl CONFIG_JBD_DEBUG *) \
- || die "sed jbd debug failed"
-
- # fake out files we forked into sep packages
- sed -i \
- -e '/^LIB_SUBDIRS/s:lib/et::' \
- -e '/^LIB_SUBDIRS/s:lib/ss::' \
- Makefile.in || die "remove subdirs"
- ln -s "${ROOT}"/usr/$(get_libdir)/libcom_err.a lib/libcom_err.a
- ln -s "${ROOT}"/$(get_libdir)/libcom_err.so lib/libcom_err.so
- ln -s /usr/bin/mk_cmds lib/ss/mk_cmds
- ln -s "${ROOT}"/usr/include/ss/ss_err.h lib/ss/
- ln -s "${ROOT}"/$(get_libdir)/libss.so lib/libss.so
-
- # sanity check for Bug 105304
- if [[ -z ${USERLAND} ]] ; then
- eerror "You just hit Bug 105304, please post your 'emerge info' here:"
- eerror "http://bugs.gentoo.org/105304"
- die "Aborting to prevent screwing your system"
- fi
-}
-
-src_compile() {
- # Keep the package from doing silly things
- export LDCONFIG=/bin/true
- export CC=$(tc-getCC)
- export STRIP=/bin/true
-
- econf \
- --bindir=/bin \
- --sbindir=/sbin \
- --enable-elf-shlibs \
- --with-ldopts="${LDFLAGS}" \
- $(use_enable !static dynamic-e2fsck) \
- --without-included-gettext \
- $(use_enable nls) \
- $(use_enable userland_GNU fsck) \
- || die
- if [[ ${CHOST} != *-uclibc ]] && grep -qs 'USE_INCLUDED_LIBINTL.*yes' config.{log,status} ; then
- eerror "INTL sanity check failed, aborting build."
- eerror "Please post your ${S}/config.log file as an"
- eerror "attachment to http://bugs.gentoo.org/show_bug.cgi?id=81096"
- die "Preventing included intl cruft from building"
- fi
- # Parallel make sometimes fails
- emake -j1 COMPILE_ET=compile_et || die
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die
- dodoc ChangeLog README RELEASE-NOTES SHLIBS
- docinto e2fsck
- dodoc e2fsck/ChangeLog e2fsck/CHANGES
-
- # Move shared libraries to /lib/, install static libraries to /usr/lib/,
- # and install linker scripts to /usr/lib/.
- dodir /$(get_libdir)
- mv "${D}"/usr/$(get_libdir)/*.so* "${D}"/$(get_libdir)/
- dolib.a lib/*.a || die "dolib.a"
- rm -f "${D}"/usr/$(get_libdir)/libcom_err.a #125146
- local x
- cd "${D}"/$(get_libdir)
- for x in *.so ; do
- gen_usr_ldscript ${x} || die "gen ldscript ${x}"
- done
-
- # move 'useless' stuff to /usr/
- dosbin "${D}"/sbin/mklost+found
- rm -f "${D}"/sbin/mklost+found
-
- # these manpages are already provided by FreeBSD libc
- use elibc_FreeBSD && \
- rm -f "${D}"/usr/share/man/man3/{uuid,uuid_compare}.3 \
- "${D}"/usr/share/man/man1/uuidgen.1
-}
diff --git a/sys-fs/e2fsprogs/e2fsprogs-1.40.ebuild b/sys-fs/e2fsprogs/e2fsprogs-1.40.ebuild
deleted file mode 100644
index 2d1671524a5c..000000000000
--- a/sys-fs/e2fsprogs/e2fsprogs-1.40.ebuild
+++ /dev/null
@@ -1,114 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/e2fsprogs/e2fsprogs-1.40.ebuild,v 1.3 2007/11/03 16:43:58 grobian Exp $
-
-inherit eutils flag-o-matic toolchain-funcs
-
-DESCRIPTION="Standard EXT2 and EXT3 filesystem utilities"
-HOMEPAGE="http://e2fsprogs.sourceforge.net/"
-SRC_URI="mirror://sourceforge/e2fsprogs/${P}.tar.gz"
-
-LICENSE="GPL-2 BSD"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
-IUSE="nls static elibc_FreeBSD"
-
-RDEPEND="~sys-libs/com_err-${PV}
- ~sys-libs/ss-${PV}
- nls? ( virtual/libintl )"
-DEPEND="${RDEPEND}
- nls? ( sys-devel/gettext )
- sys-apps/texinfo"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- # Fix locale issues while running tests #99766
- epatch "${FILESDIR}"/${PN}-1.38-tests-locale.patch #99766
- # Fix a cosmetic error in mk_cmds's help output.
- epatch "${FILESDIR}"/e2fsprogs-1.32-mk_cmds-cosmetic.patch
- epatch "${FILESDIR}"/e2fsprogs-1.39-util-strptime.patch
- chmod u+w po/*.po # Userpriv fix #27348
- # Clean up makefile to suck less
- epatch "${FILESDIR}"/e2fsprogs-1.39-makefile.patch
- epatch "${FILESDIR}"/e2fsprogs-1.39-parse-types.patch #146903
- epatch "${FILESDIR}"/${PN}-1.40-libintl.patch #122368
-
- # kernel headers use the same defines as e2fsprogs and can cause issues #48829
- sed -i \
- -e 's:CONFIG_JBD_DEBUG:__CONFIG_JBD_DEBUG__E2FS:g' \
- $(grep -rl CONFIG_JBD_DEBUG *) \
- || die "sed jbd debug failed"
-
- # fake out files we forked into sep packages
- sed -i \
- -e '/^LIB_SUBDIRS/s:lib/et::' \
- -e '/^LIB_SUBDIRS/s:lib/ss::' \
- Makefile.in || die "remove subdirs"
- ln -s "${ROOT}"/usr/$(get_libdir)/libcom_err.a lib/libcom_err.a
- ln -s "${ROOT}"/$(get_libdir)/libcom_err.so lib/libcom_err.so
- ln -s /usr/bin/mk_cmds lib/ss/mk_cmds
- ln -s "${ROOT}"/usr/include/ss/ss_err.h lib/ss/
- ln -s "${ROOT}"/$(get_libdir)/libss.so lib/libss.so
-
- # sanity check for Bug 105304
- if [[ -z ${USERLAND} ]] ; then
- eerror "You just hit Bug 105304, please post your 'emerge info' here:"
- eerror "http://bugs.gentoo.org/105304"
- die "Aborting to prevent screwing your system"
- fi
-}
-
-src_compile() {
- # Keep the package from doing silly things
- export LDCONFIG=/bin/true
- export CC=$(tc-getCC)
- export STRIP=/bin/true
-
- econf \
- --bindir=/bin \
- --sbindir=/sbin \
- --enable-elf-shlibs \
- --with-ldopts="${LDFLAGS}" \
- $(use_enable !static dynamic-e2fsck) \
- --without-included-gettext \
- $(use_enable nls) \
- $(use_enable userland_GNU fsck) \
- || die
- if [[ ${CHOST} != *-uclibc ]] && grep -qs 'USE_INCLUDED_LIBINTL.*yes' config.{log,status} ; then
- eerror "INTL sanity check failed, aborting build."
- eerror "Please post your ${S}/config.log file as an"
- eerror "attachment to http://bugs.gentoo.org/show_bug.cgi?id=81096"
- die "Preventing included intl cruft from building"
- fi
- # Parallel make sometimes fails
- emake -j1 COMPILE_ET=compile_et || die
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die
- dodoc ChangeLog README RELEASE-NOTES SHLIBS
- docinto e2fsck
- dodoc e2fsck/ChangeLog e2fsck/CHANGES
-
- # Move shared libraries to /lib/, install static libraries to /usr/lib/,
- # and install linker scripts to /usr/lib/.
- dodir /$(get_libdir)
- mv "${D}"/usr/$(get_libdir)/*.so* "${D}"/$(get_libdir)/
- dolib.a lib/*.a || die "dolib.a"
- rm -f "${D}"/usr/$(get_libdir)/libcom_err.a #125146
- local x
- cd "${D}"/$(get_libdir)
- for x in *.so ; do
- gen_usr_ldscript ${x} || die "gen ldscript ${x}"
- done
-
- # move 'useless' stuff to /usr/
- dosbin "${D}"/sbin/mklost+found
- rm -f "${D}"/sbin/mklost+found
-
- # these manpages are already provided by FreeBSD libc
- use elibc_FreeBSD && \
- rm -f "${D}"/usr/share/man/man3/{uuid,uuid_compare}.3 \
- "${D}"/usr/share/man/man1/uuidgen.1
-}
diff --git a/sys-fs/e2fsprogs/files/digest-e2fsprogs-1.39-r1 b/sys-fs/e2fsprogs/files/digest-e2fsprogs-1.39-r1
deleted file mode 100644
index 2580942c50b2..000000000000
--- a/sys-fs/e2fsprogs/files/digest-e2fsprogs-1.39-r1
+++ /dev/null
@@ -1,6 +0,0 @@
-MD5 06f7806782e357797fad1d34b7ced0c6 e2fsprogs-1.39.tar.gz 3695111
-RMD160 67e77a7cbf0e719fa8b5a8ac6285b334e1c3481b e2fsprogs-1.39.tar.gz 3695111
-SHA256 dc2033447e69a1612881151f6f163e8a3b80e51d16f5e8b3576f3f8ccb325ea3 e2fsprogs-1.39.tar.gz 3695111
-MD5 9c966817dcb61a515b34497f4517ebb9 ext4-e2fsprogs-1.39.patch.tar 716800
-RMD160 5b20e7f2133e7339d22ee85d39c92cd7af920bb9 ext4-e2fsprogs-1.39.patch.tar 716800
-SHA256 0472210d002808f1505f96b1ca0e667f3cc2a6d585bca7d9a00130d6fe0ca38e ext4-e2fsprogs-1.39.patch.tar 716800
diff --git a/sys-fs/e2fsprogs/files/digest-e2fsprogs-1.39-r2 b/sys-fs/e2fsprogs/files/digest-e2fsprogs-1.39-r2
deleted file mode 100644
index 7e58444d768b..000000000000
--- a/sys-fs/e2fsprogs/files/digest-e2fsprogs-1.39-r2
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 06f7806782e357797fad1d34b7ced0c6 e2fsprogs-1.39.tar.gz 3695111
-RMD160 67e77a7cbf0e719fa8b5a8ac6285b334e1c3481b e2fsprogs-1.39.tar.gz 3695111
-SHA256 dc2033447e69a1612881151f6f163e8a3b80e51d16f5e8b3576f3f8ccb325ea3 e2fsprogs-1.39.tar.gz 3695111
diff --git a/sys-fs/e2fsprogs/files/digest-e2fsprogs-1.40 b/sys-fs/e2fsprogs/files/digest-e2fsprogs-1.40
deleted file mode 100644
index 9ae46389c607..000000000000
--- a/sys-fs/e2fsprogs/files/digest-e2fsprogs-1.40
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 40095356dbe3d970b898469fe598317c e2fsprogs-1.40.tar.gz 4160254
-RMD160 50b80f50c8565514a241a8dbef012139bb5d8313 e2fsprogs-1.40.tar.gz 4160254
-SHA256 3a506f345e5da098c6c37239eb99e92d11a4100490245e102b13c446d1124296 e2fsprogs-1.40.tar.gz 4160254
diff --git a/sys-fs/e2fsprogs/files/digest-e2fsprogs-1.40.1 b/sys-fs/e2fsprogs/files/digest-e2fsprogs-1.40.1
deleted file mode 100644
index 6d9af5ec94b7..000000000000
--- a/sys-fs/e2fsprogs/files/digest-e2fsprogs-1.40.1
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 6bde5e7ca69ebf939098906c203d754c e2fsprogs-1.40.1.tar.gz 3957193
-RMD160 5b468a143ac73da34601ad2d2f358e60091b4f08 e2fsprogs-1.40.1.tar.gz 3957193
-SHA256 5db8bd0d4af126a112e784d40f81187a1d111d36e7b86a6ef993806a6ee02d39 e2fsprogs-1.40.1.tar.gz 3957193
diff --git a/sys-fs/e2fsprogs/files/e2fsprogs-1.32-mk_cmds-cosmetic.patch b/sys-fs/e2fsprogs/files/e2fsprogs-1.32-mk_cmds-cosmetic.patch
deleted file mode 100644
index 52b6d75b6c9f..000000000000
--- a/sys-fs/e2fsprogs/files/e2fsprogs-1.32-mk_cmds-cosmetic.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- e2fsprogs-1.32/lib/ss/mk_cmds.sh.in.orig 2002-12-26 18:44:42.000000000 +0200
-+++ e2fsprogs-1.32/lib/ss/mk_cmds.sh.in 2002-12-26 18:45:33.000000000 +0200
-@@ -31,7 +31,7 @@
- TMP="ct$$.c"
-
- if test ! -f "$FILE" ; then
-- echo "$FILE: File not found"
-+ echo "mk_cmds: $FILE: File not found"
- exit 1;
- fi
-
diff --git a/sys-fs/e2fsprogs/files/e2fsprogs-1.36-makefile.patch b/sys-fs/e2fsprogs/files/e2fsprogs-1.36-makefile.patch
deleted file mode 100644
index 807759a3c652..000000000000
--- a/sys-fs/e2fsprogs/files/e2fsprogs-1.36-makefile.patch
+++ /dev/null
@@ -1,106 +0,0 @@
---- Makefile.in
-+++ Makefile.in
-@@ -48,3 +48,3 @@
- install-shlibs-libs-recursive install-doc-libs
-- if test ! -d e2fsck && test ! -d debugfs && test ! -d misc && test ! -d ext2ed ; then $(MAKE) install-libs ; fi
-+ $(MAKE) install-libs
-
---- e2fsck/Makefile.in
-+++ e2fsck/Makefile.in
-@@ -163,6 +163,6 @@
- @echo " LINK $(root_sbindir)/fsck.ext2"
-- @$(LN) -f $(DESTDIR)$(root_sbindir)/e2fsck \
-+ @$(LN_S) -f e2fsck \
- $(DESTDIR)$(root_sbindir)/fsck.ext2
- @echo " LINK $(root_sbindir)/fsck.ext3"
-- @$(LN) -f $(DESTDIR)$(root_sbindir)/e2fsck \
-+ @$(LN_S) -f e2fsck \
- $(DESTDIR)$(root_sbindir)/fsck.ext3
-@@ -176,6 +176,6 @@
- @echo " LINK $(man8dir)/fsck.ext2.8"
-- @$(LN) -f $(DESTDIR)$(man8dir)/e2fsck.8 \
-+ @$(LN_S) -f e2fsck.8 \
- $(DESTDIR)$(man8dir)/fsck.ext2.8
- @echo " LINK $(man8dir)/fsck.ext3.8"
-- @$(LN) -f $(DESTDIR)$(man8dir)/e2fsck.8 \
-+ @$(LN_S) -f e2fsck.8 \
- $(DESTDIR)$(man8dir)/fsck.ext3.8
---- misc/Makefile.in
-+++ misc/Makefile.in
-@@ -228,12 +228,12 @@
- @echo " LINK $(root_sbindir)/mkfs.ext2"
-- @$(LN) -f $(DESTDIR)$(root_sbindir)/mke2fs \
-+ @$(LN_S) -f mke2fs \
- $(DESTDIR)$(root_sbindir)/mkfs.ext2
- @echo " LINK $(root_sbindir)/mkfs.ext3"
-- @$(LN) -f $(DESTDIR)$(root_sbindir)/mke2fs \
-+ @$(LN_S) -f mke2fs \
- $(DESTDIR)$(root_sbindir)/mkfs.ext3
- @echo " LINK $(root_sbindir)/e2label"
-- @$(LN) -f $(DESTDIR)$(root_sbindir)/tune2fs \
-+ @$(LN_S) -f tune2fs \
- $(DESTDIR)$(root_sbindir)/e2label
- @echo " LINK $(root_sbindir)/findfs"
-- @$(LN) -f $(DESTDIR)$(root_sbindir)/tune2fs \
-+ @$(LN_S) -f tune2fs \
- $(DESTDIR)$(root_sbindir)/findfs
-@@ -257,6 +257,6 @@
- @echo " LINK mkfs.ext2.8"
-- @$(LN) -f $(DESTDIR)$(man8dir)/mke2fs.8 \
-+ @$(LN_S) -f mke2fs.8 \
- $(DESTDIR)$(man8dir)/mkfs.ext2.8
- @echo " LINK mkfs.ext3.8"
-- @$(LN) -f $(DESTDIR)$(man8dir)/mke2fs.8 \
-+ @$(LN_S) -f mke2fs.8 \
- $(DESTDIR)$(man8dir)/mkfs.ext3.8
---- lib/uuid/Makefile.in
-+++ lib/uuid/Makefile.in
-@@ -148,5 +148,5 @@
- @echo " LINK $(man3dir)/uuid_generate_random.3"
-- @$(LN) -f $(DESTDIR)$(man3dir)/uuid_generate.3 $(DESTDIR)$(man3dir)/uuid_generate_random.3
-+ @$(LN_S) -f uuid_generate.3 $(DESTDIR)$(man3dir)/uuid_generate_random.3
- @echo " LINK $(man3dir)/uuid_generate_time.3"
-- @$(LN) -f $(DESTDIR)$(man3dir)/uuid_generate.3 $(DESTDIR)$(man3dir)/uuid_generate_time.3
-+ @$(LN_S) -f uuid_generate.3 $(DESTDIR)$(man3dir)/uuid_generate_time.3
- @echo " INSTALL_DATA $(libdir)/pkgconfig/uuid.pc"
---- lib/Makefile.elf-lib
-+++ lib/Makefile.elf-lib
-@@ -26,7 +26,7 @@
-
- $(ELF_LIB): $(OBJS)
- @echo " GEN_ELF_SOLIB $(ELF_LIB)"
-- @(cd elfshared; $(CC) --shared -o $(ELF_LIB) \
-+ @(cd elfshared; $(CC) --shared -o $(ELF_LIB) $(LDFLAGS) \
- -Wl,-soname,$(ELF_SONAME) $(OBJS) $(ELF_OTHER_LIBS))
- @$(MV) elfshared/$(ELF_LIB) .
- @$(RM) -f ../$(ELF_LIB) ../$(ELF_IMAGE).so ../$(ELF_SONAME)
-@@ -49,3 +49,3 @@
- @echo " SYMLINK $(libdir)/$(ELF_IMAGE).so"
-- @$(LN_S) -f $(ELF_INSTALL_DIR)/$(ELF_SONAME) \
-+ @$(LN_S) -f $(ELF_SONAME) \
- $(DESTDIR)$(libdir)/$(ELF_IMAGE).so
---- util/Makefile.in
-+++ util/Makefile.in
-@@ -15,7 +15,7 @@
-
- .c.o:
- @echo " CC $<"
-- @$(BUILD_CC) -c $(ALL_CFLAGS) $< -o $@
-+ @$(BUILD_CC) -c $(DEFS) $< -o $@
-
- PROGS= subst
-
-@@ -23,11 +23,11 @@
-
- subst: subst.o
- @echo " LD $@"
-- @$(BUILD_CC) $(ALL_LDFLAGS) -o subst subst.o
-+ @$(BUILD_CC) -o subst subst.o
-
- copy_sparse: copy_sparse.o
- @echo " LD $@"
-- @$(BUILD_CC) $(ALL_LDFLAGS) -o copy_sparse copy_sparse.o
-+ @$(BUILD_CC) -o copy_sparse copy_sparse.o
-
- gen-tarball: $(srcdir)/gen-tarball.in $(top_builddir)/config.status
- @echo " CONFIG.STATUS $@"
diff --git a/sys-fs/e2fsprogs/files/e2fsprogs-1.38-locale.patch b/sys-fs/e2fsprogs/files/e2fsprogs-1.38-locale.patch
deleted file mode 100644
index 2a0919cf44be..000000000000
--- a/sys-fs/e2fsprogs/files/e2fsprogs-1.38-locale.patch
+++ /dev/null
@@ -1,30 +0,0 @@
-Fix issues with non-C locales (like ee)
-
-http://bugs.gentoo.org/104116
-http://bugs.gentoo.org/131462
-
---- e2fsprogs/lib/et/compile_et.sh.in
-+++ e2fsprogs/lib/et/compile_et.sh.in
-@@ -1,6 +1,10 @@
- #!/bin/sh
- #
- #
-+
-+# the awk scripts here use a-z and such
-+export LC_ALL="C"
-+
- AWK=@AWK@
- DIR="${DIR-@datadir@/et}"
- ET_DIR="@ET_DIR@"
---- e2fsprogs/lib/ss/mk_cmds.sh.in
-+++ e2fsprogs/lib/ss/mk_cmds.sh.in
-@@ -2,6 +2,9 @@
- #
- #
-
-+# the awk/sed scripts here use a-z and such
-+export LC_ALL="C"
-+
- DIR="${DIR-@datadir@/ss}"
- SS_DIR="@SS_DIR@"
- AWK=@AWK@
diff --git a/sys-fs/e2fsprogs/files/e2fsprogs-1.39-blkid-memleak.patch b/sys-fs/e2fsprogs/files/e2fsprogs-1.39-blkid-memleak.patch
deleted file mode 100644
index ce8ee8a4bcc9..000000000000
--- a/sys-fs/e2fsprogs/files/e2fsprogs-1.39-blkid-memleak.patch
+++ /dev/null
@@ -1,53 +0,0 @@
-http://bugs.gentoo.org/171844
-
-# HG changeset patch
-# User tytso@mit.edu
-# Date Tue Mar 6 19:56:18 2007 -0500
-# Node ID 5a2a75111d7a6fc4b5ee99663f252a42d5a2b227
-# parent: 69a666bd25f57107a09e5bad0a158b8a810e6a63
-Fix memory leak in blkid library
-
-Addresses Debian Bug: #413661
-
-Signed-off-by: "Theodore Ts'o" <tytso@mit.edu>
-
-2007-03-06 Theodore Tso <tytso@mit.edu>
-
- * devname.c (dm_probe_all), probe.c (blkid_verify): Fix memory
- leak. (Addresses Debian Bug #413661)
-
---- a/lib/blkid/devname.c Sun Mar 4 08:17:18 2007 -0500
-+++ b/lib/blkid/devname.c Tue Mar 6 19:56:18 2007 -0500
-@@ -305,6 +305,7 @@
- probe_one(cache, device, dev, BLKID_PRI_DM, only_if_new);
-
- try_next:
-+ free(device);
- next = names->next;
- } while (next);
-
---- a/lib/blkid/probe.c Sun Mar 4 08:17:18 2007 -0500
-+++ b/lib/blkid/probe.c Tue Mar 6 19:56:18 2007 -0500
-@@ -886,9 +886,9 @@
- }
-
- if (!dev->bid_type) {
-- if (probe.fd >= 0) close(probe.fd);
- blkid_free_dev(dev);
-- return NULL;
-+ dev = 0;
-+ goto found_type;
- }
-
- found_type:
-@@ -908,7 +908,8 @@
- free(probe.sbbuf);
- if (probe.buf)
- free(probe.buf);
-- close(probe.fd);
-+ if (probe.fd >= 0)
-+ close(probe.fd);
-
- return dev;
- }
-
diff --git a/sys-fs/e2fsprogs/files/e2fsprogs-1.39-ext4-prototypes.patch b/sys-fs/e2fsprogs/files/e2fsprogs-1.39-ext4-prototypes.patch
deleted file mode 100644
index 0da1bbf3aeab..000000000000
--- a/sys-fs/e2fsprogs/files/e2fsprogs-1.39-ext4-prototypes.patch
+++ /dev/null
@@ -1,12 +0,0 @@
---- e2fsprogs-1.39/lib/ext2fs/ext2fs.h
-+++ e2fsprogs-1.39/lib/ext2fs/ext2fs.h
-@@ -963,6 +963,9 @@
- int bufsize);
- extern void ext2fs_swap_inode(ext2_filsys fs,struct ext2_inode *t,
- struct ext2_inode *f, int hostorder);
-+extern void ext2fs_swap_extent(struct ext4_extent *ex);
-+extern void ext2fs_swap_extent_index(struct ext4_extent_idx *ix);
-+extern void ext2fs_swap_extent_header(struct ext4_extent_header *eh);
-
- /* valid_blk.c */
- extern int ext2fs_inode_has_valid_blocks(struct ext2_inode *inode);
diff --git a/sys-fs/e2fsprogs/files/e2fsprogs-1.39-libintl.patch b/sys-fs/e2fsprogs/files/e2fsprogs-1.39-libintl.patch
deleted file mode 100644
index 85549a228438..000000000000
--- a/sys-fs/e2fsprogs/files/e2fsprogs-1.39-libintl.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- e2fsprogs-1.39/MCONFIG.in
-+++ e2fsprogs-1.39/MCONFIG.in
-@@ -71,7 +71,7 @@
- LIBEXT2FS = $(LIB)/libext2fs@LIB_EXT@
- LIBUUID = $(LIB)/libuuid@LIB_EXT@ @SOCKET_LIB@
- LIBBLKID = $(LIB)/libblkid@LIB_EXT@ $(DEVMAPPER_LIBS)
--LIBINTL = @LIBINTL@
-+LIBINTL = @LTLIBINTL@
- DEPLIBUUID = $(LIB)/libuuid@LIB_EXT@
-
- STATIC_LIBSS = $(LIB)/libss@STATIC_LIB_EXT@
diff --git a/sys-fs/e2fsprogs/files/e2fsprogs-1.39-parse-types.patch b/sys-fs/e2fsprogs/files/e2fsprogs-1.39-parse-types.patch
deleted file mode 100644
index 8af9128d6591..000000000000
--- a/sys-fs/e2fsprogs/files/e2fsprogs-1.39-parse-types.patch
+++ /dev/null
@@ -1,53 +0,0 @@
-make this script suck less:
- - dont use known files in /tmp
- - dont use absolute paths to headers
- - dont hardcode gcc/cc
- - dont spit out warnings about incompat func types
-
-http://bugs.gentoo.org/146903
-
---- config/parse-types.sh
-+++ config/parse-types.sh
-@@ -1,27 +1,20 @@
- #!/bin/sh
-
--ASM_TYPES=/usr/include/asm/types.h
--
--if test ! -f $ASM_TYPES
--then
-- echo "" > asm_types.h
-- echo "No asm_types file found"
-- exit 1
--fi
--
--cat > /tmp/sed.script << "EOF"
-+echo '#include <asm/types.h>' | ${CPP-${CC-gcc} -E} - | sed \
-+"
- /^#/d
- /^$/d
- s/__extension__ //
- s/typedef \(.*\) __u\([1-9]*\);/#define __U\2_TYPEDEF \1/
- s/typedef \(.*\) __s\([1-9]*\);/#define __S\2_TYPEDEF \1/
--EOF
--
--gcc -E $ASM_TYPES | sed -f /tmp/sed.script | grep ^# > asm_types.h
-+" \
-+| grep ^# > asm_types.h
-
- cp asm_types.h asm_types.c
-
- cat >> asm_types.c <<EOF
-+#include <stdio.h>
-+#include <stdlib.h>
- main(int argc, char **argv)
- {
- #ifdef __U8_TYPEDEF
-@@ -102,7 +95,7 @@
- }
- EOF
-
--cc -o asm_types asm_types.c
-+${BUILD_CC-gcc} -o asm_types asm_types.c
- if ! ./asm_types
- then
- echo "Problem detected with asm_types.h"