summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2007-10-08 21:11:16 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2007-10-08 21:11:16 +0000
commit1fa22143f965e6d2ba2134915fe9d25fbfe96de6 (patch)
treed8ebd270400d102293656a12722cc467056ea0ce /sys-fs
parentversion bump. don't install INSTALL.txt (diff)
downloadhistorical-1fa22143f965e6d2ba2134915fe9d25fbfe96de6.tar.gz
historical-1fa22143f965e6d2ba2134915fe9d25fbfe96de6.tar.bz2
historical-1fa22143f965e6d2ba2134915fe9d25fbfe96de6.zip
LVM should come up after modules and mdraid. If you want to have a MD device on top of LVM go and edit conf.d/lvm. Also ensure that all PVs are found before starting the vgscan.
Package-Manager: portage-2.1.3.12
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/lvm2/ChangeLog11
-rw-r--r--sys-fs/lvm2/files/digest-lvm2-2.02.28-r23
-rw-r--r--sys-fs/lvm2/files/lvm.confd-2.02.28-r25
-rw-r--r--sys-fs/lvm2/files/lvm.rc-2.02.28-r229
-rwxr-xr-xsys-fs/lvm2/files/lvm2-start.sh-2.02.28-r240
-rw-r--r--sys-fs/lvm2/lvm2-2.02.28-r2.ebuild114
6 files changed, 201 insertions, 1 deletions
diff --git a/sys-fs/lvm2/ChangeLog b/sys-fs/lvm2/ChangeLog
index f17217b0ea01..5c40336b774c 100644
--- a/sys-fs/lvm2/ChangeLog
+++ b/sys-fs/lvm2/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for sys-fs/lvm2
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/lvm2/ChangeLog,v 1.108 2007/10/04 16:06:21 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/lvm2/ChangeLog,v 1.109 2007/10/08 21:11:15 robbat2 Exp $
+
+*lvm2-2.02.28-r2 (08 Oct 2007)
+
+ 08 Oct 2007; Robin H. Johnson <robbat2@gentoo.org>
+ +files/lvm.confd-2.02.28-r2, +files/lvm.rc-2.02.28-r2,
+ +files/lvm2-start.sh-2.02.28-r2, +lvm2-2.02.28-r2.ebuild:
+ LVM should come up after modules and mdraid. If you want to have a MD device
+ on top of LVM go and edit conf.d/lvm. Also ensure that all PVs are found
+ before starting the vgscan.
*lvm2-2.02.28-r1 (04 Oct 2007)
diff --git a/sys-fs/lvm2/files/digest-lvm2-2.02.28-r2 b/sys-fs/lvm2/files/digest-lvm2-2.02.28-r2
new file mode 100644
index 000000000000..920c6a9cc962
--- /dev/null
+++ b/sys-fs/lvm2/files/digest-lvm2-2.02.28-r2
@@ -0,0 +1,3 @@
+MD5 940a882a71cae84f6befc8069a260ad1 LVM2.2.02.28.tgz 531905
+RMD160 bf6f25db6e34bf362353ae9557691a7f01962502 LVM2.2.02.28.tgz 531905
+SHA256 2d8d7b123e427d0bfb7471d7c17dfd88890eb98257ca22ea3be5d7307e83aceb LVM2.2.02.28.tgz 531905
diff --git a/sys-fs/lvm2/files/lvm.confd-2.02.28-r2 b/sys-fs/lvm2/files/lvm.confd-2.02.28-r2
new file mode 100644
index 000000000000..2fbd8668c376
--- /dev/null
+++ b/sys-fs/lvm2/files/lvm.confd-2.02.28-r2
@@ -0,0 +1,5 @@
+# LVM should normally only be started after mdraid is available
+# this is because LVM physical volumes are very often MD devices.
+RC_AFTER="mdraid"
+
+# vim: ft=gentoo-conf-d
diff --git a/sys-fs/lvm2/files/lvm.rc-2.02.28-r2 b/sys-fs/lvm2/files/lvm.rc-2.02.28-r2
new file mode 100644
index 000000000000..34d223bd238d
--- /dev/null
+++ b/sys-fs/lvm2/files/lvm.rc-2.02.28-r2
@@ -0,0 +1,29 @@
+#!/sbin/runscript
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/lvm2/files/lvm.rc-2.02.28-r2,v 1.1 2007/10/08 21:11:16 robbat2 Exp $
+
+depend() {
+ if [ -e /lib/librc.so ]; then
+ # on baselayout-1 this causes
+ # dependency-cycles with checkroot (before *)
+ before checkfs
+ after modules
+ fi
+}
+
+start() {
+ if [ ! -e /lib/librc.so ]; then
+ eerror "The $SVCNAME init-script is written for baselayout-2!"
+ eerror "Please do not use it with baselayout-1!".
+ return 1
+ fi
+
+ start_addon lvm
+}
+
+stop() {
+ stop_addon lvm
+}
+
+# vim:ts=4
diff --git a/sys-fs/lvm2/files/lvm2-start.sh-2.02.28-r2 b/sys-fs/lvm2/files/lvm2-start.sh-2.02.28-r2
new file mode 100755
index 000000000000..7c72199153e6
--- /dev/null
+++ b/sys-fs/lvm2/files/lvm2-start.sh-2.02.28-r2
@@ -0,0 +1,40 @@
+# /lib/rcscripts/addons/lvm-start.sh
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/lvm2/files/lvm2-start.sh-2.02.28-r2,v 1.1 2007/10/08 21:11:16 robbat2 Exp $
+
+dm_in_proc() {
+ local retval=0
+ for x in devices misc ; do
+ grep -qs 'device-mapper' /proc/${x}
+ retval=$((${retval} + $?))
+ done
+ return ${retval}
+}
+
+# LVM support for /usr, /home, /opt ....
+# This should be done *before* checking local
+# volumes, or they never get checked.
+
+# NOTE: Add needed modules for LVM or RAID, etc
+# to /etc/modules.autoload if needed
+if [ -z "${CDBOOT}" -a -x /sbin/vgscan ] ; then
+ if [ -e /proc/modules ] && ! dm_in_proc ; then
+ modprobe dm-mod 2>/dev/null
+ fi
+
+ if [ -d /proc/lvm ] || dm_in_proc ; then
+ ebegin "Setting up the Logical Volume Manager"
+ #still echo stderr for debugging
+ # Extra PV find pass because some devices might not have been available until very recently
+ /sbin/pvscan >/dev/null
+ # Now make the nodes
+ /sbin/vgscan --mknodes --ignorelockingfailure >/dev/null
+ if [ -x /sbin/vgchange ] && \
+ [ -f /etc/lvmtab -o -d /etc/lvm ]
+ then
+ /sbin/vgchange --ignorelockingfailure -a y >/dev/null
+ fi
+ eend $? "Failed to setup the LVM"
+ fi
+fi
+
+# vim:ts=4
diff --git a/sys-fs/lvm2/lvm2-2.02.28-r2.ebuild b/sys-fs/lvm2/lvm2-2.02.28-r2.ebuild
new file mode 100644
index 000000000000..253a68cf44ac
--- /dev/null
+++ b/sys-fs/lvm2/lvm2-2.02.28-r2.ebuild
@@ -0,0 +1,114 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/lvm2/lvm2-2.02.28-r2.ebuild,v 1.1 2007/10/08 21:11:15 robbat2 Exp $
+
+inherit eutils
+
+DESCRIPTION="User-land utilities for LVM2 (device-mapper) software."
+HOMEPAGE="http://sources.redhat.com/lvm2/"
+SRC_URI="ftp://sources.redhat.com/pub/lvm2/${PN/lvm/LVM}.${PV}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~mips ~ppc ~ppc64 ~sparc ~x86"
+
+# These no* flags are going to be removed shortly, pending a mail to -dev
+# - robbat2, 2007/10/02
+IUSE="readline nolvmstatic clvm cman gulm nolvm1 selinux"
+
+DEPEND=">=sys-fs/device-mapper-1.02.22-r1
+ clvm? ( >=sys-cluster/dlm-1.01.00
+ cman? ( >=sys-cluster/cman-1.01.00 )
+ gulm? ( >=sys-cluster/gulm-1.00.00 ) )"
+
+RDEPEND="${DEPEND}
+ !sys-fs/lvm-user
+ !sys-fs/clvm"
+
+S="${WORKDIR}/${PN/lvm/LVM}.${PV}"
+
+src_unpack() {
+ unpack ${A}
+ #cd "${S}" || die
+ #epatch ${FILESDIR}/lvm2-2.02.04-vgid.patch
+}
+
+src_compile() {
+ # Static compile of lvm2 so that the install described in the handbook works
+ # http://www.gentoo.org/doc/en/lvm2.xml
+ # fixes http://bugs.gentoo.org/show_bug.cgi?id=84463
+ local myconf
+ local buildmode
+
+ # fsadm is broken, don't include it (2.02.28)
+ myconf="${myconf} --enable-dmeventd --enable-cmdlib"
+
+ # Most of this package does weird stuff.
+ # The build options are tristate, and --without is NOT supported
+ # options: 'none', 'internal', 'shared'
+ if use nolvmstatic ; then
+ buildmode="shared"
+ else
+ myconf="${myconf} --enable-static_link"
+ buildmode="internal"
+ fi
+
+ # dmeventd requires snapshots and mirrors to be built in some form
+ # so we cannot disable them
+ myconf="${myconf} --with-snapshots=${buildmode}"
+ myconf="${myconf} --with-mirrors=${buildmode}"
+
+ if use nolvm1 ; then
+ myconf="${myconf} --with-lvm1=none"
+ else
+ myconf="${myconf} --with-lvm1=${buildmode}"
+ fi
+
+ # disable O_DIRECT support on hppa, breaks pv detection (#99532)
+ use hppa && myconf="${myconf} --disable-o_direct"
+
+ if use clvm; then
+ myconf="${myconf} --with-cluster=${buildmode}"
+ # 4-state!
+ local clvmd="none"
+ use cman && clvmd="cman"
+ use gulm && clvmd="${clvmd}gulm"
+ clvmd="${clvmd/cmangulm/all}"
+ myconf="${myconf} --with-clvmd=${clvmd}"
+ else
+ myconf="${myconf} --with-clvmd=none --with-cluster=none"
+ fi
+
+ myconf="${myconf} --sbindir=/sbin --with-staticdir=/sbin"
+ econf $(use_enable readline) $(use_enable selinux) ${myconf} || die
+ emake || die "compile problem"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ mv -f "${D}"/sbin/lvm.static "${D}"/sbin/lvm
+
+ dodoc README VERSION WHATS_NEW doc/*.{conf,c,txt}
+ insinto /lib/rcscripts/addons
+ newins ${FILESDIR}/lvm2-start.sh-2.02.28-r2 lvm-start.sh || die
+ newins ${FILESDIR}/lvm2-stop.sh lvm-stop.sh || die
+ newinitd ${FILESDIR}/lvm.rc-2.02.28-r2 lvm || die
+ newconfd ${FILESDIR}/lvm.confd-2.02.28-r2 lvm || die
+ if use clvm; then
+ newinitd ${FILESDIR}/clvmd.rc clvmd || die
+ fi
+
+ ewarn "use flag nocman is deprecated and replaced"
+ ewarn "with cman and gulm use flags."
+ ewarn ""
+ ewarn "use flags clvm,cman and gulm are masked"
+ ewarn "by default and need to be unmasked to use them"
+ ewarn ""
+ ewarn "Rebuild your genkernel initramfs if you are using lvm"
+}
+
+pkg_postinst() {
+ elog "lvm volumes are no longer automatically created for"
+ elog "baselayout-2 users. If you are using baselayout-2, be sure to"
+ elog "run: # rc-update add lvm boot"
+}