summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2009-06-20 11:57:49 +0000
committerMike Frysinger <vapier@gentoo.org>2009-06-20 11:57:49 +0000
commit40e12e6b4d46b6e0c2dc3a6bba5e49e9e28b2bd1 (patch)
tree22ceb384964c9a80f067c6e94ce1e587a3f49ee1 /sys-fs/e2fsprogs
parentold (diff)
downloadhistorical-40e12e6b4d46b6e0c2dc3a6bba5e49e9e28b2bd1.tar.gz
historical-40e12e6b4d46b6e0c2dc3a6bba5e49e9e28b2bd1.tar.bz2
historical-40e12e6b4d46b6e0c2dc3a6bba5e49e9e28b2bd1.zip
old
Diffstat (limited to 'sys-fs/e2fsprogs')
-rw-r--r--sys-fs/e2fsprogs/e2fsprogs-1.40.11.ebuild136
-rw-r--r--sys-fs/e2fsprogs/e2fsprogs-1.41.3.ebuild131
-rw-r--r--sys-fs/e2fsprogs/e2fsprogs-1.41.4.ebuild128
-rw-r--r--sys-fs/e2fsprogs/e2fsprogs-1.41.5.ebuild127
4 files changed, 0 insertions, 522 deletions
diff --git a/sys-fs/e2fsprogs/e2fsprogs-1.40.11.ebuild b/sys-fs/e2fsprogs/e2fsprogs-1.40.11.ebuild
deleted file mode 100644
index 78d346c1da40..000000000000
--- a/sys-fs/e2fsprogs/e2fsprogs-1.40.11.ebuild
+++ /dev/null
@@ -1,136 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/e2fsprogs/e2fsprogs-1.40.11.ebuild,v 1.1 2008/06/18 09:33:56 vapier Exp $
-
-inherit eutils flag-o-matic toolchain-funcs multilib
-
-DESCRIPTION="Standard EXT2 and EXT3 filesystem utilities"
-HOMEPAGE="http://e2fsprogs.sourceforge.net/"
-SRC_URI="mirror://sourceforge/e2fsprogs/${P}.tar.gz"
-
-LICENSE="GPL-2 BSD"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
-IUSE="nls static elibc_FreeBSD"
-
-RDEPEND="~sys-libs/com_err-${PV}
- ~sys-libs/ss-${PV}
- nls? ( virtual/libintl )"
-DEPEND="${RDEPEND}
- nls? ( sys-devel/gettext )
- sys-apps/texinfo"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/${PN}-1.38-tests-locale.patch #99766
- chmod u+w po/*.po # Userpriv fix #27348
- # Clean up makefile to suck less
- epatch "${FILESDIR}"/e2fsprogs-1.39-makefile.patch
- epatch "${FILESDIR}"/${PN}-1.40.5-libintl.patch #122368
- epatch "${FILESDIR}"/${PN}-1.40-fbsd.patch
-
- # kernel headers use the same defines as e2fsprogs and can cause issues #48829
- sed -i \
- -e 's:CONFIG_JBD_DEBUG:__CONFIG_JBD_DEBUG__E2FS:g' \
- $(grep -rl CONFIG_JBD_DEBUG *) \
- || die "sed jbd debug failed"
-
- # fake out files we forked into sep packages
- sed -i \
- -e '/^LIB_SUBDIRS/s:lib/et::' \
- -e '/^LIB_SUBDIRS/s:lib/ss::' \
- Makefile.in || die "remove subdirs"
-
- # since we've split out com_err/ss into their own ebuilds, we
- # need to fake out the local files. let the toolchain find them.
- mkdir tc || die
- echo "GROUP ( libcom_err.a )" > tc/libcom_err.a
- echo "GROUP ( libcom_err.so )" > tc/libcom_err.so
- echo "GROUP ( libss.a )" > tc/libss.a
- echo "GROUP ( libss.so )" > tc/libss.so
- sed -i \
- -e '/^LIB\(SS\|COM_ERR\)/s:$(LIB):$(top_builddir)/tc:' \
- MCONFIG.in || die
- echo '#include_next <ss/ss_err.h>' > lib/ss/ss_err.h
- ln -s $(type -P mk_cmds) lib/ss/mk_cmds
- ln -s $(type -P compile_et) lib/et/compile_et
-
- # sanity check for Bug 105304
- if [[ -z ${USERLAND} ]] ; then
- eerror "You just hit Bug 105304, please post your 'emerge info' here:"
- eerror "http://bugs.gentoo.org/105304"
- die "Aborting to prevent screwing your system"
- fi
-}
-
-src_compile() {
- # Keep the package from doing silly things
- addwrite /var/cache/fonts
- export LDCONFIG=:
- export CC=$(tc-getCC)
- export STRIP=:
-
- econf \
- --bindir=/bin \
- --sbindir=/sbin \
- --enable-elf-shlibs \
- --with-ldopts="${LDFLAGS}" \
- $(use_enable !static dynamic-e2fsck) \
- $(use_enable !elibc_uclibc tls) \
- --without-included-gettext \
- $(use_enable nls) \
- $(use_enable userland_GNU fsck) \
- || die
- if [[ ${CHOST} != *-uclibc ]] && grep -qs 'USE_INCLUDED_LIBINTL.*yes' config.{log,status} ; then
- eerror "INTL sanity check failed, aborting build."
- eerror "Please post your ${S}/config.log file as an"
- eerror "attachment to http://bugs.gentoo.org/show_bug.cgi?id=81096"
- die "Preventing included intl cruft from building"
- fi
- # Parallel make sometimes fails
- emake -j1 COMPILE_ET=compile_et || die
-
- # Build the FreeBSD helper
- if use elibc_FreeBSD ; then
- cp "${FILESDIR}"/fsck_ext2fs.c .
- emake fsck_ext2fs || die
- fi
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die
- dodoc README RELEASE-NOTES
-
- # Move shared libraries to /lib/, install static libraries to /usr/lib/,
- # and install linker scripts to /usr/lib/.
- dodir /$(get_libdir)
- mv "${D}"/usr/$(get_libdir)/*.so* "${D}"/$(get_libdir)/
- dolib.a lib/*.a || die "dolib.a"
- rm -f "${D}"/usr/$(get_libdir)/lib{com_err,ss}.a #125146
- local x
- cd "${D}"/$(get_libdir)
- for x in *.so ; do
- gen_usr_ldscript ${x} || die "gen ldscript ${x}"
- done
-
- # move 'useless' stuff to /usr/
- dosbin "${D}"/sbin/mklost+found
- rm -f "${D}"/sbin/mklost+found
-
- if use elibc_FreeBSD ; then
- # Install helpers for us
- into /
- dosbin "${S}"/fsck_ext2fs || die
- doman "${FILESDIR}"/fsck_ext2fs.8
-
- # these manpages are already provided by FreeBSD libc
- # and filefrag is linux only
- rm -f \
- "${D}"/sbin/filefrag \
- "${D}"/usr/share/man/man8/filefrag.8 \
- "${D}"/bin/uuidgen \
- "${D}"/usr/share/man/man3/{uuid,uuid_compare}.3 \
- "${D}"/usr/share/man/man1/uuidgen.1 || die
- fi
-}
diff --git a/sys-fs/e2fsprogs/e2fsprogs-1.41.3.ebuild b/sys-fs/e2fsprogs/e2fsprogs-1.41.3.ebuild
deleted file mode 100644
index 6fba0c7c322e..000000000000
--- a/sys-fs/e2fsprogs/e2fsprogs-1.41.3.ebuild
+++ /dev/null
@@ -1,131 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/e2fsprogs/e2fsprogs-1.41.3.ebuild,v 1.10 2009/01/01 15:47:52 gmsoft Exp $
-
-inherit eutils flag-o-matic toolchain-funcs multilib
-
-DESCRIPTION="Standard EXT2 and EXT3 filesystem utilities"
-HOMEPAGE="http://e2fsprogs.sourceforge.net/"
-SRC_URI="mirror://sourceforge/e2fsprogs/${P}.tar.gz"
-
-LICENSE="GPL-2 BSD"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~x86-fbsd"
-IUSE="nls elibc_FreeBSD"
-
-RDEPEND="~sys-libs/${PN}-libs-${PV}
- nls? ( virtual/libintl )"
-DEPEND="${RDEPEND}
- nls? ( sys-devel/gettext )
- sys-apps/texinfo"
-
-pkg_setup() {
- if [[ ! -e ${ROOT}/etc/mtab ]] ; then
- # add some crap to deal with missing /etc/mtab #217719
- ewarn "No /etc/mtab file, creating one temporarily"
- echo "${PN} crap for src_test" > "${ROOT}"/etc/mtab
- fi
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/${PN}-1.38-tests-locale.patch #99766
- epatch "${FILESDIR}"/${PN}-1.41.2-makefile.patch
- epatch "${FILESDIR}"/${PN}-1.40-fbsd.patch
- # blargh ... trick e2fsprogs into using e2fsprogs-libs
- rm -rf doc
- sed -i -r \
- -e 's:@LIBINTL@:@LTLIBINTL@:' \
- -e '/^LIB(BLKID|COM_ERR|SS|UUID)/s:[$][(]LIB[)]/lib([^@]*)@LIB_EXT@:-l\1:' \
- -e '/^DEPLIB(BLKID|COM_ERR|SS|UUID)/s:=.*:=:' \
- MCONFIG.in || die "muck libs" #122368
- sed -i -r \
- -e '/^LIB_SUBDIRS/s:lib/(blkid|et|ss|uuid)::g' \
- Makefile.in || die "remove subdirs"
- touch lib/ss/ss_err.h
-}
-
-src_compile() {
- # Keep the package from doing silly things
- addwrite /var/cache/fonts
- export LDCONFIG=:
- export CC=$(tc-getCC)
- export STRIP=:
-
- # We want to use the "bsd" libraries while building on Darwin, but while
- # building on other Gentoo/*BSD we prefer elf-naming scheme.
- local libtype
- case ${CHOST} in
- *-darwin*) libtype=bsd;;
- *) libtype=elf;;
- esac
-
- econf \
- --bindir=/bin \
- --sbindir=/sbin \
- --enable-${libtype}-shlibs \
- --with-ldopts="${LDFLAGS}" \
- $(use_enable !elibc_uclibc tls) \
- --without-included-gettext \
- $(use_enable nls) \
- $(use_enable userland_GNU fsck) \
- || die
- if [[ ${CHOST} != *-uclibc ]] && grep -qs 'USE_INCLUDED_LIBINTL.*yes' config.{log,status} ; then
- eerror "INTL sanity check failed, aborting build."
- eerror "Please post your ${S}/config.log file as an"
- eerror "attachment to http://bugs.gentoo.org/show_bug.cgi?id=81096"
- die "Preventing included intl cruft from building"
- fi
- emake COMPILE_ET=compile_et MK_CMDS=mk_cmds || die
-
- # Build the FreeBSD helper
- if use elibc_FreeBSD ; then
- cp "${FILESDIR}"/fsck_ext2fs.c .
- emake fsck_ext2fs || die
- fi
-}
-
-pkg_preinst() {
- if [[ -r ${ROOT}/etc/mtab ]] ; then
- if [[ $(<"${ROOT}"/etc/mtab) == "${PN} crap for src_test" ]] ; then
- rm -f "${ROOT}"/etc/mtab
- fi
- fi
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die
- emake DESTDIR="${D}" install-libs || die
- dodoc README RELEASE-NOTES
-
- # Move shared libraries to /lib/, install static libraries to /usr/lib/,
- # and install linker scripts to /usr/lib/.
- dodir /$(get_libdir)
- local lib slib
- for lib in "${D}"/usr/$(get_libdir)/*.a ; do
- slib=${lib##*/}
- mv "${lib%.a}"$(get_libname)* "${D}"/$(get_libdir)/ || die "moving lib ${slib}"
- gen_usr_ldscript ${slib%.a}$(get_libname)
- done
-
- # move 'useless' stuff to /usr/
- dosbin "${D}"/sbin/mklost+found
- rm -f "${D}"/sbin/mklost+found
-
- if use elibc_FreeBSD ; then
- # Install helpers for us
- into /
- dosbin "${S}"/fsck_ext2fs || die
- doman "${FILESDIR}"/fsck_ext2fs.8
-
- # these manpages are already provided by FreeBSD libc
- # and filefrag is linux only
- rm -f \
- "${D}"/sbin/filefrag \
- "${D}"/usr/share/man/man8/filefrag.8 \
- "${D}"/bin/uuidgen \
- "${D}"/usr/share/man/man3/{uuid,uuid_compare}.3 \
- "${D}"/usr/share/man/man1/uuidgen.1 || die
- fi
-}
diff --git a/sys-fs/e2fsprogs/e2fsprogs-1.41.4.ebuild b/sys-fs/e2fsprogs/e2fsprogs-1.41.4.ebuild
deleted file mode 100644
index 81c7b000522b..000000000000
--- a/sys-fs/e2fsprogs/e2fsprogs-1.41.4.ebuild
+++ /dev/null
@@ -1,128 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/e2fsprogs/e2fsprogs-1.41.4.ebuild,v 1.2 2009/04/05 03:15:53 vapier Exp $
-
-inherit eutils flag-o-matic toolchain-funcs multilib
-
-DESCRIPTION="Standard EXT2 and EXT3 filesystem utilities"
-HOMEPAGE="http://e2fsprogs.sourceforge.net/"
-SRC_URI="mirror://sourceforge/e2fsprogs/${P}.tar.gz"
-
-LICENSE="GPL-2 BSD"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
-IUSE="nls elibc_FreeBSD"
-
-RDEPEND="~sys-libs/${PN}-libs-${PV}
- nls? ( virtual/libintl )"
-DEPEND="${RDEPEND}
- nls? ( sys-devel/gettext )
- sys-apps/texinfo"
-
-pkg_setup() {
- if [[ ! -e ${ROOT}/etc/mtab ]] ; then
- # add some crap to deal with missing /etc/mtab #217719
- ewarn "No /etc/mtab file, creating one temporarily"
- echo "${PN} crap for src_test" > "${ROOT}"/etc/mtab
- fi
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/${PN}-1.38-tests-locale.patch #99766
- epatch "${FILESDIR}"/${PN}-1.41.2-makefile.patch
- epatch "${FILESDIR}"/${PN}-1.40-fbsd.patch
- # blargh ... trick e2fsprogs into using e2fsprogs-libs
- rm -rf doc
- sed -i -r \
- -e 's:@LIBINTL@:@LTLIBINTL@:' \
- -e '/^LIB(BLKID|COM_ERR|SS|UUID)/s:[$][(]LIB[)]/lib([^@]*)@LIB_EXT@:-l\1:' \
- -e '/^DEPLIB(BLKID|COM_ERR|SS|UUID)/s:=.*:=:' \
- MCONFIG.in || die "muck libs" #122368
- sed -i -r \
- -e '/^LIB_SUBDIRS/s:lib/(blkid|et|ss|uuid)::g' \
- Makefile.in || die "remove subdirs"
- touch lib/ss/ss_err.h
-}
-
-src_compile() {
- # Keep the package from doing silly things
- addwrite /var/cache/fonts
- export CC=$(tc-getCC)
-
- # We want to use the "bsd" libraries while building on Darwin, but while
- # building on other Gentoo/*BSD we prefer elf-naming scheme.
- local libtype
- case ${CHOST} in
- *-darwin*) libtype=bsd;;
- *) libtype=elf;;
- esac
-
- econf \
- --bindir=/bin \
- --sbindir=/sbin \
- --enable-${libtype}-shlibs \
- --with-ldopts="${LDFLAGS}" \
- $(use_enable !elibc_uclibc tls) \
- --without-included-gettext \
- $(use_enable nls) \
- $(use_enable userland_GNU fsck) \
- || die
- if [[ ${CHOST} != *-uclibc ]] && grep -qs 'USE_INCLUDED_LIBINTL.*yes' config.{log,status} ; then
- eerror "INTL sanity check failed, aborting build."
- eerror "Please post your ${S}/config.log file as an"
- eerror "attachment to http://bugs.gentoo.org/show_bug.cgi?id=81096"
- die "Preventing included intl cruft from building"
- fi
- emake COMPILE_ET=compile_et MK_CMDS=mk_cmds || die
-
- # Build the FreeBSD helper
- if use elibc_FreeBSD ; then
- cp "${FILESDIR}"/fsck_ext2fs.c .
- emake fsck_ext2fs || die
- fi
-}
-
-pkg_preinst() {
- if [[ -r ${ROOT}/etc/mtab ]] ; then
- if [[ $(<"${ROOT}"/etc/mtab) == "${PN} crap for src_test" ]] ; then
- rm -f "${ROOT}"/etc/mtab
- fi
- fi
-}
-
-src_install() {
- emake LDCONFIG=true STRIP=: DESTDIR="${D}" install install-libs || die
- dodoc README RELEASE-NOTES
-
- # Move shared libraries to /lib/, install static libraries to /usr/lib/,
- # and install linker scripts to /usr/lib/.
- dodir /$(get_libdir)
- local lib slib
- for lib in "${D}"/usr/$(get_libdir)/*.a ; do
- slib=${lib##*/}
- mv "${lib%.a}"$(get_libname)* "${D}"/$(get_libdir)/ || die "moving lib ${slib}"
- gen_usr_ldscript ${slib%.a}$(get_libname)
- done
-
- # move 'useless' stuff to /usr/
- dosbin "${D}"/sbin/mklost+found
- rm -f "${D}"/sbin/mklost+found
-
- if use elibc_FreeBSD ; then
- # Install helpers for us
- into /
- dosbin "${S}"/fsck_ext2fs || die
- doman "${FILESDIR}"/fsck_ext2fs.8
-
- # these manpages are already provided by FreeBSD libc
- # and filefrag is linux only
- rm -f \
- "${D}"/sbin/filefrag \
- "${D}"/usr/share/man/man8/filefrag.8 \
- "${D}"/bin/uuidgen \
- "${D}"/usr/share/man/man3/{uuid,uuid_compare}.3 \
- "${D}"/usr/share/man/man1/uuidgen.1 || die
- fi
-}
diff --git a/sys-fs/e2fsprogs/e2fsprogs-1.41.5.ebuild b/sys-fs/e2fsprogs/e2fsprogs-1.41.5.ebuild
deleted file mode 100644
index 6fdfb3d0a6e0..000000000000
--- a/sys-fs/e2fsprogs/e2fsprogs-1.41.5.ebuild
+++ /dev/null
@@ -1,127 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/e2fsprogs/e2fsprogs-1.41.5.ebuild,v 1.1 2009/05/29 23:27:02 vapier Exp $
-
-inherit eutils flag-o-matic toolchain-funcs multilib
-
-DESCRIPTION="Standard EXT2 and EXT3 filesystem utilities"
-HOMEPAGE="http://e2fsprogs.sourceforge.net/"
-SRC_URI="mirror://sourceforge/e2fsprogs/${P}.tar.gz"
-
-LICENSE="GPL-2 BSD"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
-IUSE="nls elibc_FreeBSD"
-
-RDEPEND="~sys-libs/${PN}-libs-${PV}
- nls? ( virtual/libintl )"
-DEPEND="${RDEPEND}
- nls? ( sys-devel/gettext )
- sys-apps/texinfo"
-
-pkg_setup() {
- if [[ ! -e ${ROOT}/etc/mtab ]] ; then
- # add some crap to deal with missing /etc/mtab #217719
- ewarn "No /etc/mtab file, creating one temporarily"
- echo "${PN} crap for src_test" > "${ROOT}"/etc/mtab
- fi
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/${PN}-1.38-tests-locale.patch #99766
- epatch "${FILESDIR}"/${PN}-1.41.5-makefile.patch
- epatch "${FILESDIR}"/${PN}-1.40-fbsd.patch
- # blargh ... trick e2fsprogs into using e2fsprogs-libs
- rm -rf doc
- sed -i -r \
- -e 's:@LIBINTL@:@LTLIBINTL@:' \
- -e '/^LIB(COM_ERR|SS|UUID)/s:[$][(]LIB[)]/lib([^@]*)@LIB_EXT@:-l\1:' \
- -e '/^DEPLIB(COM_ERR|SS|UUID)/s:=.*:=:' \
- MCONFIG.in || die "muck libs" #122368
- sed -i -r \
- -e '/^LIB_SUBDIRS/s:lib/(et|ss|uuid)::g' \
- Makefile.in || die "remove subdirs"
- # stupid configure script clobbers CC for us
- sed -i '/if test -z "$CC" ; then CC=cc; fi/d' configure
- touch lib/ss/ss_err.h
-}
-
-src_compile() {
- # Keep the package from doing silly things
- addwrite /var/cache/fonts
-
- # We want to use the "bsd" libraries while building on Darwin, but while
- # building on other Gentoo/*BSD we prefer elf-naming scheme.
- local libtype
- case ${CHOST} in
- *-darwin*) libtype=bsd;;
- *) libtype=elf;;
- esac
-
- ac_cv_path_LDCONFIG=: \
- econf \
- --bindir=/bin \
- --sbindir=/sbin \
- --enable-${libtype}-shlibs \
- --with-ldopts="${LDFLAGS}" \
- $(use_enable !elibc_uclibc tls) \
- --without-included-gettext \
- $(use_enable nls) \
- $(use_enable userland_GNU fsck) \
- --disable-libblkid \
- || die
- if [[ ${CHOST} != *-uclibc ]] && grep -qs 'USE_INCLUDED_LIBINTL.*yes' config.{log,status} ; then
- eerror "INTL sanity check failed, aborting build."
- eerror "Please post your ${S}/config.log file as an"
- eerror "attachment to http://bugs.gentoo.org/show_bug.cgi?id=81096"
- die "Preventing included intl cruft from building"
- fi
- emake COMPILE_ET=compile_et MK_CMDS=mk_cmds || die
-
- # Build the FreeBSD helper
- if use elibc_FreeBSD ; then
- cp "${FILESDIR}"/fsck_ext2fs.c .
- emake fsck_ext2fs || die
- fi
-}
-
-pkg_preinst() {
- if [[ -r ${ROOT}/etc/mtab ]] ; then
- if [[ $(<"${ROOT}"/etc/mtab) == "${PN} crap for src_test" ]] ; then
- rm -f "${ROOT}"/etc/mtab
- fi
- fi
-}
-
-src_install() {
- emake STRIP=: DESTDIR="${D}" install install-libs || die
- dodoc README RELEASE-NOTES
-
- # Move shared libraries to /lib/, install static libraries to /usr/lib/,
- # and install linker scripts to /usr/lib/.
- set -- "${D}"/usr/$(get_libdir)/*.a
- set -- ${@/*\/lib}
- gen_usr_ldscript -a "${@/.a}"
-
- # move 'useless' stuff to /usr/
- dosbin "${D}"/sbin/mklost+found
- rm -f "${D}"/sbin/mklost+found
-
- if use elibc_FreeBSD ; then
- # Install helpers for us
- into /
- dosbin "${S}"/fsck_ext2fs || die
- doman "${FILESDIR}"/fsck_ext2fs.8
-
- # these manpages are already provided by FreeBSD libc
- # and filefrag is linux only
- rm -f \
- "${D}"/sbin/filefrag \
- "${D}"/usr/share/man/man8/filefrag.8 \
- "${D}"/bin/uuidgen \
- "${D}"/usr/share/man/man3/{uuid,uuid_compare}.3 \
- "${D}"/usr/share/man/man1/uuidgen.1 || die
- fi
-}