summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2009-12-21 14:30:19 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2009-12-21 14:30:19 +0000
commitb126bd15a1d082780a2dfef297b01717bd18a0b5 (patch)
treeb19c2e69c51189a8332bd9200c8e55b040a93ed5 /sys-fs/chironfs/chironfs-1.1.1.ebuild
parentalpha/arm/ia64/s390/sh/sparc/x86 stable wrt #296686 (diff)
downloadhistorical-b126bd15a1d082780a2dfef297b01717bd18a0b5.tar.gz
historical-b126bd15a1d082780a2dfef297b01717bd18a0b5.tar.bz2
historical-b126bd15a1d082780a2dfef297b01717bd18a0b5.zip
Fix building with -Wl,--as-needed wrt #277675 by Kacper Kowalik.
Package-Manager: portage-2.2_rc59/cvs/Linux x86_64
Diffstat (limited to 'sys-fs/chironfs/chironfs-1.1.1.ebuild')
-rw-r--r--sys-fs/chironfs/chironfs-1.1.1.ebuild19
1 files changed, 14 insertions, 5 deletions
diff --git a/sys-fs/chironfs/chironfs-1.1.1.ebuild b/sys-fs/chironfs/chironfs-1.1.1.ebuild
index 78992e30caba..89b681d33ef4 100644
--- a/sys-fs/chironfs/chironfs-1.1.1.ebuild
+++ b/sys-fs/chironfs/chironfs-1.1.1.ebuild
@@ -1,18 +1,27 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/chironfs/chironfs-1.1.1.ebuild,v 1.2 2009/06/24 07:42:53 dragonheart Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/chironfs/chironfs-1.1.1.ebuild,v 1.3 2009/12/21 14:30:19 ssuominen Exp $
+
+EAPI=2
+inherit autotools eutils
DESCRIPTION="Chiron FS - A FUSE based replication filesystem"
-SRC_URI="http://chironfs.googlecode.com/files/${P}.tar.gz"
HOMEPAGE="http://www.furquim.org/chironfs/"
+SRC_URI="http://chironfs.googlecode.com/files/${P}.tar.gz"
+
LICENSE="GPL-2"
-KEYWORDS="~x86 ~amd64"
SLOT="0"
-RDEPEND=""
+KEYWORDS="~amd64 ~x86"
IUSE=""
+
DEPEND="sys-fs/fuse"
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-asneeded.patch
+ eautoreconf
+}
+
src_install() {
- emake DESTDIR="${D}" install || die 'install failure'
+ emake DESTDIR="${D}" install || die
mv "${D}"/usr/share/doc/${PN} "${D}"/usr/share/doc/${P}
}