summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-04-13 05:53:52 +0000
committerMike Frysinger <vapier@gentoo.org>2006-04-13 05:53:52 +0000
commitd151c1b25cbd061c8c6052436819ac656251eab4 (patch)
tree7e00135232603544bccfa30126e3de8e231fa448 /sys-devel/gcc
parenttouchup the min version of linux-headers that we require (diff)
downloadhistorical-d151c1b25cbd061c8c6052436819ac656251eab4.tar.gz
historical-d151c1b25cbd061c8c6052436819ac656251eab4.tar.bz2
historical-d151c1b25cbd061c8c6052436819ac656251eab4.zip
add back in build failure since users just dont seem to understand the nature of gcc snapshots
Diffstat (limited to 'sys-devel/gcc')
-rw-r--r--sys-devel/gcc/gcc-4.2.0_alpha20060408.ebuild9
1 files changed, 7 insertions, 2 deletions
diff --git a/sys-devel/gcc/gcc-4.2.0_alpha20060408.ebuild b/sys-devel/gcc/gcc-4.2.0_alpha20060408.ebuild
index 44efd92e0269..57dab3f8c752 100644
--- a/sys-devel/gcc/gcc-4.2.0_alpha20060408.ebuild
+++ b/sys-devel/gcc/gcc-4.2.0_alpha20060408.ebuild
@@ -1,13 +1,12 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.2.0_alpha20060408.ebuild,v 1.2 2006/04/12 02:47:05 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.2.0_alpha20060408.ebuild,v 1.3 2006/04/13 05:53:52 vapier Exp $
ETYPE="gcc-compiler"
inherit toolchain
DESCRIPTION="The GNU Compiler Collection. Includes C/C++, java compilers, pie+ssp extensions, Haj Ten Brugge runtime bounds checking"
-HOMEPAGE="http://www.gnu.org/software/gcc/gcc.html"
LICENSE="GPL-2 LGPL-2.1"
KEYWORDS="-* ~x86"
@@ -43,6 +42,12 @@ DEPEND="${RDEPEND}
PDEPEND="|| ( app-admin/eselect-compiler sys-devel/gcc-config )
x86? ( !nocxx? ( !elibc_uclibc? ( !build? ( =virtual/libstdc++-3.3 ) ) ) )"
+pkg_setup() {
+ if [[ -z ${I_PROMISE_TO_SUPPLY_PATCHES_WITH_BUGS} ]] ; then
+ die "Please \`export I_PROMISE_TO_SUPPLY_PATCHES_WITH_BUGS=1\` or define it in your make.conf if you want to use this ebuild. This is to try and cut down on people filing bugs for a compiler we do not currently support."
+ fi
+}
+
src_unpack() {
gcc_src_unpack