summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Black <dragonheart@gentoo.org>2004-06-16 02:23:49 +0000
committerDaniel Black <dragonheart@gentoo.org>2004-06-16 02:23:49 +0000
commit44707f58c11f27d47fbc5ceeea4d9bb6c8cdabd3 (patch)
tree478b75f9bf21c64c3a0b5c04ba025acc4f089c1e /sys-devel/bison
parentStable on x86, bug #53544 (diff)
downloadhistorical-44707f58c11f27d47fbc5ceeea4d9bb6c8cdabd3.tar.gz
historical-44707f58c11f27d47fbc5ceeea4d9bb6c8cdabd3.tar.bz2
historical-44707f58c11f27d47fbc5ceeea4d9bb6c8cdabd3.zip
uclibc fixes thanks to Peter S. Mazinger <ps.m@gmx.net>
Diffstat (limited to 'sys-devel/bison')
-rw-r--r--sys-devel/bison/ChangeLog5
-rw-r--r--sys-devel/bison/Manifest4
-rw-r--r--sys-devel/bison/bison-1.875.ebuild12
3 files changed, 14 insertions, 7 deletions
diff --git a/sys-devel/bison/ChangeLog b/sys-devel/bison/ChangeLog
index c0ca1fa988c4..042ff82246a1 100644
--- a/sys-devel/bison/ChangeLog
+++ b/sys-devel/bison/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sys-devel/bison
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/bison/ChangeLog,v 1.26 2004/02/06 20:39:55 gustavoz Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/bison/ChangeLog,v 1.27 2004/06/16 02:23:49 dragonheart Exp $
+
+ 16 Jun 2004; Daniel Black <dragonheart@gentoo.org> bison-1.875.ebuild:
+ uclibc fixes thanks to Peter S. Mazinger <ps.m@gmx.net>
06 Feb 2004; <gustavoz@gentoo.org> bison-1.875.ebuild:
stable on sparc
diff --git a/sys-devel/bison/Manifest b/sys-devel/bison/Manifest
index 3fdc3673ccbb..1d1559082c8c 100644
--- a/sys-devel/bison/Manifest
+++ b/sys-devel/bison/Manifest
@@ -1,8 +1,8 @@
-MD5 04742f53e5b66ea1adc29a0bf95cb8d4 ChangeLog 4175
+MD5 5c724510c0a97881a8960293daee028c ChangeLog 4309
MD5 796f4c136d43ecf211aa22b7bb28b2ac bison-1.34-r1.ebuild 1168
MD5 9bc17ebe6a17ce140fbde3b96a7104b2 bison-1.35.ebuild 1273
MD5 101fa7fcc6ec17705bca1dfaea977429 bison-1.75.ebuild 1117
-MD5 142bfcae5efd41b6441b808e0339361e bison-1.875.ebuild 1729
+MD5 0599039bc8e19cbe43737542e877803b bison-1.875.ebuild 1810
MD5 9a09f8d531c582e78977dbfd96edc1f2 metadata.xml 164
MD5 61b224a9eaf1ae7f77c2d1456d8fda87 files/bison-1.32-extfix.patch 1170
MD5 644a4912da3e5107f509022f173ec146 files/bison-1.875-gccerror.patch 1538
diff --git a/sys-devel/bison/bison-1.875.ebuild b/sys-devel/bison/bison-1.875.ebuild
index 231f9fda9e1c..86e72494e657 100644
--- a/sys-devel/bison/bison-1.875.ebuild
+++ b/sys-devel/bison/bison-1.875.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/bison/bison-1.875.ebuild,v 1.18 2004/04/27 12:07:03 pvdabeel Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/bison/bison-1.875.ebuild,v 1.19 2004/06/16 02:23:49 dragonheart Exp $
inherit gcc flag-o-matic eutils
@@ -11,11 +11,13 @@ SRC_URI="mirror://gnu/bison/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="x86 ppc sparc mips alpha arm hppa amd64 ia64 ppc64 s390"
-IUSE="nls static"
+IUSE="nls static uclibc"
DEPEND="sys-devel/m4
nls? ( sys-devel/gettext )"
+use uclibc && PROVIDE="dev-util/yacc"
+
src_unpack() {
unpack ${A}
cd ${S}
@@ -33,7 +35,7 @@ src_compile() {
# Bug 29017 says that bison has compile-time issues with
# -march=k6* prior to 3.4CVS. Use -march=i586 instead
# (04 Feb 2004 agriffis)
- if [ $(gcc-major-version) == 3 ] && [ $(gcc-minor-version) < 4 ] ; then
+ if [ "`gcc-major-version`" -eq "3" -a "`gcc-minor-version`" -lt "4" ] ; then
replace-cpu-flags i586 k6 k6-1 k6-2
fi
@@ -54,7 +56,9 @@ src_install() {
install || die
# This one is installed by dev-util/yacc
- mv ${D}/usr/bin/yacc ${D}/usr/bin/yacc.bison || die
+ if ! use uclibc; then
+ mv ${D}/usr/bin/yacc ${D}/usr/bin/yacc.bison || die
+ fi
# We do not need this.
rm -f ${D}/usr/lib/liby.a