summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-08-27 08:30:24 +0000
committerMike Frysinger <vapier@gentoo.org>2006-08-27 08:30:24 +0000
commit218b310bf5289246e66fb9ac17c7d97ab7f05079 (patch)
treeacc54e543e3fc95e724490f97f44c23035be9279 /sys-devel/binutils-hppa64
parentRemove trailing whitespace. (diff)
downloadhistorical-218b310bf5289246e66fb9ac17c7d97ab7f05079.tar.gz
historical-218b310bf5289246e66fb9ac17c7d97ab7f05079.tar.bz2
historical-218b310bf5289246e66fb9ac17c7d97ab7f05079.zip
old
Diffstat (limited to 'sys-devel/binutils-hppa64')
-rw-r--r--sys-devel/binutils-hppa64/binutils-hppa64-2.14.90.0.7.ebuild106
-rw-r--r--sys-devel/binutils-hppa64/binutils-hppa64-2.14.90.0.8.ebuild110
-rw-r--r--sys-devel/binutils-hppa64/files/digest-binutils-hppa64-2.14.90.0.71
-rw-r--r--sys-devel/binutils-hppa64/files/digest-binutils-hppa64-2.14.90.0.81
4 files changed, 0 insertions, 218 deletions
diff --git a/sys-devel/binutils-hppa64/binutils-hppa64-2.14.90.0.7.ebuild b/sys-devel/binutils-hppa64/binutils-hppa64-2.14.90.0.7.ebuild
deleted file mode 100644
index c4a2d38584da..000000000000
--- a/sys-devel/binutils-hppa64/binutils-hppa64-2.14.90.0.7.ebuild
+++ /dev/null
@@ -1,106 +0,0 @@
-# Copyright 1999-2004 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/binutils-hppa64/binutils-hppa64-2.14.90.0.7.ebuild,v 1.4 2004/11/08 08:50:31 mr_bones_ Exp $
-
-IUSE="nls bootstrap build"
-
-# NOTE to Maintainer: ChangeLog states that it no longer use perl to build
-# the manpages, but seems this is incorrect ....
-
-inherit eutils libtool flag-o-matic
-
-# Generate borked binaries. Bug #6730
-filter-flags "-fomit-frame-pointer -fssa"
-
-MY_P=${P/-hppa64/}
-S="${WORKDIR}/${MY_P}"
-DESCRIPTION="Tools necessary to build programs"
-SRC_URI="mirror://kernel/linux/devel/binutils/${MY_P}.tar.bz2
- mirror://kernel/linux/devel/binutils/test/${MY_P}.tar.bz2"
-HOMEPAGE="http://sources.redhat.com/binutils/"
-
-LICENSE="|| ( GPL-2 LGPL-2 )"
-SLOT="0"
-KEYWORDS="-* ~hppa"
-
-DEPEND="virtual/libc
- nls? ( sys-devel/gettext )
- !build? ( !bootstrap? ( dev-lang/perl ) )"
-
-TARGET=hppa64-linux
-
-src_unpack() {
-
- unpack ${A}
-
- # Libtool is broken (Redhat).
- for x in ${S}/opcodes/Makefile.{am,in}
- do
- cp ${x} ${x}.orig
- gawk '
- {
- if ($0 ~ /LIBADD/)
- gsub("../bfd/libbfd.la", "-L../bfd/.libs ../bfd/libbfd.la")
-
- print
- }' ${x}.orig > ${x}
- rm -rf ${x}.orig
- done
-}
-
-src_compile() {
- local myconf=
-
- use nls && \
- myconf="${myconf} --without-included-gettext" || \
- myconf="${myconf} --disable-nls"
-
-
- # Fix /usr/lib/libbfd.la
- elibtoolize --portage
-
- ./configure --enable-shared \
- --enable-64-bit-bfd \
- --prefix=/usr \
- --mandir=/usr/share/man \
- --infodir=/usr/share/info \
- --host=${CHOST} \
- --target=${TARGET} \
- ${myconf} || die
-
- make configure-bfd || die
- make headers -C bfd || die
- emake tooldir="${ROOT}/usr/bin" \
- MAKEOVERRIDES="VERSION=${PV}-${TARGET/-linux/}" \
- all || die
-
-}
-
-src_install() {
-
- make MAKEOVERRIDES="VERSION=${PV}-${TARGET/-linux/}" \
- prefix=${D}/usr \
- mandir=${D}/usr/share/man \
- infodir=${D}/usr/share/info \
- install || die
-
- # Move shared libs to the standart path
- mv ${D}/usr/${CHOST}/${TARGET}/lib/lib*-*.so ${D}/usr/lib
-
- # Remove unused files
- for i in man info include share ${CHOST} lib/libiberty.a lib/ldscripts
- do
- rm -Rf ${D}/usr/${i}
- done
-
- # Remove /usr/bin/* to create symlinks
- rm ${D}/usr/bin/*
-
- # Create symlinks
- cd ${D}/usr/bin
- for i in ${D}/usr/${TARGET}/bin/*
- do
- BIN=`basename ${i}`
- dosym ../${TARGET}/bin/${BIN} /usr/bin/${TARGET}-${BIN}
- done
-}
diff --git a/sys-devel/binutils-hppa64/binutils-hppa64-2.14.90.0.8.ebuild b/sys-devel/binutils-hppa64/binutils-hppa64-2.14.90.0.8.ebuild
deleted file mode 100644
index 3e518db583c8..000000000000
--- a/sys-devel/binutils-hppa64/binutils-hppa64-2.14.90.0.8.ebuild
+++ /dev/null
@@ -1,110 +0,0 @@
-# Copyright 1999-2004 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/binutils-hppa64/binutils-hppa64-2.14.90.0.8.ebuild,v 1.6 2004/11/08 08:50:31 mr_bones_ Exp $
-
-IUSE="nls bootstrap build"
-
-# NOTE to Maintainer: ChangeLog states that it no longer use perl to build
-# the manpages, but seems this is incorrect ....
-
-inherit eutils libtool flag-o-matic
-
-# Generate borked binaries. Bug #6730
-filter-flags "-fomit-frame-pointer -fssa"
-
-MY_P=${P/-hppa64/}
-S="${WORKDIR}/${MY_P}"
-DESCRIPTION="Tools necessary to build programs"
-SRC_URI="mirror://kernel/linux/devel/binutils/${MY_P}.tar.bz2
- mirror://kernel/linux/devel/binutils/test/${MY_P}.tar.bz2"
-HOMEPAGE="http://sources.redhat.com/binutils/"
-
-LICENSE="|| ( GPL-2 LGPL-2 )"
-SLOT="0"
-KEYWORDS="-* hppa"
-
-DEPEND="virtual/libc
- nls? ( sys-devel/gettext )
- !build? ( !bootstrap? ( dev-lang/perl ) )"
-
-TARGET=hppa64-linux
-
-src_unpack() {
-
- unpack ${A}
-
- cd ${S}
- #epatch ${FILESDIR}/hppa64-fptr-reloc.diff
-
- # Libtool is broken (Redhat).
- for x in ${S}/opcodes/Makefile.{am,in}
- do
- cp ${x} ${x}.orig
- gawk '
- {
- if ($0 ~ /LIBADD/)
- gsub("../bfd/libbfd.la", "-L../bfd/.libs ../bfd/libbfd.la")
-
- print
- }' ${x}.orig > ${x}
- rm -rf ${x}.orig
- done
-
-}
-
-src_compile() {
- local myconf=
-
- use nls && \
- myconf="${myconf} --without-included-gettext" || \
- myconf="${myconf} --disable-nls"
-
-
- # Fix /usr/lib/libbfd.la
- elibtoolize --portage
-
- ./configure --enable-shared \
- --enable-64-bit-bfd \
- --prefix=/usr \
- --mandir=/usr/share/man \
- --infodir=/usr/share/info \
- --host=${CHOST} \
- --target=${TARGET} \
- ${myconf} || die
-
- make configure-bfd || die
- make headers -C bfd || die
- emake tooldir="${ROOT}/usr/bin" \
- MAKEOVERRIDES="VERSION=${PV}-${TARGET/-linux/}" \
- all || die
-
-}
-
-src_install() {
-
- make MAKEOVERRIDES="VERSION=${PV}-${TARGET/-linux/}" \
- prefix=${D}/usr \
- mandir=${D}/usr/share/man \
- infodir=${D}/usr/share/info \
- install || die
-
- # Move shared libs to the standart path
- mv ${D}/usr/${CHOST}/${TARGET}/lib/lib*-*.so ${D}/usr/lib
-
- # Remove unused files
- for i in man info include share ${CHOST} lib/libiberty.a lib/ldscripts
- do
- rm -Rf ${D}/usr/${i}
- done
-
- # Remove /usr/bin/* to create symlinks
- rm ${D}/usr/bin/*
-
- # Create symlinks
- cd ${D}/usr/bin
- for i in ${D}/usr/${TARGET}/bin/*
- do
- BIN=`basename ${i}`
- dosym ../${TARGET}/bin/${BIN} /usr/bin/${TARGET}-${BIN}
- done
-}
diff --git a/sys-devel/binutils-hppa64/files/digest-binutils-hppa64-2.14.90.0.7 b/sys-devel/binutils-hppa64/files/digest-binutils-hppa64-2.14.90.0.7
deleted file mode 100644
index 07f652ab2119..000000000000
--- a/sys-devel/binutils-hppa64/files/digest-binutils-hppa64-2.14.90.0.7
+++ /dev/null
@@ -1 +0,0 @@
-MD5 b5b1608f7308c487c0f3af8e4592a71a binutils-2.14.90.0.7.tar.bz2 10575077
diff --git a/sys-devel/binutils-hppa64/files/digest-binutils-hppa64-2.14.90.0.8 b/sys-devel/binutils-hppa64/files/digest-binutils-hppa64-2.14.90.0.8
deleted file mode 100644
index 5adbc8100690..000000000000
--- a/sys-devel/binutils-hppa64/files/digest-binutils-hppa64-2.14.90.0.8
+++ /dev/null
@@ -1 +0,0 @@
-MD5 3e28792a585e14b57838cd24130a24dd binutils-2.14.90.0.8.tar.bz2 11015696