summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-12-16 15:54:28 +0000
committerJustin Lecher <jlec@gentoo.org>2010-12-16 15:54:28 +0000
commit3cbb2a205e2dd49793401c3fea832427df465226 (patch)
treeaa343802e513c79075e833321002233a364890ab /sys-cluster
parentVersion bump (diff)
downloadhistorical-3cbb2a205e2dd49793401c3fea832427df465226.tar.gz
historical-3cbb2a205e2dd49793401c3fea832427df465226.tar.bz2
historical-3cbb2a205e2dd49793401c3fea832427df465226.zip
Removal of fortran.eclass, #348851
Package-Manager: portage-2.2.0_alpha8/cvs/Linux x86_64
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/lam-mpi/ChangeLog5
-rw-r--r--sys-cluster/lam-mpi/lam-mpi-7.1.4-r1.ebuild13
-rw-r--r--sys-cluster/mpe2/ChangeLog6
-rw-r--r--sys-cluster/mpe2/mpe2-1.0.6_p1-r1.ebuild11
-rw-r--r--sys-cluster/mpe2/mpe2-1.0.6_p1.ebuild11
-rw-r--r--sys-cluster/mpich2/ChangeLog5
-rw-r--r--sys-cluster/mpich2/mpich2-1.2.1_p1-r1.ebuild11
7 files changed, 25 insertions, 37 deletions
diff --git a/sys-cluster/lam-mpi/ChangeLog b/sys-cluster/lam-mpi/ChangeLog
index bb20ea639015..84e216a27ea8 100644
--- a/sys-cluster/lam-mpi/ChangeLog
+++ b/sys-cluster/lam-mpi/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sys-cluster/lam-mpi
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/lam-mpi/ChangeLog,v 1.83 2010/05/02 23:14:10 abcd Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/lam-mpi/ChangeLog,v 1.84 2010/12/16 15:52:03 jlec Exp $
+
+ 16 Dec 2010; Justin Lecher <jlec@gentoo.org> lam-mpi-7.1.4-r1.ebuild:
+ Removal of fortran.eclass, #348851
02 May 2010; Jonathan Callen <abcd@gentoo.org> lam-mpi-7.1.4-r1.ebuild:
Bump to EAPI-3, add prefix support & keywords
diff --git a/sys-cluster/lam-mpi/lam-mpi-7.1.4-r1.ebuild b/sys-cluster/lam-mpi/lam-mpi-7.1.4-r1.ebuild
index 625080c7441b..a8588e1101e3 100644
--- a/sys-cluster/lam-mpi/lam-mpi-7.1.4-r1.ebuild
+++ b/sys-cluster/lam-mpi/lam-mpi-7.1.4-r1.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/lam-mpi/lam-mpi-7.1.4-r1.ebuild,v 1.12 2010/05/02 23:14:10 abcd Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/lam-mpi/lam-mpi-7.1.4-r1.ebuild,v 1.13 2010/12/16 15:52:03 jlec Exp $
EAPI="3"
-inherit autotools eutils fortran flag-o-matic multilib portability
+inherit autotools eutils flag-o-matic multilib portability toolchain-funcs
IUSE="crypt pbs fortran xmpi romio examples"
@@ -72,7 +72,6 @@ pkg_setup() {
elog "implementation, http://www.openmpi.org"
elog " ---From the lam-mpi hompage. Please consider upgrading."
einfo
- # fortran_pkg_setup should -not- be run here.
}
src_configure() {
@@ -98,12 +97,6 @@ src_configure() {
# in the current tree.
rm -rf "${S}"/share/ssi/boot/{bproc,globus,slurm}
- if use fortran; then
- fortran_pkg_setup
- # this is NOT in pkg_setup as it is NOT needed for RDEPEND right away it
- # can be installed after merging from binary, and still have things fine
- fi
-
# Disable totalview, see #245439 and #276194
econf \
--with-ltdl-include="${EPREFIX}"/usr/include \
@@ -115,7 +108,7 @@ src_configure() {
--with-threads=posix \
--disable-tv \
$(use_with romio) \
- $(use_with fortran fc "${FORTRANC}") \
+ $(use_with fortran fc "$(tc-getFC)") \
${myconf}
}
diff --git a/sys-cluster/mpe2/ChangeLog b/sys-cluster/mpe2/ChangeLog
index 1477c50ed580..27ecc979c8cf 100644
--- a/sys-cluster/mpe2/ChangeLog
+++ b/sys-cluster/mpe2/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-cluster/mpe2
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/mpe2/ChangeLog,v 1.5 2010/09/13 22:20:52 jsbronder Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/mpe2/ChangeLog,v 1.6 2010/12/16 15:54:28 jlec Exp $
+
+ 16 Dec 2010; Justin Lecher <jlec@gentoo.org> mpe2-1.0.6_p1.ebuild,
+ mpe2-1.0.6_p1-r1.ebuild:
+ Removal of fortran.eclass, #348851
13 Sep 2010; Justin Bronder <jsbronder@gentoo.org> mpe2-1.0.6_p1.ebuild,
mpe2-1.0.6_p1-r1.ebuild:
diff --git a/sys-cluster/mpe2/mpe2-1.0.6_p1-r1.ebuild b/sys-cluster/mpe2/mpe2-1.0.6_p1-r1.ebuild
index 33e6c36a73b3..099f663eab01 100644
--- a/sys-cluster/mpe2/mpe2-1.0.6_p1-r1.ebuild
+++ b/sys-cluster/mpe2/mpe2-1.0.6_p1-r1.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/mpe2/mpe2-1.0.6_p1-r1.ebuild,v 1.2 2010/09/13 22:20:52 jsbronder Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/mpe2/mpe2-1.0.6_p1-r1.ebuild,v 1.3 2010/12/16 15:54:28 jlec Exp $
EAPI=2
-inherit fortran eutils java-utils-2
+inherit eutils java-utils-2 toolchain-funcs
MY_P=${P/_/}
DESCRIPTION="MPI development tools"
@@ -47,11 +47,6 @@ pkg_setup() {
die "Unknown MPI implementation"
fi
- if use fortran ; then
- FORTRAN="g77 gfortran ifort ifc"
- fortran_pkg_setup
- fi
-
export JFLAGS="${JFLAGS} $(java-pkg_javac-args)"
if [[ "${MPE_IMP}" == openmpi ]] && [ -z "${MPE2_FORCE_OPENMPI_TEST}" ]; then
@@ -78,7 +73,7 @@ src_configure() {
if use fortran; then
c="${c} --with-mpif77=/usr/bin/mpif77"
- export F77=${FORTRANC}
+ export F77=$(tc-getFC)
else
c="${c} --disable-f77"
fi
diff --git a/sys-cluster/mpe2/mpe2-1.0.6_p1.ebuild b/sys-cluster/mpe2/mpe2-1.0.6_p1.ebuild
index e31e76fc48d4..1839424bed1c 100644
--- a/sys-cluster/mpe2/mpe2-1.0.6_p1.ebuild
+++ b/sys-cluster/mpe2/mpe2-1.0.6_p1.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/mpe2/mpe2-1.0.6_p1.ebuild,v 1.5 2010/09/14 22:21:58 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/mpe2/mpe2-1.0.6_p1.ebuild,v 1.6 2010/12/16 15:54:28 jlec Exp $
EAPI=2
-inherit fortran eutils java-utils-2
+inherit eutils java-utils-2 toolchain-funcs
MY_P=${P/_/}
DESCRIPTION="MPI development tools"
@@ -47,11 +47,6 @@ pkg_setup() {
die "Unknown MPI implementation"
fi
- if use fortran ; then
- FORTRAN="g77 gfortran ifort ifc"
- fortran_pkg_setup
- fi
-
export JFLAGS="${JFLAGS} $(java-pkg_javac-args)"
if [[ "${MPE_IMP}" == openmpi ]] && [ -z "${MPE2_FORCE_OPENMPI_TEST}" ]; then
@@ -76,7 +71,7 @@ src_configure() {
if use fortran; then
c="${c} --with-mpif77=/usr/bin/mpif77"
- export F77=${FORTRANC}
+ export F77=$(tc-getFC)
else
c="${c} --disable-f77"
fi
diff --git a/sys-cluster/mpich2/ChangeLog b/sys-cluster/mpich2/ChangeLog
index 2e1a03a7c007..a39675ed9b59 100644
--- a/sys-cluster/mpich2/ChangeLog
+++ b/sys-cluster/mpich2/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sys-cluster/mpich2
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/mpich2/ChangeLog,v 1.66 2010/11/29 16:14:20 jsbronder Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/mpich2/ChangeLog,v 1.67 2010/12/16 15:54:28 jlec Exp $
+
+ 16 Dec 2010; Justin Lecher <jlec@gentoo.org> mpich2-1.2.1_p1-r1.ebuild:
+ Removal of fortran.eclass, #348851
29 Nov 2010; Justin Bronder <jsbronder@gentoo.org> -mpich2-1.0.8.ebuild,
metadata.xml:
diff --git a/sys-cluster/mpich2/mpich2-1.2.1_p1-r1.ebuild b/sys-cluster/mpich2/mpich2-1.2.1_p1-r1.ebuild
index 6d1ff27bcfa2..3c84924f3c41 100644
--- a/sys-cluster/mpich2/mpich2-1.2.1_p1-r1.ebuild
+++ b/sys-cluster/mpich2/mpich2-1.2.1_p1-r1.ebuild
@@ -1,11 +1,11 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/mpich2/mpich2-1.2.1_p1-r1.ebuild,v 1.9 2010/11/26 16:02:47 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/mpich2/mpich2-1.2.1_p1-r1.ebuild,v 1.10 2010/12/16 15:54:28 jlec Exp $
EAPI=2
PYTHON_DEPEND="2"
-inherit eutils fortran python
+inherit eutils python toolchain-funcs
MY_PV=${PV/_/}
DESCRIPTION="MPICH2 - A portable MPI implementation"
@@ -35,11 +35,6 @@ pkg_setup() {
python_set_active_version 2
python_pkg_setup
- if use fortran ; then
- FORTRAN="g77 gfortran ifort ifc"
- fortran_pkg_setup
- fi
-
if use mpi-threads && ! use threads; then
ewarn "mpi-threads requires threads, assuming that's what you want"
fi
@@ -101,7 +96,7 @@ src_configure() {
fi
# enable f90 support for appropriate compilers
- case "${FORTRANC}" in
+ case "$(tc-getFC)" in
gfortran|if*)
c="${c} --enable-f77 --enable-f90";;
g77)