summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Bronder <jsbronder@gentoo.org>2008-08-31 20:20:42 +0000
committerJustin Bronder <jsbronder@gentoo.org>2008-08-31 20:20:42 +0000
commitb1e81d068bc4f021ae780e796a9ab5d31f81b197 (patch)
tree7956f86cdfe9a67d63f4f8559376c9d3e9a58b5e /sys-cluster/openmpi
parentbump (diff)
downloadhistorical-b1e81d068bc4f021ae780e796a9ab5d31f81b197.tar.gz
historical-b1e81d068bc4f021ae780e796a9ab5d31f81b197.tar.bz2
historical-b1e81d068bc4f021ae780e796a9ab5d31f81b197.zip
Bump sys-cluster/openmpi-1.2.7
Package-Manager: portage-2.1.4.4
Diffstat (limited to 'sys-cluster/openmpi')
-rw-r--r--sys-cluster/openmpi/Manifest12
-rw-r--r--sys-cluster/openmpi/openmpi-1.2.7.ebuild97
2 files changed, 109 insertions, 0 deletions
diff --git a/sys-cluster/openmpi/Manifest b/sys-cluster/openmpi/Manifest
index 261d3106a439..7e63d7dfe143 100644
--- a/sys-cluster/openmpi/Manifest
+++ b/sys-cluster/openmpi/Manifest
@@ -1,7 +1,19 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
DIST openmpi-1.2.5.tar.bz2 3554443 RMD160 609a2070d69bbcde883d2f0d1d6364c5903ae59f SHA1 c217798453782cb9e25d58daf845aa6fdc62fcbf SHA256 3c3aed872c17165131c77bd7a12fe8aec776cb23da946b7d12840db93ab79322
DIST openmpi-1.2.6.tar.bz2 3556676 RMD160 abb72266e44cb5e3a2450a4936f3744edef77cf4 SHA1 b2960e2fd7432816cb70302a6b6c2f55fbd62cab SHA256 e5b27af5a153a257b1562a97bbf7164629161033934558cefd8e1e644a9f73d3
+DIST openmpi-1.2.7.tar.bz2 3555597 RMD160 6707fba2f2de240c25f6135cd37bb42eb78c6590 SHA1 fd377ff52c5b6f61c293b0daa9d681046e673e22 SHA256 d66c7f0bb11494023451651d0e61afaef9d2199ed9a91ed08f0dedeb51541c36
EBUILD openmpi-1.2.5.ebuild 2404 RMD160 b1b34826f7642556f67e98ce8e82b195906074c3 SHA1 cfbb569fc286eb43433193879608c36f87b1c6b9 SHA256 c6f8211413d9cfb9914fbc81fb1be5bcf6b118297adc152fa8f63fbcb0120a08
EBUILD openmpi-1.2.6-r1.ebuild 2532 RMD160 0d0e7f85c7764797d8bded07e2d1fb91a8a6858b SHA1 c74630f95029072d564762d65bfffb8b6043e67d SHA256 301f428d8e5de3a07dc43c186e83b1ff0c03e2a0988f53f84494617f8e4cc24b
EBUILD openmpi-1.2.6.ebuild 2570 RMD160 80f78f33a907315027b97273d7a15aec68555d00 SHA1 963703fbe9a106cc1d623c92a7b0d04b1d934ff3 SHA256 54c7a8b9d796ec143f161bd552fe6536b555fb72499f11c2a937fb486d39f5c7
+EBUILD openmpi-1.2.7.ebuild 2538 RMD160 5b65879d49567e077f27be658230ec495b8ee932 SHA1 6ef700d47661b294aecee9db4d756172fdbd537d SHA256 f3526c4b8550cd48e8dd0837284f0f565e3ee8d5250085aa0ea74601bb3eb0fc
MISC ChangeLog 5700 RMD160 917f75922e703e5c88409be777ea934e1b488c69 SHA1 5a3c8583289d73fed1b345bea1b0491014dd32b4 SHA256 e1abd76ec7f56798a90098c6923d465d840c197e7aca57575b11ccf7388bbdf1
MISC metadata.xml 589 RMD160 c1b05c7c7df9273ea6354fc46536212caa15757c SHA1 67f4d1bcedf14923622b841650d8c9dd04461c63 SHA256 9f85bd8ab961bc5ae03a79c40dc41f885608073e3661e21c126b47e18de868c3
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v2.0.9 (GNU/Linux)
+
+iEYEARECAAYFAki6/ScACgkQ4MrvBE1wQ8mfdwCfQU1jmEseYscp62m7h1nyZNqh
+CfQAn0OkS1b1d6uC0rjfDO2PNvKrzlKa
+=k4EN
+-----END PGP SIGNATURE-----
diff --git a/sys-cluster/openmpi/openmpi-1.2.7.ebuild b/sys-cluster/openmpi/openmpi-1.2.7.ebuild
new file mode 100644
index 000000000000..59f6e7d3d688
--- /dev/null
+++ b/sys-cluster/openmpi/openmpi-1.2.7.ebuild
@@ -0,0 +1,97 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/openmpi/openmpi-1.2.7.ebuild,v 1.1 2008/08/31 20:20:42 jsbronder Exp $
+
+inherit eutils multilib flag-o-matic toolchain-funcs fortran
+
+MY_P=${P/-mpi}
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="A high-performance message passing library (MPI)"
+HOMEPAGE="http://www.open-mpi.org"
+SRC_URI="http://www.open-mpi.org/software/ompi/v1.2/downloads/${MY_P}.tar.bz2"
+LICENSE="BSD"
+SLOT="0"
+RESTRICT="threads? ( test )"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="pbs fortran nocxx threads romio heterogeneous ipv6"
+RDEPEND="pbs? ( sys-cluster/torque )
+ !sys-cluster/mpich
+ !sys-cluster/lam-mpi
+ !sys-cluster/mpich2"
+DEPEND="${RDEPEND}"
+
+pkg_setup() {
+ if use threads; then
+ ewarn
+ ewarn "WARNING: use of threads is still disabled by default in"
+ ewarn "upstream builds."
+ ewarn "You may stop now and set USE=-threads"
+ ewarn
+ epause 5
+ fi
+
+ elog
+ elog "OpenMPI has an overwhelming count of configuration options."
+ elog "Don't forget the EXTRA_ECONF environment variable can let you"
+ elog "specify configure options if you find them necessary."
+ elog
+
+ if use fortran; then
+ FORTRAN="g77 gfortran ifc"
+ fortran_pkg_setup
+ fi
+}
+
+src_compile() {
+ local myconf="
+ --sysconfdir=/etc/${PN}
+ --without-xgrid
+ --enable-pretty-print-stacktrace
+ --enable-orterun-prefix-by-default
+ --without-slurm"
+
+ if use threads; then
+ myconf="${myconf}
+ --enable-mpi-threads
+ --with-progress-threads
+ --with-threads=posix"
+ fi
+
+ if use fortran; then
+ if [[ "${FORTRANC}" = "g77" ]]; then
+ myconf="${myconf} --disable-mpi-f90"
+ elif [[ "${FORTRANC}" = "gfortran" ]]; then
+ # Because that's just a pain in the butt.
+ myconf="${myconf} --with-wrapper-fflags=-I/usr/include"
+ elif [[ "${FORTRANC}" = if* ]]; then
+ # Enabled here as gfortran compile times are huge with this enabled.
+ myconf="${myconf} --with-mpi-f90-size=medium"
+ fi
+ else
+ myconf="${myconf}
+ --disable-mpi-f90
+ --disable-mpi-f77"
+ fi
+
+ econf ${myconf} \
+ $(use_enable !nocxx mpi-cxx) \
+ $(use_enable romio io-romio) \
+ $(use_enable heterogeneous) \
+ $(use_with pbs tm) \
+ $(use_enable ipv6) \
+ || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+src_install () {
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc README AUTHORS NEWS VERSION
+}
+
+src_test() {
+ # Doesn't work with the default src_test as the dry run (-n) fails.
+ cd "${S}"
+ emake -j1 check || die "emake check failed"
+}