summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Bienstman <pbienst@gentoo.org>2005-09-01 11:59:18 +0000
committerPeter Bienstman <pbienst@gentoo.org>2005-09-01 11:59:18 +0000
commit6ab019e32f35c83f067e02ed8b8ac059f296acf3 (patch)
treeeb6c6d305f5daf5ed95207b2f5657ea1651c6c21 /sys-cluster/hpl/hpl-1.0-r2.ebuild
parentdrbd-0.7.12 masked (diff)
downloadhistorical-6ab019e32f35c83f067e02ed8b8ac059f296acf3.tar.gz
historical-6ab019e32f35c83f067e02ed8b8ac059f296acf3.tar.bz2
historical-6ab019e32f35c83f067e02ed8b8ac059f296acf3.zip
Move to virtual/blas and virtual/lapack.
Package-Manager: portage-2.0.51.22-r2
Diffstat (limited to 'sys-cluster/hpl/hpl-1.0-r2.ebuild')
-rw-r--r--sys-cluster/hpl/hpl-1.0-r2.ebuild56
1 files changed, 56 insertions, 0 deletions
diff --git a/sys-cluster/hpl/hpl-1.0-r2.ebuild b/sys-cluster/hpl/hpl-1.0-r2.ebuild
new file mode 100644
index 000000000000..bab5aee51830
--- /dev/null
+++ b/sys-cluster/hpl/hpl-1.0-r2.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/hpl/hpl-1.0-r2.ebuild,v 1.1 2005/09/01 11:59:18 pbienst Exp $
+
+inherit eutils
+
+DESCRIPTION="HPL - A Portable Implementation of the High-Performance Linpack Benchmark for Distributed-Memory Computers"
+HOMEPAGE="http://www.netlib.org/benchmark/hpl/"
+SRC_URI="http://www.netlib.org/benchmark/hpl/hpl.tgz"
+LICENSE="HPL"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+S="${WORKDIR}/${PN}"
+
+DEPEND="virtual/mpi
+ virtual/blas
+ virtual/lapack"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ cp setup/Make.Linux_PII_FBLAS Make.gentoo_hpl_fblas_x86
+ sed -i \
+ -e '/^HPL_OPTS\>/s,=,= -DHPL_DETAILED_TIMING -DHPL_COPY_L,' \
+ -e '/^ARCH\>/s,= .*,= gentoo_hpl_fblas_x86,' \
+ -e '/^MPdir\>/s,= .*,=,' \
+ -e '/^MPlib\>/s,= .*,=,' \
+ -e "/^LAlib\>/s,= .*,= /usr/$(get_libdir)/libblas.so /usr/$(get_libdir)/liblapack.so," \
+ -e '/^LINKER\>/s,= .*,= mpicc,' \
+ -e '/^CC\>/s,= .*,= mpicc,' \
+ Make.gentoo_hpl_fblas_x86
+}
+
+src_compile() {
+ # do NOT use emake here
+ HOME=${WORKDIR} make arch=gentoo_hpl_fblas_x86 || die "Failed to build"
+}
+
+src_install() {
+ doman man/man3/*.3
+ dodoc INSTALL BUGS COPYRIGHT HISTORY README TUNING
+ dobin bin/gentoo_hpl_fblas_x86/xhpl || die "Failed to install bins"
+ insinto /usr/share/hpl
+ doins bin/gentoo_hpl_fblas_x86/HPL.dat || die "Failed to install HPL parameters"
+ dohtml -r www/*
+ dolib lib/gentoo_hpl_fblas_x86/libhpl.a || die "Failed to install lib"
+}
+
+pkg_postinst() {
+ einfo "Remember to copy /usr/share/hpl/HPL.dat to your working directory first!"
+ einfo "For mpich, run linpack by executing this in your working directory"
+ einfo "\"mpirun -np 4 /usr/bin/xhpl\""
+ einfo "where -np specifies the number of processes."
+ einfo "Other methods are needed lam-mpi etc."
+}