summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCiaran McCreesh <ciaranm@gentoo.org>2005-03-06 17:45:15 +0000
committerCiaran McCreesh <ciaranm@gentoo.org>2005-03-06 17:45:15 +0000
commit679da5f8cac5c6304acd56e9e11aba0831103baa (patch)
tree67fe1467c64b464a8c090666f6e4994ec93edb0c /sys-block/gpart/gpart-0.1h-r1.ebuild
parentgpgme dep fix (diff)
downloadhistorical-679da5f8cac5c6304acd56e9e11aba0831103baa.tar.gz
historical-679da5f8cac5c6304acd56e9e11aba0831103baa.tar.bz2
historical-679da5f8cac5c6304acd56e9e11aba0831103baa.zip
Moved from sys-apps/gpart to sys-block/gpart.
Diffstat (limited to 'sys-block/gpart/gpart-0.1h-r1.ebuild')
-rw-r--r--sys-block/gpart/gpart-0.1h-r1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/sys-block/gpart/gpart-0.1h-r1.ebuild b/sys-block/gpart/gpart-0.1h-r1.ebuild
new file mode 100644
index 000000000000..138db9616428
--- /dev/null
+++ b/sys-block/gpart/gpart-0.1h-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-block/gpart/gpart-0.1h-r1.ebuild,v 1.1 2005/03/06 17:45:15 ciaranm Exp $
+
+inherit eutils
+
+DESCRIPTION="Partition table rescue/guessing tool"
+HOMEPAGE="http://www.stud.uni-hannover.de/user/76201/gpart/"
+SRC_URI="http://www.stud.uni-hannover.de/user/76201/gpart/${P}.tar.gz
+ ftp://ftp.namesys.com/pub/misc-patches/gpart-0.1h-reiserfs-3.6.patch.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND="virtual/libc"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-errno.patch
+ epatch "${FILESDIR}"/${P}-vfat.patch
+ epatch "${FILESDIR}"/${P}-ntfs.patch
+ epatch "${FILESDIR}"/${P}-PIC.patch
+ epatch "${WORKDIR}"/gpart-0.1h-reiserfs-3.6.patch
+ sed -i -e "/^CFLAGS/s: -O2 : ${CFLAGS} :" make.defs
+}
+
+src_install() {
+ dobin src/gpart || die
+ doman man/gpart.8
+ dodoc README CHANGES INSTALL LSM
+}