summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2012-10-30 12:04:04 +0000
committerAlexis Ballier <aballier@gentoo.org>2012-10-30 12:04:04 +0000
commit9dee5f5b79bd9f9986a040b3f46521399d2f7184 (patch)
tree7566070b8e0aba879db32a1eda756783cb6a2cfc /sys-auth/openpam/openpam-20120526.ebuild
parentstable arm ppc ppc64, bug #440160 (diff)
downloadhistorical-9dee5f5b79bd9f9986a040b3f46521399d2f7184.tar.gz
historical-9dee5f5b79bd9f9986a040b3f46521399d2f7184.tar.bz2
historical-9dee5f5b79bd9f9986a040b3f46521399d2f7184.zip
version bump
Package-Manager: portage-2.2.0_alpha142/cvs/Linux x86_64 Manifest-Sign-Key: 0x160F534A
Diffstat (limited to 'sys-auth/openpam/openpam-20120526.ebuild')
-rw-r--r--sys-auth/openpam/openpam-20120526.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/sys-auth/openpam/openpam-20120526.ebuild b/sys-auth/openpam/openpam-20120526.ebuild
new file mode 100644
index 000000000000..27a9c26d635a
--- /dev/null
+++ b/sys-auth/openpam/openpam-20120526.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/openpam/openpam-20120526.ebuild,v 1.1 2012/10/30 12:03:57 aballier Exp $
+
+EAPI="2"
+# https://bugs.gentoo.org/show_bug.cgi?id=318121
+WANT_AUTOMAKE=1.9
+inherit multilib autotools eutils libtool
+
+DESCRIPTION="Open source PAM library."
+HOMEPAGE="http://www.openpam.org/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64-fbsd ~sparc-fbsd ~x86-fbsd"
+IUSE="debug vim-syntax"
+
+RDEPEND="!sys-libs/pam"
+DEPEND="sys-devel/make
+ dev-lang/perl"
+PDEPEND="sys-auth/pambase
+ vim-syntax? ( app-vim/pam-syntax )"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-20071221-gentoo.patch"
+ epatch "${FILESDIR}/${PN}-20050201-nbsd.patch"
+
+ sed -i -e 's:-Werror::' "${S}/configure.ac"
+
+ mkdir "${S}/m4" # Otherwise aclocal fails since ACLOCAL_AMFLAGS is set in Makefile.am
+ eautoreconf
+ elibtoolize
+}
+
+src_configure() {
+ econf ${myconf} \
+ --disable-dependency-tracking \
+ --with-modules-dir=/$(get_libdir)/security/
+}
+
+src_install() {
+ emake -j1 DESTDIR="${D}" install || die
+ dodoc CREDITS HISTORY RELNOTES README || die
+
+ find "${D}" -name '*.la' -delete || die
+}