summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-07-29 05:12:10 +0000
committerMike Frysinger <vapier@gentoo.org>2004-07-29 05:12:10 +0000
commitc85d49552a758dee2b7936d325b08efe661971f0 (patch)
tree3f56a61e8c9decc23d0abb01e19ef71c53275597 /sys-apps
parentdont forget virtual/os-headers (diff)
downloadhistorical-c85d49552a758dee2b7936d325b08efe661971f0.tar.gz
historical-c85d49552a758dee2b7936d325b08efe661971f0.tar.bz2
historical-c85d49552a758dee2b7936d325b08efe661971f0.zip
move the manpage perm fixes into pkg_postinst() #40322
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/man/Manifest8
-rw-r--r--sys-apps/man/man-1.5m-r1.ebuild9
2 files changed, 12 insertions, 5 deletions
diff --git a/sys-apps/man/Manifest b/sys-apps/man/Manifest
index 7d78f54014c0..9fee8d2e683a 100644
--- a/sys-apps/man/Manifest
+++ b/sys-apps/man/Manifest
@@ -2,7 +2,7 @@
Hash: SHA1
MD5 cacba5416aa20dbb0aa8bf2a8d1964ac ChangeLog 7695
-MD5 97255148d86bb7da1161765509805215 man-1.5m-r1.ebuild 3351
+MD5 00cd25d021d380c0f23b3197ee8cb494 man-1.5m-r1.ebuild 3595
MD5 87416b779f5fd76e415bccbd8e16b30d man-1.5l-r6.ebuild 2792
MD5 91ffe421042078d3875bcd0b8edcf033 man-1.5m.ebuild 2961
MD5 9a09f8d531c582e78977dbfd96edc1f2 metadata.xml 164
@@ -38,7 +38,7 @@ MD5 d8990b0dc5c9670156737c7012de3e9e files/man-1.5m-wrong-quotes.patch 411
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.9.8 (GNU/Linux)
-iD8DBQFA4irnHTu7gpaalycRAlrKAJ95TYvOYX5fo7lY0FqjJhYu8ItI0ACg70yw
-l3l05TlBWjId9U5S96rshfc=
-=C+tB
+iD8DBQFBCIc3HTu7gpaalycRAqPaAKCAc/OgkE2l7G2F0et9Pbwqpuv6EQCgjo78
+QP0Ys8mvm5jsKuOANt55zOM=
+=xreN
-----END PGP SIGNATURE-----
diff --git a/sys-apps/man/man-1.5m-r1.ebuild b/sys-apps/man/man-1.5m-r1.ebuild
index 7d2f430c6fb7..af90b8d77eb5 100644
--- a/sys-apps/man/man-1.5m-r1.ebuild
+++ b/sys-apps/man/man-1.5m-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/man/man-1.5m-r1.ebuild,v 1.8 2004/06/30 02:52:00 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/man/man-1.5m-r1.ebuild,v 1.9 2004/07/29 05:12:10 vapier Exp $
inherit eutils
@@ -121,6 +121,13 @@ src_install() {
}
pkg_postinst() {
+ einfo "Forcing sane permissions onto ${ROOT}/var/cache/man (Bug #40322)"
+ chown -R root:man ${ROOT}/var/cache/man
+ chmod -R g+w ${ROOT}/var/cache/man
+ [ -e ${ROOT}/var/cache/man/whatis ] && chown root:root ${ROOT}/var/cache/man/whatis
+
+ echo
+
local files="`ls ${ROOT}/etc/cron.{daily,weekly}/makewhatis{,.cron} 2>/dev/null`"
if [ "${files/$'\n'}" != "${files}" ] ; then
ewarn "You have multiple makewhatis cron files installed."