summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Robbins <drobbins@gentoo.org>2003-06-12 00:28:49 +0000
committerDaniel Robbins <drobbins@gentoo.org>2003-06-12 00:28:49 +0000
commit4d6749f18edb81e556d59cf6d7b39a9427017aa3 (patch)
treeee2aef2e6294c8bfcf42a047eee8d62fcfb99a6b /sys-apps
parentNew hotplug for x86, fixing bug 21877 and generally updating hotplug function... (diff)
downloadhistorical-4d6749f18edb81e556d59cf6d7b39a9427017aa3.tar.gz
historical-4d6749f18edb81e556d59cf6d7b39a9427017aa3.tar.bz2
historical-4d6749f18edb81e556d59cf6d7b39a9427017aa3.zip
New hotplug for x86, fixing bug 21877 and generally updating hotplug functionality
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/hotplug/Manifest4
-rw-r--r--sys-apps/hotplug/files/digest-hotplug-20030501-r22
-rw-r--r--sys-apps/hotplug/hotplug-20030501-r2.ebuild58
3 files changed, 62 insertions, 2 deletions
diff --git a/sys-apps/hotplug/Manifest b/sys-apps/hotplug/Manifest
index 2a9309bbb370..4d3479d7f968 100644
--- a/sys-apps/hotplug/Manifest
+++ b/sys-apps/hotplug/Manifest
@@ -4,8 +4,8 @@ MD5 cede312e2783d607cb0dd3c594cd20e3 hotplug-20030501.ebuild 1488
MD5 4add5675ce1bf7372ff9189f27c2317a hotplug-20020114.ebuild 1492
MD5 77efe735c313997ccc11119d2a08713c hotplug-20020826-r1.ebuild 1552
MD5 ff4869e458ad17b4691293ed22b2fcc7 hotplug-20020401-r1.ebuild 1467
-MD5 8fbaa675299bbd9148e7233677d9bd17 hotplug-20030501-r2.ebuild 1515
-MD5 09e3a9ec63e1038cfaf5ff45fce21fd2 ChangeLog 3236
+MD5 d7db0885a4edefe3f3841e465394dfee hotplug-20030501-r2.ebuild 1517
+MD5 a3d5f743936c515a7aafd51ee6ca8085 ChangeLog 3236
MD5 dd670e698d3616cbfe662ce54e6511f5 hotplug-20020826.ebuild 1452
MD5 64aa2a1e7fb2526bb52c6fd4b5f24608 files/digest-hotplug-20020826-r1 221
MD5 0e5a1a005fcfa0e242be02e9ef99de7a files/digest-hotplug-20020826-r2 224
diff --git a/sys-apps/hotplug/files/digest-hotplug-20030501-r2 b/sys-apps/hotplug/files/digest-hotplug-20030501-r2
new file mode 100644
index 000000000000..65275d83c5b2
--- /dev/null
+++ b/sys-apps/hotplug/files/digest-hotplug-20030501-r2
@@ -0,0 +1,2 @@
+MD5 bd3bd7de70dd06b37daf86feb5970c77 hotplug-2003_05_01.tar.gz 41930
+MD5 89835f43f1568b40db98759b0ad7380a hotplug-20030501-r1-gentoo-patches.tar.bz2 3308
diff --git a/sys-apps/hotplug/hotplug-20030501-r2.ebuild b/sys-apps/hotplug/hotplug-20030501-r2.ebuild
new file mode 100644
index 000000000000..a7997a95d3bb
--- /dev/null
+++ b/sys-apps/hotplug/hotplug-20030501-r2.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/hotplug/hotplug-20030501-r2.ebuild,v 1.1 2003/06/12 00:28:43 drobbins Exp $
+
+inherit eutils
+
+# source maintainers named it hotplug-YYYY_MM_DD instead of hotplug-YYYYMMDD
+MY_P=${PN}-${PV:0:4}_${PV:4:2}_${PV:6:2}
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="USB and PCI hotplug scripts"
+HOMEPAGE="http://linux-hotplug.sourceforge.net"
+SRC_URI="mirror://sourceforge/linux-hotplug/${MY_P}.tar.gz
+ mirror://gentoo/${PN}-20030501-r1-gentoo-patches.tar.bz2"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86 ~ppc ~hppa"
+
+# hotplug needs pcimodules utility provided by pcitutils-2.1.9-r1
+DEPEND=">=sys-apps/pciutils-2.1.9
+ >=sys-apps/usbutils-0.9"
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}/etc/hotplug
+ epatch ${WORKDIR}/hotplug-patches/
+}
+
+src_install() {
+ into /
+ dosbin sbin/hotplug
+ doman *.8
+ dodoc README ChangeLog
+
+ cd ${S}/etc/hotplug
+ insinto /etc/hotplug
+ doins blacklist hotplug.functions usb.distmap usb.handmap usb.usermap
+ exeinto /etc/hotplug
+ doexe *.agent *.rc
+ dodir /etc/hotplug/usb /etc/hotplug/pci
+ cd ${S}/etc/hotplug.d/default
+ exeinto /etc/hotplug.d/default
+ doexe default.hotplug
+
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/hotplug.rc hotplug
+
+ insinto /etc/conf.d
+ newins ${FILESDIR}/usb.confd usb
+ dodir /var/run/usb
+}
+
+pkg_postinst() {
+ ewarn "WARNING: The fxload program was spliced off this package"
+ ewarn "WARNING: emerge fxload if you need it"
+}
+