summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Robbins <drobbins@gentoo.org>2002-03-21 06:10:11 +0000
committerDaniel Robbins <drobbins@gentoo.org>2002-03-21 06:10:11 +0000
commit0b0c0b8b191002c77b28ba4ea147ad871e885d87 (patch)
tree1a05ceac8aebf220cd8f765ae064467301be7c52 /sys-apps
parenttypo in the last patch (diff)
downloadhistorical-0b0c0b8b191002c77b28ba4ea147ad871e885d87.tar.gz
historical-0b0c0b8b191002c77b28ba4ea147ad871e885d87.tar.bz2
historical-0b0c0b8b191002c77b28ba4ea147ad871e885d87.zip
cleanups, basically
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/iptables/ChangeLog9
-rw-r--r--sys-apps/iptables/files/digest-iptables-1.2.5-r11
-rw-r--r--sys-apps/iptables/iptables-1.2.5-r1.ebuild35
3 files changed, 44 insertions, 1 deletions
diff --git a/sys-apps/iptables/ChangeLog b/sys-apps/iptables/ChangeLog
index ccfb2674bede..8600ecaacdaa 100644
--- a/sys-apps/iptables/ChangeLog
+++ b/sys-apps/iptables/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-apps/iptables
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/iptables/ChangeLog,v 1.1 2002/02/01 21:53:37 gbevin Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/iptables/ChangeLog,v 1.2 2002/03/21 06:10:11 drobbins Exp $
+
+*iptables-1.2.5-r1 (20 Mar 2002)
+
+ 20 Mar 2002; Daniel Robbins <drobbins@gentoo.org> : iptables *requires*
+ kernel sources to compile. Before, we got away without them since we had a
+ /usr/include/linux/autoconf.h. Now we don't, and this means that we need a
+ source tree handy. Sad but true, and apparently the right thing to do.
*iptables-1.2.5 (1 Feb 2002)
diff --git a/sys-apps/iptables/files/digest-iptables-1.2.5-r1 b/sys-apps/iptables/files/digest-iptables-1.2.5-r1
new file mode 100644
index 000000000000..4c07dbe72def
--- /dev/null
+++ b/sys-apps/iptables/files/digest-iptables-1.2.5-r1
@@ -0,0 +1 @@
+MD5 3446aec70217df6cc5be7c155817f54e iptables-1.2.5.tar.bz2 238478
diff --git a/sys-apps/iptables/iptables-1.2.5-r1.ebuild b/sys-apps/iptables/iptables-1.2.5-r1.ebuild
new file mode 100644
index 000000000000..b8e2f39bf0ea
--- /dev/null
+++ b/sys-apps/iptables/iptables-1.2.5-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/iptables/iptables-1.2.5-r1.ebuild,v 1.1 2002/03/21 06:10:11 drobbins Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Kernel 2.4 firewall, NAT and packet mangling tools"
+SRC_URI="http://netfilter.samba.org/files/${P}.tar.bz2"
+
+# iptables is dependent on kernel sources. Strange but true.
+DEPEND="virtual/glibc sys-kernel/linux-sources"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ mv Makefile Makefile.orig
+ sed -e "s/-O2/${CFLAGS}/g" -e "s:/usr/local::g" Makefile.orig > Makefile
+}
+
+src_compile() {
+ #I had a problem with emake - DR
+ make KERNEL_DIR=/usr/src/linux || die
+}
+
+src_install() {
+ dodir /usr/{lib,share/man/man8,sbin}
+ # iptables and libraries are now installed to /sbin and /lib. Why? So systems
+ # with remote network-mounted /usr filesystems can get their network interfaces
+ # up and running correctly without /usr.
+ make LIBDIR=${D}/lib \
+ BINDIR=${D}/sbin \
+ MANDIR=${D}/usr/share/man \
+ INCDIR=${D}/usr/include \
+ install || die
+ dodoc COPYING KNOWN_BUGS
+}