summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2010-10-01 21:42:26 +0000
committerMichał Górny <mgorny@gentoo.org>2010-10-01 21:42:26 +0000
commit68c55f57f9a7826941d13460f55b9a1abcd951b5 (patch)
tree30f81abebec0394ee7f5100498efaa1b7bbc4dc2 /sys-apps/uam
parentChange proxymaintainer to myself (diff)
downloadhistorical-68c55f57f9a7826941d13460f55b9a1abcd951b5.tar.gz
historical-68c55f57f9a7826941d13460f55b9a1abcd951b5.tar.bz2
historical-68c55f57f9a7826941d13460f55b9a1abcd951b5.zip
Import from the Sunrise overlay, per bug #278363.
Package-Manager: portage-2.2_rc88_p61/cvs/Linux x86_64
Diffstat (limited to 'sys-apps/uam')
-rw-r--r--sys-apps/uam/ChangeLog10
-rw-r--r--sys-apps/uam/Manifest14
-rw-r--r--sys-apps/uam/metadata.xml8
-rw-r--r--sys-apps/uam/uam-0.0.6.ebuild57
4 files changed, 89 insertions, 0 deletions
diff --git a/sys-apps/uam/ChangeLog b/sys-apps/uam/ChangeLog
new file mode 100644
index 000000000000..aed6b92338c7
--- /dev/null
+++ b/sys-apps/uam/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for sys-apps/uam
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/uam/ChangeLog,v 1.1 2010/10/01 21:42:26 mgorny Exp $
+
+*uam-0.0.6 (01 Oct 2010)
+
+ 01 Oct 2010; Michał Górny <mgorny@gentoo.org> +uam-0.0.6.ebuild,
+ +metadata.xml:
+ Import from the Sunrise overlay, per bug #278363.
+
diff --git a/sys-apps/uam/Manifest b/sys-apps/uam/Manifest
new file mode 100644
index 000000000000..9b98e1fbeb5c
--- /dev/null
+++ b/sys-apps/uam/Manifest
@@ -0,0 +1,14 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+DIST uam-0.0.6.tar.bz2 10373 RMD160 9781665c2d10f69ee4106e40806ab08c4bf3a367 SHA1 11bb75dd29a15235d27875911c85f590d777f6e6 SHA256 4d36356bd4243c66c6edf3bfb53d733d0b6a439511e9450332033273fea17616
+EBUILD uam-0.0.6.ebuild 1923 RMD160 82ceec8a55cd554242b463a0235a0287ed7e1293 SHA1 533ea4d80d5bbd812ecc885d05093e3d2b7d4b58 SHA256 104b0533ad8a828b41c016b7845c8976dad714344bb2104142e24117d8fe24bf
+MISC ChangeLog 362 RMD160 ac4aedf1a108e04d733bd7fabd5dc24151438767 SHA1 1a88192fdc1273389443df421649237bdc2b8e9f SHA256 5ce1d33e7e2aeae60b05c81e39448a2ffec269da594bc79a5fa9fbe73fdeb145
+MISC metadata.xml 225 RMD160 ba38573da589a2841131e842f603e56870f1b887 SHA1 313271f5aecc1dab0e6d5c6bcef5c2ce4aaa2ed9 SHA256 683509d2c56a04acdce5a75072536653fce01efa354862c574d420e8925cffdc
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v2.0.16 (GNU/Linux)
+
+iEYEARECAAYFAkymVa4ACgkQnGSe5QXeB7ujIQCfeWnyx9v0tNsuWltSRhAhAFUH
+Fh8AoKc7hRACyKvfc8e+SZU6nj5uw8ac
+=Z0Hr
+-----END PGP SIGNATURE-----
diff --git a/sys-apps/uam/metadata.xml b/sys-apps/uam/metadata.xml
new file mode 100644
index 000000000000..88a25e59287c
--- /dev/null
+++ b/sys-apps/uam/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>no-herd</herd>
+ <maintainer>
+ <email>mgorny@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>
diff --git a/sys-apps/uam/uam-0.0.6.ebuild b/sys-apps/uam/uam-0.0.6.ebuild
new file mode 100644
index 000000000000..e2850075ae43
--- /dev/null
+++ b/sys-apps/uam/uam-0.0.6.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/uam/uam-0.0.6.ebuild,v 1.1 2010/10/01 21:42:26 mgorny Exp $
+
+inherit eutils multilib
+
+DESCRIPTION="Simple udev-based automounter for removable USB media"
+HOMEPAGE="http://github.com/mgorny/uam/"
+SRC_URI="http://github.com/downloads/mgorny/${PN}/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="sys-fs/udev"
+
+src_compile() {
+ emake LIBDIR=/$(get_libdir) || die
+}
+
+src_install() {
+ emake LIBDIR=/$(get_libdir) DESTDIR="${D}" install || die
+
+ dodoc NEWS README || die
+}
+
+pkg_postinst() {
+ # The plugdev group is created by pam, pmount and many other ebuilds
+ # in gx86. As we don't want to depend on any of them (even pmount is
+ # optional), we create it ourself too.
+ enewgroup plugdev
+
+ elog "To be able to access uam-mounted filesystems, you have to be"
+ elog "a member of the 'plugdev' group."
+ elog
+ elog "Note that uam doesn't provide any way to allow unprivileged user"
+ elog "to manually umount devices. The upstream suggested solution"
+ elog "is to use [sys-apps/pmount]. If you don't feel like installing"
+ elog "additional tools, remember to sync before removing your USB stick."
+ elog
+ elog "Another feature uam is not capable of is mounting removable media"
+ elog "in fixed drives, like CDs and floppies. You might, however, be able"
+ elog "to mount them as an unprivileged user using appropriate fstab entries"
+ elog "or [sys-apps/pmount]."
+ elog
+ elog "If you'd like to receive libnotify-based notifications, you need"
+ elog "to install the [x11-misc/sw-notify-send] tool from the Sunrise"
+ elog "overlay [1] (or bug #318961 [2])."
+ elog
+ elog "[1] http://overlays.gentoo.org/proj/sunrise"
+ elog "[2] http://bugs.gentoo.org/show_bug.cgi?id=318961"
+
+ ebegin "Calling udev to reload its rules"
+ udevadm control --reload-rules
+ eend $?
+}