summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Harring <ferringb@gentoo.org>2005-04-23 07:26:14 +0000
committerBrian Harring <ferringb@gentoo.org>2005-04-23 07:26:14 +0000
commit9572b9882c4c246578887b8b742cca5d938ca747 (patch)
tree9502ae88787e5c3220247703334c4fd84fc3781d /sys-apps/sandbox
parentmake sure init.d is +x #90018 (diff)
downloadhistorical-9572b9882c4c246578887b8b742cca5d938ca747.tar.gz
historical-9572b9882c4c246578887b8b742cca5d938ca747.tar.bz2
historical-9572b9882c4c246578887b8b742cca5d938ca747.zip
broken out sandbox, with cvs head updates
Package-Manager: portage-1.585-cvs
Diffstat (limited to 'sys-apps/sandbox')
-rw-r--r--sys-apps/sandbox/ChangeLog9
-rw-r--r--sys-apps/sandbox/Manifest4
-rw-r--r--sys-apps/sandbox/files/digest-sandbox-1.21
-rw-r--r--sys-apps/sandbox/metadata.xml16
-rw-r--r--sys-apps/sandbox/sandbox-1.2.ebuild72
5 files changed, 102 insertions, 0 deletions
diff --git a/sys-apps/sandbox/ChangeLog b/sys-apps/sandbox/ChangeLog
new file mode 100644
index 000000000000..18ed8ab0cfe1
--- /dev/null
+++ b/sys-apps/sandbox/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for <CATEGORY>/<PACKAGE_NAME>
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/sandbox/ChangeLog,v 1.1 2005/04/23 07:26:14 ferringb Exp $
+
+*sandbox-1.2 (Apr 23 2005)
+
+ 23 Apr 2005; Brian Harring <ferringb@gentoo.org>; sandbox-1.2.ebuild
+ Initial import of cvs head sandbox code. Multilib portion of it
+ could stand testing.
diff --git a/sys-apps/sandbox/Manifest b/sys-apps/sandbox/Manifest
new file mode 100644
index 000000000000..fd880d2042bc
--- /dev/null
+++ b/sys-apps/sandbox/Manifest
@@ -0,0 +1,4 @@
+MD5 968e2965b0b6f620634dae6d28d8b4c4 metadata.xml 455
+MD5 14c74d97df3b7b04884553d0d20e6500 sandbox-1.2.ebuild 1712
+MD5 4529df9cdb9ab408e8224a709b067985 ChangeLog 406
+MD5 06ad9881ad2610487c66565ee5b39389 files/digest-sandbox-1.2 64
diff --git a/sys-apps/sandbox/files/digest-sandbox-1.2 b/sys-apps/sandbox/files/digest-sandbox-1.2
new file mode 100644
index 000000000000..3c8b53374039
--- /dev/null
+++ b/sys-apps/sandbox/files/digest-sandbox-1.2
@@ -0,0 +1 @@
+MD5 262ae0d6e24f6e37a4c3053b7e9c3315 sandbox-1.2.tar.bz2 234810
diff --git a/sys-apps/sandbox/metadata.xml b/sys-apps/sandbox/metadata.xml
new file mode 100644
index 000000000000..cf7aa40a0c1d
--- /dev/null
+++ b/sys-apps/sandbox/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>no-herd</herd>
+
+<!-- portage lacks a herd. correct this when we have one. -->
+
+<maintainer>
+ <email>dev-portage@gentoo.org</email>
+ <description>Primary contact</description>
+</maintainer>
+<maintainer>
+ <email>azarah@gentoo.org</email>
+ <description>Sandbox guru extraordinare</description>
+</maintainer>
+</pkgmetadata>
diff --git a/sys-apps/sandbox/sandbox-1.2.ebuild b/sys-apps/sandbox/sandbox-1.2.ebuild
new file mode 100644
index 000000000000..858e217a656b
--- /dev/null
+++ b/sys-apps/sandbox/sandbox-1.2.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/sandbox/sandbox-1.2.ebuild,v 1.1 2005/04/23 07:26:14 ferringb Exp $
+
+inherit eutils flag-o-matic eutils toolchain-funcs multilib
+#
+# don't monkey with this ebuild unless contacting portage devs.
+# period.
+#
+
+IUSE=""
+DESCRIPTION="sandbox'd LD_PRELOAD hack"
+SRC_URI="http://dev.gentoo.org/~ferringb/${P}.tar.bz2"
+DEPENDS=""
+LICENSE="GPL-2"
+SLOT='0'
+
+KEYWORDS=" alpha amd64 arm hppa ia64 mips ppc ppc-macos ppc64 s390 sh sparc x86"
+#KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc-macos ~ppc64 ~s390 ~sh ~sparc ~x86"
+
+src_unpack() {
+ if has_multilib_profile; then
+ for TA in $(get_install_abis); do
+ unpack ${A} || die "unpack failed"
+ cd ${S}
+ epunt_cxx
+ cd ..
+ mv ${S} ${S%/}-${TA} || die "failed mving \$S to $TA"
+ done
+ else
+ unpack ${A} || die "unpack failed"
+ cd ${S}
+ epunt_cxx
+ fi
+}
+
+src_compile() {
+ if has_multilib_profile; then
+ OABI="${ABI}"
+ export CFLAGS="${CFLAGS} -DSB_HAVE_64BIT_ARCH"
+ for ABI in $(get_install_abis); do
+ export ABI
+ cd ${S}-${ABI}
+ econf || die "econf failed for $ABI"
+ emake || die "emake failed for $ABI"
+ done
+ ABI="${OABI}"
+ else
+ if useq amd64; then
+ check_multilib
+ export CFLAGS="${CFLAGS} -DSB_HAVE_64BIT_ARCH=${MULTILIB}"
+ fi
+ cd ${S}
+ econf || die "econf failed"
+ emake || die "emake failed"
+ fi
+}
+
+src_install() {
+ if has_multilib_profile; then
+ OABI="${ABI}"
+ for ABI in $(get_install_abis); do
+ export ABI
+ cd ${S}-${ABI}
+ einstall || die "einstall failed for $ABI"
+ done
+ ABI="${OABI}"
+ else
+ cd ${S}
+ einstall || die "einstalled failed"
+ fi
+}