summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetteri Räty <betelgeuse@gentoo.org>2009-07-25 09:26:12 +0000
committerPetteri Räty <betelgeuse@gentoo.org>2009-07-25 09:26:12 +0000
commita21d7b6ad9a577a5c1004261a49b56dcfb186c20 (patch)
treecf7c075cde58ccf6ec757e1e555b55442c4e5f2d /sys-apps/paludis/paludis-0.38.1.ebuild
parentAdd check for boost build with python use flag when python-bindings is enabled. (diff)
downloadhistorical-a21d7b6ad9a577a5c1004261a49b56dcfb186c20.tar.gz
historical-a21d7b6ad9a577a5c1004261a49b56dcfb186c20.tar.bz2
historical-a21d7b6ad9a577a5c1004261a49b56dcfb186c20.zip
Conditionalize libpcre built_with_use check under either qa or inquisitio use flags.
Package-Manager: portage-2.2_rc33/cvs/Linux i686
Diffstat (limited to 'sys-apps/paludis/paludis-0.38.1.ebuild')
-rw-r--r--sys-apps/paludis/paludis-0.38.1.ebuild12
1 files changed, 7 insertions, 5 deletions
diff --git a/sys-apps/paludis/paludis-0.38.1.ebuild b/sys-apps/paludis/paludis-0.38.1.ebuild
index 53dec4501cc7..63417d6aa993 100644
--- a/sys-apps/paludis/paludis-0.38.1.ebuild
+++ b/sys-apps/paludis/paludis-0.38.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/paludis/paludis-0.38.1.ebuild,v 1.2 2009/07/25 09:22:43 betelgeuse Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/paludis/paludis-0.38.1.ebuild,v 1.3 2009/07/25 09:26:12 betelgeuse Exp $
inherit bash-completion eutils flag-o-matic
@@ -48,10 +48,12 @@ create-paludis-user() {
}
pkg_setup() {
- if ! built_with_use dev-libs/libpcre cxx ; then
- eerror "Paludis needs dev-libs/libpcre built with C++ support"
- eerror "Please build dev-libs/libpcre with USE=cxx support"
- die "Rebuild dev-libs/libpcre with USE=cxx"
+ if use inquisitio || use qa; then
+ if ! built_with_use dev-libs/libpcre cxx ; then
+ eerror "Paludis needs dev-libs/libpcre built with C++ support"
+ eerror "Please build dev-libs/libpcre with USE=cxx support"
+ die "Rebuild dev-libs/libpcre with USE=cxx"
+ fi
fi
if use python-bindings && \