summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Black <dragonheart@gentoo.org>2004-06-05 06:11:30 +0000
committerDaniel Black <dragonheart@gentoo.org>2004-06-05 06:11:30 +0000
commit8de51de69442eb1c3b08007d5c5aad8aa6ebba9b (patch)
treeb18846a8957f513aa32c0cc2b4888f0f7f4156cc /sys-apps/microcode-ctl
parentinitial commit - ebuild submitted by Alexandru Toma via bug #52663 (diff)
downloadhistorical-8de51de69442eb1c3b08007d5c5aad8aa6ebba9b.tar.gz
historical-8de51de69442eb1c3b08007d5c5aad8aa6ebba9b.tar.bz2
historical-8de51de69442eb1c3b08007d5c5aad8aa6ebba9b.zip
Fixed to include udev support. bug #52982
Diffstat (limited to 'sys-apps/microcode-ctl')
-rw-r--r--sys-apps/microcode-ctl/ChangeLog9
-rw-r--r--sys-apps/microcode-ctl/Manifest4
-rw-r--r--sys-apps/microcode-ctl/files/digest-microcode-ctl-1.07-r12
-rw-r--r--sys-apps/microcode-ctl/microcode-ctl-1.07-r1.ebuild46
4 files changed, 59 insertions, 2 deletions
diff --git a/sys-apps/microcode-ctl/ChangeLog b/sys-apps/microcode-ctl/ChangeLog
index fe5213b2fc02..701bde04ffb9 100644
--- a/sys-apps/microcode-ctl/ChangeLog
+++ b/sys-apps/microcode-ctl/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-apps/microcode-ctl
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/microcode-ctl/ChangeLog,v 1.5 2004/05/23 20:40:56 dragonheart Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/microcode-ctl/ChangeLog,v 1.6 2004/06/05 06:11:29 dragonheart Exp $
+
+*microcode-ctl-1.07-r1 (05 Jun 2004)
+
+ 05 Jun 2004; Daniel Black <dragonheart@gentoo.org>
+ +microcode-ctl-1.07-r1.ebuild:
+ Fixed to include udev support. Thanks to Jason Wallace
+ <jason_wallace@myrealbox.com> in bug #52982
*microcode-ctl-1.07 (24 May 2004)
diff --git a/sys-apps/microcode-ctl/Manifest b/sys-apps/microcode-ctl/Manifest
index 2d023b7f1bb8..666b24b0cee1 100644
--- a/sys-apps/microcode-ctl/Manifest
+++ b/sys-apps/microcode-ctl/Manifest
@@ -1,6 +1,8 @@
-MD5 406b67ecf157524c10b418e22ced28b8 ChangeLog 1471
+MD5 dcbe58f5f41fb5cc1c2691291eb99487 ChangeLog 1698
MD5 9a09f8d531c582e78977dbfd96edc1f2 metadata.xml 164
+MD5 bba5b21b1dbce8d67741889df560119c microcode-ctl-1.07-r1.ebuild 1329
MD5 d9eba1125691972ab43ce81279434903 microcode-ctl-1.06-r1.ebuild 1393
MD5 a88efaae903d99007016212dafbc705b microcode-ctl-1.07.ebuild 1335
+MD5 61018eeebaafae71bedeeef06fcc6725 files/digest-microcode-ctl-1.07-r1 148
MD5 d7008d6229625e357c4168a2b7e63bb1 files/digest-microcode-ctl-1.06-r1 151
MD5 28fbe71f2e1e505f2f749bcf2ad15452 files/digest-microcode-ctl-1.07 151
diff --git a/sys-apps/microcode-ctl/files/digest-microcode-ctl-1.07-r1 b/sys-apps/microcode-ctl/files/digest-microcode-ctl-1.07-r1
new file mode 100644
index 000000000000..7705fe205c45
--- /dev/null
+++ b/sys-apps/microcode-ctl/files/digest-microcode-ctl-1.07-r1
@@ -0,0 +1,2 @@
+MD5 9d355d5edf03a0c9cbbdbbd163aaed60 microcode_ctl-1.07.tar.gz 170980
+MD5 9bf455889d7caff777ced8266b667478 microcode-ctl-1.07-gentoo.tar.bz2 106095
diff --git a/sys-apps/microcode-ctl/microcode-ctl-1.07-r1.ebuild b/sys-apps/microcode-ctl/microcode-ctl-1.07-r1.ebuild
new file mode 100644
index 000000000000..a404978bfe3d
--- /dev/null
+++ b/sys-apps/microcode-ctl/microcode-ctl-1.07-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/microcode-ctl/microcode-ctl-1.07-r1.ebuild,v 1.1 2004/06/05 06:11:29 dragonheart Exp $
+
+MY_P=${PN/-/_}-${PV}
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="Intel IA32 microcode update utility"
+HOMEPAGE="http://www.urbanmyth.org/microcode"
+SRC_URI="http://www.urbanmyth.org/microcode/${MY_P}.tar.gz
+ mirror://gentoo/${P}-gentoo.tar.bz2"
+IUSE=""
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~amd64 -ppc -sparc -hppa -mips -alpha"
+
+DEPEND="virtual/linux-sources"
+
+src_compile() {
+ make all || die "compile problem"
+}
+
+src_install() {
+ into /usr/
+ dosbin microcode_ctl
+ doman microcode_ctl.8
+ dodoc Changelog README
+ insinto /etc/
+ doins ${WORKDIR}/${PV}/microcode.dat
+ exeinto /etc/init.d/
+ doexe ${WORKDIR}/${PV}/microcode_ctl
+}
+
+pkg_postinst() {
+ einfo "Your kernel must include devfs or udev and microcode update support."
+ echo
+ einfo "To update the microcode now, run"
+ einfo ""
+ einfo "\tmicrocode_ctl -u"
+ einfo ""
+ einfo "The update will not survive a reboot. To have it do that run"
+ einfo ""
+ einfo "\trc-update add microcode_ctl default"
+ einfo ""
+ einfo "NOTE: For 2.6.x series kernels, use the '-d' flag to specify a"
+ einfo " different microcode device: /dev/microcode"
+}