summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrandon Low <lostlogic@gentoo.org>2004-01-11 20:10:22 +0000
committerBrandon Low <lostlogic@gentoo.org>2004-01-11 20:10:22 +0000
commit10dcaa07c2e872b4ba5208c887dc9c35a514a872 (patch)
tree3bd0eb15eab845448ce83a3a5281c2c4d3accb85 /sys-apps/lm-sensors
parentAdd a CVS snapshot which should work for users of 2.6.1 kernels who were gett... (diff)
downloadhistorical-10dcaa07c2e872b4ba5208c887dc9c35a514a872.tar.gz
historical-10dcaa07c2e872b4ba5208c887dc9c35a514a872.tar.bz2
historical-10dcaa07c2e872b4ba5208c887dc9c35a514a872.zip
Add a CVS snapshot which should work for users of 2.6.1 kernels who were getting errors reading temperatures with 2.8.2
Diffstat (limited to 'sys-apps/lm-sensors')
-rw-r--r--sys-apps/lm-sensors/Manifest6
-rw-r--r--sys-apps/lm-sensors/files/digest-lm-sensors-2.8.2.200401111
-rw-r--r--sys-apps/lm-sensors/lm-sensors-2.8.2.20040111.ebuild139
3 files changed, 143 insertions, 3 deletions
diff --git a/sys-apps/lm-sensors/Manifest b/sys-apps/lm-sensors/Manifest
index 5975ba875d77..ec32074b8e34 100644
--- a/sys-apps/lm-sensors/Manifest
+++ b/sys-apps/lm-sensors/Manifest
@@ -1,10 +1,10 @@
MD5 fce52fbef3d736da7592583a1255affc lm-sensors-2.8.1.ebuild 3825
-MD5 3d2dca7134535bcec3460324e4b79098 lm-sensors-2.7.0-r1.ebuild 2736
+MD5 846852ccef6091ef1bc98bf955e69cee lm-sensors-2.7.0-r1.ebuild 2668
MD5 0a8a5b7c595d62f66dedb4e0c81c81db lm-sensors-2.7.0.ebuild 2323
MD5 28373b812640d00c88c1b25d8e27d1f4 lm-sensors-2.8.0.ebuild 3697
-MD5 319f68b91b516c01ba436f7952fa9c3f lm-sensors-2.8.2.20040111.ebuild 4752
+MD5 fc63eec64677063e2bb7dea30ad088e5 lm-sensors-2.8.2.20040111.ebuild 4782
MD5 319f68b91b516c01ba436f7952fa9c3f lm-sensors-2.8.2.ebuild 4752
-MD5 7900e9c1d2a5c137832f543afd03664d ChangeLog 5357
+MD5 c03ea45b38b37e49841cfd7304e1e251 ChangeLog 5610
MD5 2bf0a19b70a2d6934eb9a38fe84d6702 lm-sensors-2.6.5.ebuild 2039
MD5 37443e54165d5bcdaa8550d52edafa98 metadata.xml 228
MD5 2217cbce56dd9da8bbe4188a24c9412f files/rc 2006
diff --git a/sys-apps/lm-sensors/files/digest-lm-sensors-2.8.2.20040111 b/sys-apps/lm-sensors/files/digest-lm-sensors-2.8.2.20040111
new file mode 100644
index 000000000000..f0418fcd6227
--- /dev/null
+++ b/sys-apps/lm-sensors/files/digest-lm-sensors-2.8.2.20040111
@@ -0,0 +1 @@
+MD5 042068157667b9f674e3ba4b872cc045 lm_sensors-2.8.2.20040111.tar.gz 742574
diff --git a/sys-apps/lm-sensors/lm-sensors-2.8.2.20040111.ebuild b/sys-apps/lm-sensors/lm-sensors-2.8.2.20040111.ebuild
new file mode 100644
index 000000000000..fb2c35518bdc
--- /dev/null
+++ b/sys-apps/lm-sensors/lm-sensors-2.8.2.20040111.ebuild
@@ -0,0 +1,139 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/lm-sensors/lm-sensors-2.8.2.20040111.ebuild,v 1.1 2004/01/11 20:10:15 lostlogic Exp $
+
+inherit flag-o-matic
+
+MY_P=${PN/-/_}-${PV}
+S="${WORKDIR}/${MY_P}"
+MYI2C="${WORKDIR}/i2c-headers"
+
+DESCRIPTION="Hardware Sensors Monitoring by lm_sensors"
+SRC_URI="http://dev.gentoo.org/~plasmaroo/patches/${PN}/${MY_P}.tar.gz"
+HOMEPAGE="http://www2.lm-sensors.nu/~lm78"
+
+SLOT="${KV}"
+# gentoo-sources-2.4.20-r1 and xfs-sources-2.4.20-r1 will
+# have support for this package, do not change these to ~
+# until your arch has i2c-2.7.0 in it's kernel.
+KEYWORDS="~x86 ~amd64 -ppc -sparc"
+LICENSE="GPL-2"
+
+DEPEND=""
+
+src_unpack() {
+ unpack ${A} || die
+ cd ${S} || die
+ epatch ${FILESDIR}/${PN}-2.8.2-sensors-detect-gentoo.diff > /dev/null || die
+
+ # Get the right I2C includes without dropping the kernel includes
+ mkdir -p ${MYI2C}/linux
+ cp /usr/include/linux/i2c* ${MYI2C}/linux/
+}
+
+src_compile() {
+ echo
+ einfo "*****************************************************************"
+ einfo
+ einfo "This ebuild assumes your /usr/src/linux kernel is the one you"
+ einfo "used to build i2c-2.8.2."
+ einfo
+ einfo "For 2.5+ series kernels, use the support already in the kernel"
+ einfo "under 'Character devices' -> 'I2C support' and then merge this"
+ einfo "ebuild."
+ einfo
+ einfo "To cross-compile, 'export LINUX=\"/lib/modules/<version>/build\"'"
+ einfo "or symlink /usr/src/linux to another kernel."
+ einfo
+ einfo "*****************************************************************"
+ echo
+
+ UserModeOnly=false
+ if [ "$LINUX" != "" ]; then
+ einfo "Cross-compiling using:- $LINUX"
+ LINUX=`echo $LINUX | sed 's/build\//build/'`
+ KV=`cut -d\ -f3 ${LINUX}include/linux/version.h | grep \" | sed -e 's/"//' -e 's/"//'`
+ if [ "${KV}" == "" ]; then
+ die "Could not get kernel version; make sure ${LINUX}include/linux/version.h is there!"
+ fi
+ else
+ LINUX='/usr/src/linux'
+ check_KV || die "Cannot find kernel in /usr/src/linux!"
+ einfo "Using kernel in /usr/src/linux/:- ${KV}"
+ fi
+ if [ `echo ${KV} | grep 2\.[56]\.` ]; then
+ einfo "You are using a 2.5 / 2.6 series kernel; only building utilities..."
+ UserModeOnly=true
+ else
+ einfo "You are using a `echo ${KV} | cut -d. -f-2` series kernel; building everything..."
+ fi
+ if [ "${KV}" != "${SLOT}" ]; then
+ echo
+ ewarn "WARNING:- Specified and running kernels do not match!"
+ ewarn "WARNING:- This package will be slotted as ${SLOT}!"
+ fi
+
+ if [ ! -e ${MYI2C}/linux/i2c.h ]; then
+ cp $LINUX/include/linux/i2c* ${MYI2C}/linux
+ fi
+
+ echo; einfo "You may safely ignore any errors from compilation"
+ einfo "that contain 'No such file' references."
+
+ echo
+ filter-flags -fPIC
+
+ cd ${S}
+ emake clean
+ if [ ${UserModeOnly} == true ]; then
+ emake I2C_HEADERS=${MYI2C} user || die "Could not compile user-mode utilities!"
+ else
+ emake I2C_HEADERS=${MYI2C} LINUX=$LINUX || die "lm_sensors requires the source of a compatible kernel version in /usr/src/linux or specified in \$LINUX and >=i2c-2.8.1 support built as modules. Make sure that I2C >=2.8.1 is on your system before filing a bug."
+ fi
+}
+
+src_install() {
+
+ mkdir -p ${D}/usr/bin
+ mkdir -p ${D}/usr/sbin
+ if [ ${UserModeOnly} == true ]; then
+ emake DESTDIR=${D} PREFIX=${D}/usr MANDIR=${D}/usr/share/man user_install || die "Install failed!"
+ else
+ emake LINUX=$LINUX DESTDIR=${D} PREFIX=${D}/usr MANDIR=${D}/usr/share/man install || die "Install failed!"
+ fi
+ cp ${D}/${D}* ${D} -Rf
+ rm ${D}/var -Rf
+
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/rc lm_sensors
+ dodoc BACKGROUND BUGS CHANGES CONTRIBUTORS COPYING INSTALL QUICKSTART \
+ README* TODO
+ cp -a doc/* ${D}/usr/share/doc/${PF}
+
+}
+
+pkg_postinst() {
+ [ -x /usr/sbin/update-modules ] && /usr/sbin/update-modules
+
+ echo
+ einfo
+ einfo "The lm_sensors hardware sensors package has been installed."
+ einfo
+ einfo "It is recommended that you read the lm_sensors documentation."
+ einfo "To enable lm_sensors you will need to compile i2c support in"
+ einfo "your kernel as a module and run /usr/sbin/sensors-detect to"
+ einfo "detect the hardware in your system."
+ einfo
+ einfo "Be warned, the probing of hardware in your system performed by"
+ einfo "sensors-detect could freeze your system. Also do not use"
+ einfo "lm_sensors on certain laptop models from IBM. See the lm_sensors"
+ einfo "documentation and website for more information."
+ einfo
+ einfo "IMPORTANT: When you merge this package it installs kernel modules"
+ einfo "that can only be used with the specific kernel version whose"
+ einfo "source is located in /usr/src/linux. If you upgrade to a new"
+ einfo "kernel, you will need to remerge the lm_sensors package to build"
+ einfo "new kernel modules."
+ einfo
+ echo
+}