summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWolfram Schlich <wschlich@gentoo.org>2004-09-05 18:28:50 +0000
committerWolfram Schlich <wschlich@gentoo.org>2004-09-05 18:28:50 +0000
commit82c070eff3c469f65cb8b92cef870b34e3c3e7c1 (patch)
tree898bdbaac0da2f60dfba702b6162a4a5a5982d68 /sys-apps/htop/htop-0.4.1.ebuild
parentadding ~amd64 to media-video/submux-dvd-0.5 (#59088) (diff)
downloadhistorical-82c070eff3c469f65cb8b92cef870b34e3c3e7c1.tar.gz
historical-82c070eff3c469f65cb8b92cef870b34e3c3e7c1.tar.bz2
historical-82c070eff3c469f65cb8b92cef870b34e3c3e7c1.zip
version bump
Diffstat (limited to 'sys-apps/htop/htop-0.4.1.ebuild')
-rw-r--r--sys-apps/htop/htop-0.4.1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/sys-apps/htop/htop-0.4.1.ebuild b/sys-apps/htop/htop-0.4.1.ebuild
new file mode 100644
index 000000000000..92eebe88d147
--- /dev/null
+++ b/sys-apps/htop/htop-0.4.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/htop/htop-0.4.1.ebuild,v 1.1 2004/09/05 18:28:50 wschlich Exp $
+
+inherit eutils flag-o-matic
+
+DESCRIPTION="interactive process viewer"
+HOMEPAGE="http://htop.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ppc"
+IUSE="debug"
+DEPEND="sys-libs/ncurses"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+}
+
+src_compile() {
+ use debug && {
+ append-flags -O -ggdb -DDEBUG
+ RESTRICT="${RESTRICT} nostrip"
+ }
+ econf || die "configure failed"
+ emake || die "make failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc README ChangeLog TODO
+}