summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2003-09-24 20:07:19 +0000
committerAron Griffis <agriffis@gentoo.org>2003-09-24 20:07:19 +0000
commitb6a87fcc50afaee7d0d5747c04a83889649a3283 (patch)
treee78160780b66b8c0b47418499ae71c0f46b48649 /sys-apps/hotplug
parentfix bogus error messages (diff)
downloadhistorical-b6a87fcc50afaee7d0d5747c04a83889649a3283.tar.gz
historical-b6a87fcc50afaee7d0d5747c04a83889649a3283.tar.bz2
historical-b6a87fcc50afaee7d0d5747c04a83889649a3283.zip
fix bogus error messages
Diffstat (limited to 'sys-apps/hotplug')
-rw-r--r--sys-apps/hotplug/Manifest4
-rw-r--r--sys-apps/hotplug/files/digest-hotplug-20030805-r12
-rw-r--r--sys-apps/hotplug/files/hotplug.functions.patch13
-rw-r--r--sys-apps/hotplug/hotplug-20030805-r1.ebuild62
4 files changed, 79 insertions, 2 deletions
diff --git a/sys-apps/hotplug/Manifest b/sys-apps/hotplug/Manifest
index 72abd7dd8bf7..bfd967a660d7 100644
--- a/sys-apps/hotplug/Manifest
+++ b/sys-apps/hotplug/Manifest
@@ -1,8 +1,8 @@
MD5 5ab9b61479b8fafefcaca30dbdbb314d hotplug-20020826-r2.ebuild 1563
MD5 95eed4ffc6aac22db5d1030f2d528e2e hotplug-20030805.ebuild 1530
MD5 8adbe30df2fad3fcdc443742156ddce5 hotplug-20030501-r2.ebuild 1517
-MD5 b86adc2a1c1193c92af9dd45916bd0e1 hotplug-20030805-r1.ebuild 1749
-MD5 e12333dfa5d7116c37b16174ac9ed344 ChangeLog 4043
+MD5 b2727f7bdfca2e4987d2d65063533e98 hotplug-20030805-r1.ebuild 1753
+MD5 befbbb024c8ea6b802f3cb3be44fc72d ChangeLog 4044
MD5 0e5a1a005fcfa0e242be02e9ef99de7a files/digest-hotplug-20020826-r2 224
MD5 a3281f5b866be688f79d9a46d060180a files/digest-hotplug-20030805 151
MD5 1bd9ddb0959318fe56dec239c8265fb1 files/usb.confd 291
diff --git a/sys-apps/hotplug/files/digest-hotplug-20030805-r1 b/sys-apps/hotplug/files/digest-hotplug-20030805-r1
new file mode 100644
index 000000000000..faa1d90068fa
--- /dev/null
+++ b/sys-apps/hotplug/files/digest-hotplug-20030805-r1
@@ -0,0 +1,2 @@
+MD5 200eef33ddfcee9c023a3a7797ac6919 hotplug-2003_08_05.tar.gz 42537
+MD5 a0db235527f911f91473e04f752fbffe hotplug-20030805-gentoo-patches.tar.bz2 1991
diff --git a/sys-apps/hotplug/files/hotplug.functions.patch b/sys-apps/hotplug/files/hotplug.functions.patch
new file mode 100644
index 000000000000..e7df638a2c66
--- /dev/null
+++ b/sys-apps/hotplug/files/hotplug.functions.patch
@@ -0,0 +1,13 @@
+--- hotplug-20030805/etc/hotplug/hotplug.functions.orig 2003-09-24 09:35:09.000000000 -0400
++++ hotplug-20030805/etc/hotplug/hotplug.functions 2003-09-24 15:59:20.000000000 -0400
+@@ -139,7 +139,9 @@
+ do
+ # maybe driver modules need loading
+ LOADED=false
+- if ! lsmod | grep -q "^$MODULE " > /dev/null 2>&1; then
++ if lsmod | grep -q "^$MODULE "; then
++ LOADED=true
++ else
+ if grep -q "^$MODULE\$" $HOTPLUG_DIR/blacklist \
+ >/dev/null 2>&1; then
+ debug_mesg "... blacklisted module: $MODULE"
diff --git a/sys-apps/hotplug/hotplug-20030805-r1.ebuild b/sys-apps/hotplug/hotplug-20030805-r1.ebuild
new file mode 100644
index 000000000000..d3738d23fad2
--- /dev/null
+++ b/sys-apps/hotplug/hotplug-20030805-r1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/hotplug/hotplug-20030805-r1.ebuild,v 1.1 2003/09/24 20:07:15 agriffis Exp $
+
+inherit eutils
+
+# source maintainers named it hotplug-YYYY_MM_DD instead of hotplug-YYYYMMDD
+MY_P=${PN}-${PV:0:4}_${PV:4:2}_${PV:6:2}
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="USB and PCI hotplug scripts"
+HOMEPAGE="http://linux-hotplug.sourceforge.net"
+SRC_URI="mirror://sourceforge/linux-hotplug/${MY_P}.tar.gz
+ mirror://gentoo/${P}-gentoo-patches.tar.bz2"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~amd64 ~ppc ~hppa ~sparc ~alpha ~mips ~arm"
+
+# hotplug needs pcimodules utility provided by pcitutils-2.1.9-r1
+DEPEND=">=sys-apps/pciutils-2.1.9
+ >=sys-apps/usbutils-0.9"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ EPATCH_SUFFIX="patch" epatch ${WORKDIR}/hotplug-patches
+
+ # The following patch prevents bogus messages of the flavor
+ # "missing kernel or user mode driver prism2_usb". It has been
+ # mentioned on the linux-hotplug mailing list.
+ epatch ${FILESDIR}/hotplug.functions.patch
+}
+
+src_install() {
+ into /
+ dosbin sbin/hotplug
+ doman *.8
+ dodoc README ChangeLog
+
+ cd ${S}/etc/hotplug
+ insinto /etc/hotplug
+ doins blacklist hotplug.functions usb.distmap usb.handmap usb.usermap
+ exeinto /etc/hotplug
+ doexe *.agent *.rc
+ dodir /etc/hotplug/usb /etc/hotplug/pci
+ cd ${S}/etc/hotplug.d/default
+ exeinto /etc/hotplug.d/default
+ doexe default.hotplug
+
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/hotplug.rc hotplug
+
+ insinto /etc/conf.d
+ newins ${FILESDIR}/usb.confd usb
+ dodir /var/run/usb
+}
+
+pkg_postinst() {
+ ewarn "WARNING: The fxload program was spliced off this package"
+ ewarn "WARNING: emerge fxload if you need it"
+}
+