summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Robbins <drobbins@gentoo.org>2001-10-06 17:13:29 +0000
committerDaniel Robbins <drobbins@gentoo.org>2001-10-06 17:13:29 +0000
commitf808d300ce948c5b81cf5c21de2e3a05abd824e1 (patch)
treec8c9643c98312ebe63cbe13ee800be1c3075828f /sys-apps/gzip/gzip-1.2.4a-r6.ebuild
parentfixums (diff)
downloadhistorical-f808d300ce948c5b81cf5c21de2e3a05abd824e1.tar.gz
historical-f808d300ce948c5b81cf5c21de2e3a05abd824e1.tar.bz2
historical-f808d300ce948c5b81cf5c21de2e3a05abd824e1.zip
fixums
Diffstat (limited to 'sys-apps/gzip/gzip-1.2.4a-r6.ebuild')
-rw-r--r--sys-apps/gzip/gzip-1.2.4a-r6.ebuild72
1 files changed, 24 insertions, 48 deletions
diff --git a/sys-apps/gzip/gzip-1.2.4a-r6.ebuild b/sys-apps/gzip/gzip-1.2.4a-r6.ebuild
index 09995ae41049..0baa06c9c780 100644
--- a/sys-apps/gzip/gzip-1.2.4a-r6.ebuild
+++ b/sys-apps/gzip/gzip-1.2.4a-r6.ebuild
@@ -1,16 +1,12 @@
-# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Copyright 1999-2001 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# Author Daniel Robbins <drobbins@gentoo.org>
-# Chad Huneycutt <chad.huneycutt@acm.org>
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/gzip/gzip-1.2.4a-r6.ebuild,v 1.1 2001/08/14 01:59:52 chadh Exp $
+# Author Daniel Robbins <drobbins@gentoo.org>, Chad Huneycutt <chad.huneycutt@acm.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/gzip/gzip-1.2.4a-r6.ebuild,v 1.2 2001/10/06 17:13:29 drobbins Exp $
-A=${P}.tar.gz
S=${WORKDIR}/${P}
DESCRIPTION="Standard GNU compressor"
-SRC_URI="ftp://gatekeeper.dec.com/pub/GNU/gzip/${A}
- ftp://prep.ai.mit.edu/gnu/gzip/${A}"
+SRC_URI="ftp://gatekeeper.dec.com/pub/GNU/gzip/${P}.tar.gz ftp://prep.ai.mit.edu/gnu/gzip/${P}.tar.gz"
HOMEPAGE="http://www.gnu.org/software/gzip/gzip.html"
-
DEPEND="virtual/glibc nls? ( sys-devel/gettext )"
RDEPEND="virtual/glibc"
@@ -21,29 +17,14 @@ src_unpack() {
}
src_compile() {
-
- local myconf
- if [ -z "`use nls`" ]
- then
- myconf="--disable-nls"
- fi
-
- try ./configure --host=${CHOST} --prefix=/usr --exec-prefix=/ \
- --mandir=/usr/share/man --infodir=/usr/share/info ${myconf}
-
- if [ -z "`use static`" ]
- then
- try pmake
- else
- try pmake LDFLAGS=-static ${MAKEOPTS}
- fi
+ [ -z "`use nls`" ] && myconf="--disable-nls"
+ ./configure --host=${CHOST} --prefix=/usr --exec-prefix=/ --mandir=/usr/share/man --infodir=/usr/share/info ${myconf} || die
+ emake || die
}
src_install() {
-
dodir /usr/bin /usr/share/man/man1
- try make prefix=${D}/usr exec_prefix=${D}/ mandir=${D}/usr/share/man/man1 infodir=${D}/usr/share/info install
-
+ make prefix=${D}/usr exec_prefix=${D}/ mandir=${D}/usr/share/man/man1 infodir=${D}/usr/share/info install || die
cd ${D}/bin
for i in gzexe zforce zgrep zmore znew zcmp
do
@@ -52,27 +33,22 @@ src_install() {
rm ${i}.orig
chmod 755 ${i}
done
-
- if [ -z "`use build`" ] && [ -z "`use bootcd`" ]
- then
- cd ${D}/usr/share/man/man1
-
- for i in gzexe gzip zcat zcmp zdiff zforce \
- zgrep zmore znew
- do
- rm ${i}.1
- ln -s gunzip.1.gz ${i}.1.gz
- done
-
- cd ${S}
- rm -rf ${D}/usr/man ${D}/usr/lib
-
- dodoc ChangeLog COPYING NEWS README THANKS TODO
- docinto txt
- dodoc algorithm.doc gzip.doc
- else
- rm -rf ${D}/usr
- fi
+ if [ -z "`use build`" ]
+ then
+ cd ${D}/usr/share/man/man1
+ for i in gzexe gzip zcat zcmp zdiff zforce zgrep zmore znew
+ do
+ rm ${i}.1
+ ln -s gunzip.1.gz ${i}.1.gz
+ done
+ cd ${S}
+ rm -rf ${D}/usr/man ${D}/usr/lib
+ dodoc ChangeLog COPYING NEWS README THANKS TODO
+ docinto txt
+ dodoc algorithm.doc gzip.doc
+ else
+ rm -rf ${D}/usr
+ fi
}