summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonny Davies <woodchip@gentoo.org>2001-10-03 04:35:20 +0000
committerDonny Davies <woodchip@gentoo.org>2001-10-03 04:35:20 +0000
commit03109a7bca193d3d89ef32bbb71635ce9ee926f7 (patch)
tree20cd9399803b3bf5df81d6d76b51fff440263914 /sys-apps/dcron/files
parentdcron rc5/rc6 support. remove some old commented out cruft from package.mask (diff)
downloadhistorical-03109a7bca193d3d89ef32bbb71635ce9ee926f7.tar.gz
historical-03109a7bca193d3d89ef32bbb71635ce9ee926f7.tar.bz2
historical-03109a7bca193d3d89ef32bbb71635ce9ee926f7.zip
dcron rc5/rc6 support. i knocked the previous revision down to dcron-2.7.ebuild. sorry if that causes any pain. it shouldnt really be a problem since the inclusion masks are setup properly for this. major change to the install routine and the patchfile, this simplifies the whole mess somewhat.
Diffstat (limited to 'sys-apps/dcron/files')
-rw-r--r--sys-apps/dcron/files/dcron-2.7-Makefile-gentoo.diff34
-rw-r--r--sys-apps/dcron/files/dcron-newinit16
-rwxr-xr-xsys-apps/dcron/files/dcron-run2
-rw-r--r--[-rwxr-xr-x]sys-apps/dcron/files/dcron.rc5 (renamed from sys-apps/dcron/files/dcron)0
-rw-r--r--sys-apps/dcron/files/dcron.rc617
-rw-r--r--sys-apps/dcron/files/digest-dcron-2.7 (renamed from sys-apps/dcron/files/digest-dcron-2.7-r4)0
-rw-r--r--sys-apps/dcron/files/digest-dcron-2.7-r6 (renamed from sys-apps/dcron/files/digest-dcron-2.7-r5)0
-rwxr-xr-xsys-apps/dcron/files/log-run2
-rwxr-xr-xsys-apps/dcron/files/svc-dcron28
9 files changed, 17 insertions, 82 deletions
diff --git a/sys-apps/dcron/files/dcron-2.7-Makefile-gentoo.diff b/sys-apps/dcron/files/dcron-2.7-Makefile-gentoo.diff
index 15094d304062..0272185e550e 100644
--- a/sys-apps/dcron/files/dcron-2.7-Makefile-gentoo.diff
+++ b/sys-apps/dcron/files/dcron-2.7-Makefile-gentoo.diff
@@ -23,37 +23,3 @@
protos.h: ${SRCS} ${D_SRCS}
fgrep -h Prototype ${SRCS} ${D_SRCS} >protos.h
-@@ -31,18 +31,21 @@
- rm -f *.o dcron.tgz $(PROTOS)
-
- install:
-- rm -f /usr/bin/crond /usr/bin/crontab
-- cp crond crontab /usr/bin
-- chown root.wheel /usr/bin/crond
-- chown root.cron /usr/bin/crontab
-- chmod 700 /usr/bin/crond
-- chmod 4750 /usr/bin/crontab
-- -mkdirs /usr/man/man1
-- -mkdirs /usr/man/man8
-- cp crontab.1 /usr/man/man1
-- cp crond.8 /usr/man/man8
-- chmod 444 /usr/man/man1/crontab.1
-- chmod 444 /usr/man/man8/crond.8
-+ mkdir $(DESTDIR)/usr
-+ mkdir $(DESTDIR)/usr/bin
-+ cp crond crontab $(DESTDIR)/usr/bin
-+ chown root.wheel $(DESTDIR)/usr/bin/crond
-+ chown root.cron $(DESTDIR)/usr/bin/crontab
-+ chmod 700 $(DESTDIR)/usr/bin/crond
-+ chmod 4750 $(DESTDIR)/usr/bin/crontab
-+ mkdir $(DESTDIR)/usr/share
-+ mkdir $(DESTDIR)/usr/share/man
-+ mkdir $(DESTDIR)/usr/share/man/man1
-+ mkdir $(DESTDIR)/usr/share/man/man8
-+ cp crontab.1 $(DESTDIR)/usr/share/man/man1
-+ cp crond.8 $(DESTDIR)/usr/share/man/man8
-+ chmod 444 $(DESTDIR)/usr/share/man/man1/crontab.1
-+ chmod 444 $(DESTDIR)/usr/share/man/man8/crond.8
-
- # dillon-specific
- #
diff --git a/sys-apps/dcron/files/dcron-newinit b/sys-apps/dcron/files/dcron-newinit
deleted file mode 100644
index a1b9180f606c..000000000000
--- a/sys-apps/dcron/files/dcron-newinit
+++ /dev/null
@@ -1,16 +0,0 @@
-#!/sbin/runscript
-
-SERVICE=dcron
-EXE="/usr/sbin/crond"
-
-start() {
- ebegin "Starting ${SERVICE}"
- start-stop-daemon --start --quiet --exec $EXE 1>&2
- eend $? "Error starting ${SERVICE}."
-}
-
-stop() {
- ebegin "Stopping ${SERVICE}"
- start-stop-daemon --stop --quiet -u root -n $SERVICE 1>&2
- eend $? "Error stopping ${SERVICE}."
-}
diff --git a/sys-apps/dcron/files/dcron-run b/sys-apps/dcron/files/dcron-run
deleted file mode 100755
index 7678679ffecc..000000000000
--- a/sys-apps/dcron/files/dcron-run
+++ /dev/null
@@ -1,2 +0,0 @@
-#!/bin/sh
-exec /usr/sbin/crond 2>&1 -f
diff --git a/sys-apps/dcron/files/dcron b/sys-apps/dcron/files/dcron.rc5
index a8da6b9eddd7..a8da6b9eddd7 100755..100644
--- a/sys-apps/dcron/files/dcron
+++ b/sys-apps/dcron/files/dcron.rc5
diff --git a/sys-apps/dcron/files/dcron.rc6 b/sys-apps/dcron/files/dcron.rc6
new file mode 100644
index 000000000000..d9e0088d7bdf
--- /dev/null
+++ b/sys-apps/dcron/files/dcron.rc6
@@ -0,0 +1,17 @@
+#!/sbin/runscript
+
+depend() {
+ need clock
+}
+
+start() {
+ ebegin "Starting dcron"
+ start-stop-daemon --start --quiet --exec /usr/sbin/crond
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping dcron"
+ start-stop-daemon --stop --quiet --exec /usr/sbin/crond
+ eend $?
+}
diff --git a/sys-apps/dcron/files/digest-dcron-2.7-r4 b/sys-apps/dcron/files/digest-dcron-2.7
index d7f67342a50f..d7f67342a50f 100644
--- a/sys-apps/dcron/files/digest-dcron-2.7-r4
+++ b/sys-apps/dcron/files/digest-dcron-2.7
diff --git a/sys-apps/dcron/files/digest-dcron-2.7-r5 b/sys-apps/dcron/files/digest-dcron-2.7-r6
index d7f67342a50f..d7f67342a50f 100644
--- a/sys-apps/dcron/files/digest-dcron-2.7-r5
+++ b/sys-apps/dcron/files/digest-dcron-2.7-r6
diff --git a/sys-apps/dcron/files/log-run b/sys-apps/dcron/files/log-run
deleted file mode 100755
index a1482342ca08..000000000000
--- a/sys-apps/dcron/files/log-run
+++ /dev/null
@@ -1,2 +0,0 @@
-#!/bin/sh
-exec multilog t /var/log/dcron.d
diff --git a/sys-apps/dcron/files/svc-dcron b/sys-apps/dcron/files/svc-dcron
deleted file mode 100755
index 24199adeed94..000000000000
--- a/sys-apps/dcron/files/svc-dcron
+++ /dev/null
@@ -1,28 +0,0 @@
-#!/bin/sh
-#RCUPDATE:2 3 4:80:This line is required for script management
-
-. /etc/rc.d/config/basic
-. /etc/rc.d/config/functions
-
-SERVICE=dcron
-opts="start stop"
-
-start() {
- ebegin "Starting supervised ${SERVICE}"
- ln -sf ../services/${SERVICE} ${SVCDIR}/control/${SERVICE}
- eend $?
-}
-
-stop() {
- ebegin "Stopping supervised ${SERVICE}"
- if [ -e ${SVCDIR}/control/${SERVICE} ]
- then
- /usr/bin/svc -dx ${SVCDIR}/control/${SERVICE}/log
- /usr/bin/svc -dx ${SVCDIR}/control/${SERVICE}
- rm ${SVCDIR}/control/${SERVICE}
- fi
- eend $?
-}
-
-doservice ${@}
-