summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2009-06-24 04:17:57 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2009-06-24 04:17:57 +0000
commitd47eec7c37c3b3ec6d8cf4988a725e7e7c540956 (patch)
treef3195e784c0285ea6e11434fb2bccbde367d4a66 /sci-physics
parentVersion bump, thanks Ben Bannier for testing, closing bug #274969 (diff)
downloadhistorical-d47eec7c37c3b3ec6d8cf4988a725e7e7c540956.tar.gz
historical-d47eec7c37c3b3ec6d8cf4988a725e7e7c540956.tar.bz2
historical-d47eec7c37c3b3ec6d8cf4988a725e7e7c540956.zip
Version bump, thanks Ben Bannier for testing, closing bug #274975
Package-Manager: portage-2.2_rc33/cvs/Linux x86_64
Diffstat (limited to 'sci-physics')
-rw-r--r--sci-physics/hepmc/ChangeLog8
-rw-r--r--sci-physics/hepmc/hepmc-2.05.00.ebuild48
2 files changed, 55 insertions, 1 deletions
diff --git a/sci-physics/hepmc/ChangeLog b/sci-physics/hepmc/ChangeLog
index ef577eb96688..b3d90eb4aa41 100644
--- a/sci-physics/hepmc/ChangeLog
+++ b/sci-physics/hepmc/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-physics/hepmc
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/hepmc/ChangeLog,v 1.6 2009/05/05 19:37:24 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/hepmc/ChangeLog,v 1.7 2009/06/24 04:17:57 bicatali Exp $
+
+*hepmc-2.05.00 (24 Jun 2009)
+
+ 24 Jun 2009; SĂ©bastien Fabbro <bicatali@gentoo.org>
+ +hepmc-2.05.00.ebuild:
+ Version bump, thanks Ben Bannier for testing, closing bug #274975
05 May 2009; Christian Faulhammer <fauli@gentoo.org> hepmc-2.04.00.ebuild:
stable x86, bug 245875
diff --git a/sci-physics/hepmc/hepmc-2.05.00.ebuild b/sci-physics/hepmc/hepmc-2.05.00.ebuild
new file mode 100644
index 000000000000..1edf063f9ac1
--- /dev/null
+++ b/sci-physics/hepmc/hepmc-2.05.00.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/hepmc/hepmc-2.05.00.ebuild,v 1.1 2009/06/24 04:17:57 bicatali Exp $
+
+EAPI=2
+
+MYP=HepMC-${PV}
+
+DESCRIPTION="Event Record for Monte Carlo Generators"
+HOMEPAGE="https://savannah.cern.ch/projects/hepmc/"
+SRC_URI="http://lcgapp.cern.ch/project/simu/HepMC/download/${MYP}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~sparc ~x86"
+IUSE="doc examples gev cm"
+
+DEPEND=""
+
+S="${WORKDIR}/${MYP}"
+
+src_configure() {
+ # random default choice: use MeV over GeV and mm over cm
+ local length_conf="MM"
+ use cm && length_conf="CM"
+ local momentum_conf="MEV"
+ use gev && momentum_conf="GEV"
+ econf \
+ --with-length=${length_conf} \
+ --with-momentum=${momentum_conf}
+}
+
+src_install() {
+ emake \
+ DESTDIR="${D}" \
+ INSTALLDIR=/usr/share/doc/${PF}/examples \
+ doc_installdir=/usr/share/doc/${PF} \
+ install || die "emake install failed"
+
+ dodoc README AUTHORS ChangeLog
+ insinto /usr/share/doc/${PF}
+ if use doc; then
+ doins -r doc/html || die
+ else
+ rm -f "${D}"/usr/share/doc/${PF}/*pdf
+ fi
+ use examples || rm -rf "${D}"/usr/share/doc/${PF}/examples
+}