summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2012-09-20 13:11:18 +0000
committerMark Wright <gienah@gentoo.org>2012-09-20 13:11:18 +0000
commit58b754b80794f4f7d7ad79e20e217587c6d661e8 (patch)
tree8fc7e22c4f69ef9634c252a434af5671f0353ca3 /sci-mathematics
parentisabelle doc requires a symlink (diff)
downloadhistorical-58b754b80794f4f7d7ad79e20e217587c6d661e8.tar.gz
historical-58b754b80794f4f7d7ad79e20e217587c6d661e8.tar.bz2
historical-58b754b80794f4f7d7ad79e20e217587c6d661e8.zip
Bump E to 1.6 Tiger Hill
Package-Manager: portage-2.1.11.18/cvs/Linux x86_64
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/e/ChangeLog8
-rw-r--r--sci-mathematics/e/e-1.6.ebuild131
2 files changed, 137 insertions, 2 deletions
diff --git a/sci-mathematics/e/ChangeLog b/sci-mathematics/e/ChangeLog
index d765047586d7..90c5c2ce1cce 100644
--- a/sci-mathematics/e/ChangeLog
+++ b/sci-mathematics/e/ChangeLog
@@ -1,9 +1,13 @@
# ChangeLog for sci-mathematics/e
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/e/ChangeLog,v 1.1 2012/05/30 00:55:22 gienah Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/e/ChangeLog,v 1.2 2012/09/20 13:11:18 gienah Exp $
+
+*e-1.6 (20 Sep 2012)
+
+ 20 Sep 2012; Mark Wright <gienah@gentoo.org> +e-1.6.ebuild:
+ Bump E to 1.6 Tiger Hill
*e-1.5 (30 May 2012)
30 May 2012; Mark Wright <gienah@gentoo.org> +e-1.5.ebuild, +metadata.xml:
Add E theorem prover, with optional Isabelle/HOL sledgehammer integration.
-
diff --git a/sci-mathematics/e/e-1.6.ebuild b/sci-mathematics/e/e-1.6.ebuild
new file mode 100644
index 000000000000..30b85907c67d
--- /dev/null
+++ b/sci-mathematics/e/e-1.6.ebuild
@@ -0,0 +1,131 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/e/e-1.6.ebuild,v 1.1 2012/09/20 13:11:18 gienah Exp $
+
+EAPI="4"
+
+MY_PN="E"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="E is a theorem prover for full first-order logic with equality"
+HOMEPAGE="http://www4.informatik.tu-muenchen.de/~schulz/E/E.html"
+SRC_URI="http://www4.in.tum.de/~schulz/WORK/E_DOWNLOAD/V_${PV}/${MY_PN}.tgz -> ${MY_P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="doc examples isabelle"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ isabelle? (
+ >=sci-mathematics/isabelle-2011.1-r1
+ )"
+
+S="${WORKDIR}"/${MY_PN}
+
+src_configure() {
+ ./configure --prefix="${ROOT}usr" \
+ --man-prefix="${ROOT}share/man" \
+ || die "E configure failed"
+
+ sed -e "s@CFLAGS = @CFLAGS = ${CFLAGS} @" \
+ -e "s@LD = \$(CC) @LD = \$(CC) ${LDFLAGS} @" \
+ -i "${S}/Makefile.vars" \
+ || die "Could not add our flags to Makefile.vars"
+}
+
+src_install() {
+ for i in "${S}/PROVER/eprover" \
+ "${S}/PROVER/epclextract" \
+ "${S}/PROVER/eproof" \
+ "${S}/PROVER/eproof_ram" \
+ "${S}/PROVER/eground" \
+ "${S}/PROVER/e_ltb_runner" \
+ "${S}/PROVER/e_axfilter" \
+ "${S}/PROVER/checkproof" \
+ "${S}/PROVER/ekb_create" \
+ "${S}/PROVER/ekb_delete" \
+ "${S}/PROVER/ekb_ginsert" \
+ "${S}/PROVER/ekb_insert"
+ do
+ dobin "${i}"
+ done
+
+ for i in "${S}/DOC/man/eprover.1" \
+ "${S}/DOC/man/epclextract.1" \
+ "${S}/DOC/man/eproof.1" \
+ "${S}/DOC/man/eproof_ram.1" \
+ "${S}/DOC/man/eground.1" \
+ "${S}/DOC/man/e_ltb_runner.1" \
+ "${S}/DOC/man/e_axfilter.1" \
+ "${S}/DOC/man/checkproof.1" \
+ "${S}/DOC/man/ekb_create.1" \
+ "${S}/DOC/man/ekb_delete.1" \
+ "${S}/DOC/man/ekb_ginsert.1" \
+ "${S}/DOC/man/ekb_insert.1"
+ do
+ doman "${i}"
+ done
+
+ if use doc; then
+ pushd "${S}"/DOC || die "Could not cd to DOC"
+ dodoc ANNOUNCE CREDITS DONE E-REMARKS E-REMARKS.english E-USERS \
+ HISTORY NEWS PORTING ReadMe THINKME TODO TPTP_SUBMISSION \
+ WISHLIST eprover.pdf
+ dohtml *.html
+ insinto /usr/share/doc/${PF}/html
+ doins estyle.sty
+ popd
+ fi
+
+ if use examples; then
+ dodir /usr/share/${MY_PN}/examples
+ insinto /usr/share/${MY_PN}/examples
+ doins -r EXAMPLE_PROBLEMS
+ doins -r SIMPLE_APPS
+ fi
+
+ if use isabelle; then
+ ISABELLE_HOME="$(isabelle getenv ISABELLE_HOME | cut -d'=' -f 2)" \
+ || die "isabelle getenv ISABELLE_HOME failed"
+ if [[ -z "${ISABELLE_HOME}" ]]; then
+ die "ISABELLE_HOME empty"
+ fi
+ dodir "${ISABELLE_HOME}/contrib/${PN}-${PV}/etc"
+ cat <<- EOF >> "${S}/settings"
+ E_HOME="${ROOT}usr/bin"
+ E_VERSION="${PV}"
+ EOF
+ insinto "${ISABELLE_HOME}/contrib/${PN}-${PV}/etc"
+ doins "${S}/settings"
+ fi
+}
+
+pkg_postinst() {
+ if use isabelle; then
+ if [ -f "${ROOT}etc/isabelle/components" ]; then
+ if egrep "contrib/${PN}-[0-9.]*" "${ROOT}etc/isabelle/components"; then
+ sed -e "/contrib\/${PN}-[0-9.]*/d" \
+ -i "${ROOT}etc/isabelle/components"
+ fi
+ cat <<- EOF >> "${ROOT}etc/isabelle/components"
+ contrib/${PN}-${PV}
+ EOF
+ fi
+ fi
+}
+
+pkg_postrm() {
+ if use isabelle; then
+ if [ ! -f "${ROOT}usr/bin/eproof" ]; then
+ if [ -f "${ROOT}etc/isabelle/components" ]; then
+ # Note: this sed should only match the version of this ebuild
+ # Which is what we want as we do not want to remove the line
+ # of a new E being installed during an upgrade.
+ sed -e "/contrib\/${PN}-${PV}/d" \
+ -i "${ROOT}etc/isabelle/components"
+ fi
+ fi
+ fi
+}