summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2008-06-04 16:40:53 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2008-06-04 16:40:53 +0000
commitb003b1f23d364002014f8f226785245003f9eccd (patch)
tree4494163c5e0eac1239daf3b4814b6e6fad78af5d /sci-mathematics/dataplot/dataplot-20080225.ebuild
parentInitial import from sunrise. Proxy-maintaining for Thomas Anderson (diff)
downloadhistorical-b003b1f23d364002014f8f226785245003f9eccd.tar.gz
historical-b003b1f23d364002014f8f226785245003f9eccd.tar.bz2
historical-b003b1f23d364002014f8f226785245003f9eccd.zip
Fixed directory changes
Package-Manager: portage-2.1.5.3
Diffstat (limited to 'sci-mathematics/dataplot/dataplot-20080225.ebuild')
-rw-r--r--sci-mathematics/dataplot/dataplot-20080225.ebuild9
1 files changed, 6 insertions, 3 deletions
diff --git a/sci-mathematics/dataplot/dataplot-20080225.ebuild b/sci-mathematics/dataplot/dataplot-20080225.ebuild
index f99d5a0b5681..ed57e7983af6 100644
--- a/sci-mathematics/dataplot/dataplot-20080225.ebuild
+++ b/sci-mathematics/dataplot/dataplot-20080225.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/dataplot/dataplot-20080225.ebuild,v 1.1 2008/06/04 16:31:40 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/dataplot/dataplot-20080225.ebuild,v 1.2 2008/06/04 16:40:53 bicatali Exp $
inherit eutils toolchain-funcs flag-o-matic autotools fortran
@@ -48,9 +48,12 @@ pkg_setup() {
src_unpack() {
# unpacking and renaming because
# upstream does not use directories
- mkdir "${S_AUX}" && cd "${S_AUX}"
+ mkdir "${S_AUX}"
+ pushd "${S_AUX}"
unpack ${MY_P_AUX}.tar.gz
- mkdir ${MY_P} && cd "${S}"
+ popd
+ mkdir ${MY_P}
+ cd "${S}"
unpack ${MY_P}.tar.gz
# autotoolization: need to fix a few files with