summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2007-08-05 12:07:03 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2007-08-05 12:07:03 +0000
commit6183031fd960f58239c6b95a648a4f25b06e77d3 (patch)
treea1a43101f504539536f943101ea926ca986194ce /sci-libs/netcdf/files
parentRemove the dependency on sys-libs/lrmi. (diff)
downloadhistorical-6183031fd960f58239c6b95a648a4f25b06e77d3.tar.gz
historical-6183031fd960f58239c6b95a648a4f25b06e77d3.tar.bz2
historical-6183031fd960f58239c6b95a648a4f25b06e77d3.zip
Fixed parallel-make for fortran. Closing bug #187759, thanks to Ed Catmur <ed@catmur.co.uk>. Removed obsolete versions.
Package-Manager: portage-2.1.2.11
Diffstat (limited to 'sci-libs/netcdf/files')
-rw-r--r--sci-libs/netcdf/files/digest-netcdf-3.5.0-r33
-rw-r--r--sci-libs/netcdf/files/digest-netcdf-3.6.0-r13
-rw-r--r--sci-libs/netcdf/files/gcc3-gentoo.patch245
-rw-r--r--sci-libs/netcdf/files/netcdf-3.6.2-parallel-make.patch15
4 files changed, 15 insertions, 251 deletions
diff --git a/sci-libs/netcdf/files/digest-netcdf-3.5.0-r3 b/sci-libs/netcdf/files/digest-netcdf-3.5.0-r3
deleted file mode 100644
index 730db80e2338..000000000000
--- a/sci-libs/netcdf/files/digest-netcdf-3.5.0-r3
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 28640a40a44f982f90f5eeb15e917a1f netcdf-3.5.0.tar.Z 1319419
-RMD160 4313e00fc56273e871c003bfb27c533d4a7f556f netcdf-3.5.0.tar.Z 1319419
-SHA256 d3a2113a9174d845dc377122826cd68b1e02fbb253c0f0c253b8e1c199c84b97 netcdf-3.5.0.tar.Z 1319419
diff --git a/sci-libs/netcdf/files/digest-netcdf-3.6.0-r1 b/sci-libs/netcdf/files/digest-netcdf-3.6.0-r1
deleted file mode 100644
index 8751c862900c..000000000000
--- a/sci-libs/netcdf/files/digest-netcdf-3.6.0-r1
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 27c193e0462d9979406d167a01a5ee95 netcdf-3.6.0-p1.tar.gz 842025
-RMD160 f59877c5f1f70b7099f263f0a34c1b1bd12d41d9 netcdf-3.6.0-p1.tar.gz 842025
-SHA256 a9e6105ed89ce6cfd2edc78e8184232a2f950e674c5241c28cae361a1fe1adfe netcdf-3.6.0-p1.tar.gz 842025
diff --git a/sci-libs/netcdf/files/gcc3-gentoo.patch b/sci-libs/netcdf/files/gcc3-gentoo.patch
deleted file mode 100644
index dd4d05c42f4b..000000000000
--- a/sci-libs/netcdf/files/gcc3-gentoo.patch
+++ /dev/null
@@ -1,245 +0,0 @@
-*** cxx/ncvalues.h.orig 2002-07-31 03:03:17.000000000 +0930
---- cxx/ncvalues.h 2002-07-31 03:26:14.000000000 +0930
-***************
-*** 10,25 ****
- #ifndef Ncvalues_def
- #define Ncvalues_def
-
-! #include <iostream.h>
-! #ifdef STRSTREAM_H_SPEC
-! # include STRSTREAM_H_SPEC
-! #else
-! # include <strstream.h>
-! #endif
- #include <limits.h>
- #include <string.h>
- #include "netcdf.h"
-!
- typedef unsigned char ncbyte;
-
- #define NC_UNSPECIFIED ((nc_type)0)
---- 10,22 ----
- #ifndef Ncvalues_def
- #define Ncvalues_def
-
-! #include <iostream>
-! #include <sstream>
-! extern "C" {
- #include <limits.h>
- #include <string.h>
- #include "netcdf.h"
-! }
- typedef unsigned char ncbyte;
-
- #define NC_UNSPECIFIED ((nc_type)0)
-***************
-*** 82,88 ****
- virtual int invalid( void ) const; \
- private: \
- TYPE* the_values; \
-! ostream& print(ostream&) const; \
- };
-
- #define NcTypeEnum(TYPE) makename2(_nc__,TYPE)
---- 79,85 ----
- virtual int invalid( void ) const; \
- private: \
- TYPE* the_values; \
-! std::ostream& print(std::ostream&) const; \
- };
-
- #define NcTypeEnum(TYPE) makename2(_nc__,TYPE)
-***************
-*** 218,228 ****
-
- #define as_string_implement(TYPE) \
- char* NcVal(TYPE)::as_string( long n ) const \
-! { \
- char* s = new char[32]; \
-! ostrstream ostr(s, sizeof(s)); \
-! ostr << the_values[n] << ends; \
-! return s; \
- }
-
- class NcValues // ABC for value blocks
---- 215,227 ----
-
- #define as_string_implement(TYPE) \
- char* NcVal(TYPE)::as_string( long n ) const \
-! { \
- char* s = new char[32]; \
-! ostringstream ostr; \
-! ostr << the_values[n]; \
-! strncpy(s,ostr.str().c_str(),32); \
-! s[31]=0; \
-! return s; \
- }
-
- class NcValues // ABC for value blocks
-***************
-*** 232,238 ****
- NcValues(NcType, long);
- virtual ~NcValues( void );
- virtual long num( void );
-! virtual ostream& print(ostream&) const = 0;
- virtual void* base( void ) const = 0;
- virtual int bytes_for_one( void ) const = 0;
-
---- 231,237 ----
- NcValues(NcType, long);
- virtual ~NcValues( void );
- virtual long num( void );
-! virtual std::ostream& print(std::ostream&) const = 0;
- virtual void* base( void ) const = 0;
- virtual int bytes_for_one( void ) const = 0;
-
-***************
-*** 252,258 ****
- protected:
- NcType the_type;
- long the_number;
-! friend ostream& operator<< (ostream&, const NcValues&);
- };
-
- declare(NcValues,ncbyte)
---- 251,257 ----
- protected:
- NcType the_type;
- long the_number;
-! friend std::ostream& operator<< (std::ostream&, const NcValues&);
- };
-
- declare(NcValues,ncbyte)
-*** cxx/ncvalues.cpp.orig 2002-07-31 03:12:52.000000000 +0930
---- cxx/ncvalues.cpp 2002-07-31 03:13:56.000000000 +0930
-***************
-*** 7,15 ****
- * $Header: /var/cvsroot/gentoo-x86/sci-libs/netcdf/files/gcc3-gentoo.patch,v 1.1 2004/12/28 18:29:26 ribosome Exp $
- *********************************************************************/
-
-! #include <iostream.h> // for debugging
- #include "ncvalues.h"
-
- NcValues::NcValues( void ) : the_number(0), the_type(ncNoType)
- {}
-
---- 7,17 ----
- * $Header: /var/cvsroot/gentoo-x86/sci-libs/netcdf/files/gcc3-gentoo.patch,v 1.1 2004/12/28 18:29:26 ribosome Exp $
- *********************************************************************/
-
-! #include <iostream> // for debugging
- #include "ncvalues.h"
-
-+ using namespace std;
-+
- NcValues::NcValues( void ) : the_number(0), the_type(ncNoType)
- {}
-
-***************
-*** 304,310 ****
-
- ostream& NcValues_float::print(ostream& os) const
- {
-! long save=os.flags();
- os.precision(7);
- for(int i = 0; i < the_number - 1; i++)
- os << the_values[i] << ", ";
---- 306,312 ----
-
- ostream& NcValues_float::print(ostream& os) const
- {
-! ios::fmtflags save=os.flags();
- os.precision(7);
- for(int i = 0; i < the_number - 1; i++)
- os << the_values[i] << ", ";
-***************
-*** 316,322 ****
-
- ostream& NcValues_double::print(ostream& os) const
- {
-! long save=os.flags();
- os.precision(15);
- for(int i = 0; i < the_number - 1; i++)
- os << the_values[i] << ", ";
---- 318,324 ----
-
- ostream& NcValues_double::print(ostream& os) const
- {
-! ios::fmtflags save=os.flags();
- os.precision(15);
- for(int i = 0; i < the_number - 1; i++)
- os << the_values[i] << ", ";
-*** cxx/netcdfcpp.h.orig 2002-07-31 03:07:35.000000000 +0930
---- cxx/netcdfcpp.h 2002-07-31 03:07:56.000000000 +0930
-***************
-*** 154,160 ****
- virtual ~NcDim( void );
-
- // to construct dimensions, since constructor is private
-! friend NcFile;
- };
-
-
---- 154,160 ----
- virtual ~NcDim( void );
-
- // to construct dimensions, since constructor is private
-! friend class NcFile;
- };
-
-
-***************
-*** 357,363 ****
- void init_cur( void );
-
- // to make variables, since constructor is private
-! friend NcFile;
- };
-
-
---- 357,363 ----
- void init_cur( void );
-
- // to make variables, since constructor is private
-! friend class NcFile;
- };
-
-
-***************
-*** 388,394 ****
- NcAtt( NcFile*, NcToken); // global attribute
-
- // To make attributes, since constructor is private
-! friend NcFile;
- friend NcAtt* NcVar::get_att( NcToken ) const;
- };
-
---- 388,394 ----
- NcAtt( NcFile*, NcToken); // global attribute
-
- // To make attributes, since constructor is private
-! friend class NcFile;
- friend NcAtt* NcVar::get_att( NcToken ) const;
- };
-
-*** cxx/nctst.cpp.orig 2002-07-31 04:00:10.000000000 +0930
---- cxx/nctst.cpp 2002-07-31 04:00:19.000000000 +0930
-***************
-*** 1,7 ****
-! #include <iostream.h>
- #include <string.h>
- #include "netcdfcpp.h"
-
- void gen(const char* path) // Generate a netCDF file
- {
- NcFile nc(path, NcFile::Replace); // Create, leave in define mode
---- 1,9 ----
-! #include <iostream>
- #include <string.h>
- #include "netcdfcpp.h"
-
-+ using namespace std;
-+
- void gen(const char* path) // Generate a netCDF file
- {
- NcFile nc(path, NcFile::Replace); // Create, leave in define mode
diff --git a/sci-libs/netcdf/files/netcdf-3.6.2-parallel-make.patch b/sci-libs/netcdf/files/netcdf-3.6.2-parallel-make.patch
new file mode 100644
index 000000000000..11b1b61214e3
--- /dev/null
+++ b/sci-libs/netcdf/files/netcdf-3.6.2-parallel-make.patch
@@ -0,0 +1,15 @@
+--- f90/Makefile.am 2007/08/04 22:02:56 1.1
++++ f90/Makefile.am 2007/08/04 22:09:55
+@@ -64,10 +64,12 @@ if UPPER_CASE_MOD
+ nodist_include_HEADERS = TYPESIZES.mod NETCDF.mod
+ TYPESIZES.mod: typeSizes.o
+ NETCDF.mod: $(NETCDF_O)
++$(NETCDF_O): TYPESIZES.mod
+ else
+ nodist_include_HEADERS = typesizes.mod netcdf.mod
+ typesizes.mod: typeSizes.o
+ netcdf.mod: $(NETCDF_O)
++$(NETCDF_O): typesizes.mod
+ endif
+
+ # This is what we are building: a convenience library of F90 functions.