summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOlivier Fisette <ribosome@gentoo.org>2005-06-05 15:09:41 +0000
committerOlivier Fisette <ribosome@gentoo.org>2005-06-05 15:09:41 +0000
commit7476bbec1b75c6120411a2c8bbb37a3ca92cfac9 (patch)
treea32e5eac578705af79a0bd030c26e8763ac37168 /sci-libs/libqalculate/libqalculate-0.8.0.ebuild
parentrepoman: Trim trailing whitespace (diff)
downloadhistorical-7476bbec1b75c6120411a2c8bbb37a3ca92cfac9.tar.gz
historical-7476bbec1b75c6120411a2c8bbb37a3ca92cfac9.tar.bz2
historical-7476bbec1b75c6120411a2c8bbb37a3ca92cfac9.zip
Initial import. This package, along with "qalculate-gtk" and "qalculate-kde" will eventually replace the "qalculate" package.
Package-Manager: portage-2.0.51.19
Diffstat (limited to 'sci-libs/libqalculate/libqalculate-0.8.0.ebuild')
-rw-r--r--sci-libs/libqalculate/libqalculate-0.8.0.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/sci-libs/libqalculate/libqalculate-0.8.0.ebuild b/sci-libs/libqalculate/libqalculate-0.8.0.ebuild
new file mode 100644
index 000000000000..dd058a1d1f58
--- /dev/null
+++ b/sci-libs/libqalculate/libqalculate-0.8.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/libqalculate/libqalculate-0.8.0.ebuild,v 1.1 2005/06/05 15:09:41 ribosome Exp $
+
+DESCRIPTION="A modern multi-purpose calculator library"
+HOMEPAGE="http://qalculate.sourceforge.net/"
+SRC_URI="mirror://sourceforge/qalculate/${P}.tar.gz"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="nls readline"
+
+DEPEND=">=sci-libs/cln-1.1
+ dev-libs/libxml2
+ >=dev-libs/glib-2.4
+ >=media-gfx/gnuplot-3.7
+ net-misc/wget
+ nls? ( sys-devel/gettext )
+ readline? ( sys-libs/readline )"
+
+RDEPEND="dev-lang/perl
+ dev-perl/XML-Parser
+ >=dev-util/pkgconfig-0.12.0"
+
+src_compile() {
+ CONFIG="$(use_with readline)"
+ econf ${CONFIG} || die
+ emake || die
+}
+
+src_install() {
+ DOCS="AUTHORS ChangeLog NEWS README TODO"
+ einstall || die
+ dodoc ${DOCS}
+}