summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2014-02-04 10:43:39 +0000
committerJustin Lecher <jlec@gentoo.org>2014-02-04 10:43:39 +0000
commit6575aaa27b8652739c79e5926e24526477c13c98 (patch)
tree5fd37d0b2c90d2a6cd5bc95f5671630707be32a4 /sci-libs/coinor-flopcpp/coinor-flopcpp-1.1.7.ebuild
parentdrop empty *DEPEND (diff)
downloadhistorical-6575aaa27b8652739c79e5926e24526477c13c98.tar.gz
historical-6575aaa27b8652739c79e5926e24526477c13c98.tar.bz2
historical-6575aaa27b8652739c79e5926e24526477c13c98.zip
Move preparations to src_prepare
Package-Manager: portage-2.2.8-r1/cvs/Linux x86_64 Manifest-Sign-Key: 0xB9D4F231BD1558AB!
Diffstat (limited to 'sci-libs/coinor-flopcpp/coinor-flopcpp-1.1.7.ebuild')
-rw-r--r--sci-libs/coinor-flopcpp/coinor-flopcpp-1.1.7.ebuild7
1 files changed, 4 insertions, 3 deletions
diff --git a/sci-libs/coinor-flopcpp/coinor-flopcpp-1.1.7.ebuild b/sci-libs/coinor-flopcpp/coinor-flopcpp-1.1.7.ebuild
index 4f700ff893c6..1bf74a42340a 100644
--- a/sci-libs/coinor-flopcpp/coinor-flopcpp-1.1.7.ebuild
+++ b/sci-libs/coinor-flopcpp/coinor-flopcpp-1.1.7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/coinor-flopcpp/coinor-flopcpp-1.1.7.ebuild,v 1.3 2014/02/04 09:25:41 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/coinor-flopcpp/coinor-flopcpp-1.1.7.ebuild,v 1.4 2014/02/04 10:37:08 jlec Exp $
EAPI=5
@@ -28,14 +28,15 @@ DEPEND="${RDEPEND}
S="${WORKDIR}/${MYPN}-${PV}/FlopCpp"
src_prepare() {
+ # needed for the --with-coin-instdir
+ dodir /usr
sed -i \
-e "s:lib/pkgconfig:$(get_libdir)/pkgconfig:g" \
configure || die
autotools-utils_src_prepare
}
+
src_configure() {
- # needed for the --with-coin-instdir
- dodir /usr
local myeconfargs=(
--enable-dependency-linking
--with-coin-instdir="${ED}"/usr